welcome

We have included the following drivers and libraries on the Product Reference CD-ROM shipped with your Agilent N6700 and N6705A.

  • IVI-COM Drivers

  • VXIplug&play Drivers

Agilent IO Libraries are included on a separate Automation-Ready CD-ROM, which is also shipped with your Agilent N6700 and N6705A.

You can also download the drivers and libraries from the Agilent Developer Network at adn.tm.agilent.com.

The Agilent N6700 and N6705A have a built-in Web server that lets you control them directly from an internet browser on your computer. With the Web server, you can access the front panel control functions including the LAN configuration parameters.

The built-in Web server only operates over the LAN interface. It requires Internet Explorer 5+ or Netscape 6.2+. You also need the Java (Sun) plug-in. This is included in the Java Runtime Environment. Refer to Sun Microsystem’s website http://www.sun.com.

The Web server is enabled when shipped. To launch the Web server:

  1. Establish a LAN interface connection from your computer to the Agilent N6700.

  2. Open the internet browser on your computer. In the Tools menu, under Internet Options, select Connections, then LAN Settings, and make sure that the Bypass proxy server for local addresses box is checked.

  3. To launch the Web server, enter the instrument’s IP address or fully-qualified hostname into the browser’s Address field.

  4. To begin controlling your instrument, click on the Browser Web Control button in the navigation bar on the left.

  5. For additional Help, click on the Help with this Page button.

The following documents are available in PDF format on the Product Reference CD-ROM shipped with the Agilent N6700.

  • N6700 and N6705A Programmer’s Reference (PDF version of this Help file)

  • N6700 User's Guide and N6705A User’s Guide

  • N6700 Service Guide and N6705A Service Guide

You can also download these documents from the Agilent web site at www.agilent.com/find/N6700.

Agilent Technologies
N6700 Modular Power System and
N6705A DC Power Analyzer
Programmer's Reference

Printable PDF Version

This Help file contains reference information to help you program the Agilent N6700 Modular Power System and the Agilent N6705A DC Power Analyzer over the remote interface using the SCPI programming language. The Agilent N6700 and N6705A support the SCPI programming language on all of its remote I/O interfaces.

Introduction to the SCPI Language

Commands A-Z

Commands by Subsystem

Command Quick Reference

Non-Volatile Settings

Reset Settings (*RST)

Programming Examples

SCPI Error Messages

Agilent 662xA Compatibility

Additional Information

For additional information on the Agilent N6700 and N6705A, be sure to browse the Product Reference CD-ROM shipped with the instrument or go to www.agilent.com/find/N6700.

Instrument Drivers and IO Libraries

Agilent N6700 Web Server

Agilent N6700 Product Documentation

Contact Agilent Technologies

© Agilent Technologies, Inc. 2005 - 2007

Version 2.0


Introduction to the SCPI Language

This topic contains a brief introduction to the SCPI programming language.

SCPI (Standard Commands for Programmable Instruments) is a programming language for controlling test and measurement instruments. SCPI provides instrument control with a standardized command syntax and style, as well as a standardized data interchange format.

SCPI Commands

SCPI has two types of commands, common and subsystem.

  • Common commands are defined by the IEEE 488.2 standard to perform common interface functions such as reset, status, and synchronization. All common commands consist of a three-letter mnemonic preceded by an asterisk: *RST *IDN? *SRE 8. Common commands are located in the IEEE-488.2 Common Commands group.

  • Subsystem commands perform specific power system functions. They can be a single command or a group of commands. The groups are comprised of commands that extend one or more levels below the root. Subsystem commands are arranged alphabetically according to the function they perform. The following figure shows a portion of a subsystem command tree, from which you access the commands located along the various paths. Some [optional] commands have been included for clarity.

:OUTput
[:STATe] <Bool>,(@<chanlist>)
:DELay
:FALL <NRf+>,(@<chanlist>)
:RISE <NRf+>,(@<chanlist>)
:INHibit
:MODE <mode>

:STATus
:OPERation
[:EVENt]? (@<chanlist>)
:CONDition? (@<chanlist>)

Multiple Commands in a Message

Multiple SCPI commands can be combined and sent as a single message with one message terminator. There are two important considerations when sending several commands within a single message:

  • Use a semicolon to separate commands within a message.

  • There is an implied header path that affects how commands are interpreted by the power system.

The header path can be thought of as a string that gets inserted before each command within a message. For the first command in a message, the header path is a null string. For each subsequent command the header path is defined as the characters that make up the headers of the previous command in the message up to and including the last colon separator. An example of a message with two commands is:

OUTPut:STATe ON,(@1);PROTection:CLEar (@1)

which shows the use of the semicolon separating the two commands, and also illustrates the header path concept. Note that with the second command, the leading header "OUTPut" was omitted because after the "OUTPut:STATe ON" command, the header path became defined as "OUTPut" and thus the instrument interpreted the second command as:

OUTPut:PROTection:CLEar (@1)

In fact, it would have been syntactically incorrect to include the "OUTPut" explicitly in the second command, since the result after combining it with the header path would be:

OUTPut:OUTPut:PROTection:CLEar (@1)

which is incorrect.

Moving Among Subsystems

In order to combine commands from different subsystems, you need to be able to reset the header path to a null string within a message. You do this by beginning the command with a colon (:), which discards any previous header path. For example, you could clear the output protection and check the status of the Operation Condition register in one message by using a root specifier as follows:

OUTPut:PROTection:CLEar (@1);:STATus:OPERation:CONDition? (@1)

The following message shows how to combine commands from different subsystems as well as within the same subsystem:

VOLTage:LEVel 7.5,(@1);PROTection 10,(@1);:CURRent:LEVel 0.5,(@1)

Note the use of the optional header LEVel to maintain the correct path within the subsystems, and the use of the root specifier to move between subsystems.

Including Common Commands

You can combine common commands with subsystem commands in the same message. Treat the common command as a message unit by separating it with a semicolon (the message unit separator). Common commands do not affect the header path; you may insert them anywhere in the message.

OUTPut OFF,(@1);*RCL 1;OUTPut ON,(@1)

Using Queries

Observe the following precautions with queries:

  • Add a blank space between the query indicator (?) and any subsequent parameter such as a channel list.

  • Allocate the proper number of variables for the returned data.

  • Read back all the results of a query before sending another command to the power system. Otherwise, a Query Interrupted error will occur and the unreturned data will be lost.

Coupled Commands

When commands are coupled it means that the value sent by one command is affected by the settings of another command. The following commands are coupled:

[SOURce:]CURRent and [SOURce:]CURRent:RANGe

[SOURce:]VOLTage and [SOURce:]VOLTage:RANGe

If a range command is sent that places an output on a range with a lower maximum setting than the present level, an error is generated. This also occurs if a level is programmed with a value too large for the present range.

These types of errors can be avoided by sending the both level and range commands as a set, in the same SCPI message. For example,

CURRent 10,(@1);CURRent:RANGe 10,(@1)<NL>

will always be correct because the commands are not executed until the message terminator is received. Because the range and setting information is received as a set, no range/setting conflict occurs.

SCPI Messages

There are two types of SCPI messages, program and response.

  • A program message consists of one or more properly formatted SCPI commands sent from the controller to the power system. The message, which may be sent at any time, requests the power system to perform some action.

  • A response message consists of data in a specific SCPI format sent from the power system to the controller. The power system sends the message only when commanded by a program message "query."

The following figure illustrates the SCPI message structure.

The Message Unit

The simplest SCPI command is a single message unit consisting of a command header (or keyword) followed by a message terminator such as a newline. The message unit may include a parameter after the header. The parameter can be numeric or a string.

*RST<NL>

VOLTage 20,(@1)<NL>

Channel List Parameter

The channel parameter is required to address one or more channels. It has the following syntax:

(@<channel> [,<channel>][,<channel>][,<channel>])

You can also specify a range of sequential channels as follows:

(@<start_channel>:<end_channel>)

For example, (@2) specifies channel 2 and (@1:3) specifies channels 1 through 3. The channel list, shown as <chanlist> throughout this document, must be preceded with the @ symbol and must be enclosed in parentheses (). A maximum of 4 channels may be specified through a combination of single channels and ranges. Query results are channel list order-sensitive. Results are returned in the order they are specified in the list.

When adding a channel list parameter to a query, you must include a space character between the query indicator (?) and the channel list parameter. Otherwise error –103, Invalid separator will occur.

Headers

Headers, also referred to as keywords, are instructions recognized by the power system. Headers may be in the long form or in the short form. In the long form, the header is completely spelled out, such as VOLTAGE, STATUS, and DELAY. In the short form, the header has only the first three or four letters, such as VOLT, STAT, and DEL.

When the long form notation is used in this document, the capital letters indicate the equivalent short form. For example, MEASure is the long form, and MEAS indicates the short form equivalent.

Query Indicator

Following a header with a question mark turns it into a query (VOLTage?, VOLTage:TRIGgered?). The ? is the query indicator. If a query contains parameters, place the query indicator at the end of the last header, before the parameters.

VOLTage:TRIGgered? MAX,(@1)

Message Unit Separator

When two or more message units are combined into a compound message, separate the units with a semicolon.

STATus:OPERation? (@1);QUEStionable? (@1)

Root Specifier

When it precedes the first header of a message unit, the colon becomes the root specifier. It tells the command parser that this is the root or the top node of the command tree.

Message Terminator

A terminator informs SCPI that it has reached the end of a message. The following messages terminators are permitted:

  • newline <NL>, which is ASCII decimal 10 or hex 0A

  • end or identify <END> (EOI with ATN false)

  • both of the above <NL><END>

  • also <CR><NL>

In the examples used in this document, there is an assumed message terminator at the end of each message.

SCPI Conventions and Data Formats

The following SCPI conventions are used throughout this guide.

Angle brackets < > | Items within angle brackets are parameter abbreviations. For example, <NR1> indicates a specific form of numerical data.
Vertical bar | | Vertical bars separate alternative parameters. For example, VOLT | CURR indicates that either "VOLT" or "CURR" can be used as a parameter.
Square brackets [ ] | Items within square brackets are optional. The representation [SOURce:]VOLTage means that SOURce: may be omitted.
Parentheses ( ) | Items within parentheses are used in place of the usual parameter types to specify a channel list. The notation (@1:3) specifies a channel list that includes channels 1, 2, and 3. The notation (@1,3) specifies a channel list that includes only channels 1 and 3.
Braces { } | Braces indicate parameters that may be repeated zero or more times. It is used especially for showing arrays. The notation <A>{,<B>} shows that parameter "A" must be entered, while parameter "B" may be omitted or may be entered one or more times.

Data programmed or queried from the power system is ASCII. The data may be numerical or character string.

<NR1> | Digits with an implied decimal point assumed at the right of the least-significant digit. Example: 273
<NR2> | Digits with an explicit decimal point. Example: 27.3
<NR3> | Digits with an explicit decimal point and an exponent. Example: 2.73E+02
<NRf> | Extended format that includes <NR1>, <NR2> and <NR3>. Examples: 273 27.3 2.73E+02
<NRf+> | Expanded decimal format that includes <NRf> and MIN, MAX. Examples: 273 27.3 2.73E+02 MAX. MIN and MAX are the minimum and maximum limit values that are implicit in the range specification for the parameter.
<Bool> | Boolean Data. Can be numeric (0, 1), or named (OFF, ON).
<SPD> | String Program Data. Programs string parameters enclosed in single or double quotes.
<SRD> | String Response Data. Returns string parameters enclosed in single or double quotes.
<CPD> | Character Program Data. Programs discrete parameters. Accepts both the short form and the long form.
<CRD> | Character Response Data. Returns discrete parameters. Only the short form of the parameter is returned.
<AARD> | Arbitrary ASCII Response Data. Permits the return of undelimited 7-bit ASCII. This data type has an implied message terminator.
<Block> | Arbitrary Block Response Data. Permits the return of definite length and indefinite length arvbitrary response dataI. This data type has an implied message terminator.

The SCPI language allows the use of suffixes and multipliers.

Class | Suffix | Unit | Unit with Multiplier
Current | A | ampere | MA (milliampere)
Amplitude | V | volt | MV (millivolt)
Time | S | second | MS (millisecond)
Common Multipliers |  |  |
1E3 | K | kilo |
1E-3 | M | milli |
1E-6 | U | micro |

SCPI Command Completion

SCPI commands sent to the power system are processed either sequentially or in parallel. Sequential commands finish execution before a subsequent command begins. Parallel commands allow other commands to begin executing while the parallel command is still executing.

The following is a list of parallel commands. You should use some form of command synchronization as discussed in this section before assuming that these commands have completed.

OUTPut:STATe | INITiate
VOLTage | OUTPut:PROTection:CLEar
CURRent | FUNCtion:MODE

The *WAI, *OPC, and *OPC? common commands provide different ways of indicating when all transmitted commands, including any parallel ones, have completed their operations. Some practical considerations for using these commands are as follows:

*WAI - prevents the power system from processing subsequent commands until all pending operations are completed. For example, the *WAI command can be used to make a voltage measurement after an output on command has completed:

OUTPut ON,(@1);*WAI;:MEASure:VOLTage? (@1)

*OPC? - places a 1 in the Output Queue when all pending operations have completed. Because it requires your program to read the returned value before executing the next program statement, *OPC? can be used to cause the controller to wait for commands to complete before proceeding with its program.

*OPC - sets the OPC status bit when all pending operations have completed. Since your program can read this status bit on an interrupt basis, *OPC allows subsequent commands to be executed.

The trigger subsystem must be in the Idle state for the status OPC bit to be true. As far as triggers are concerned, OPC is false whenever the trigger subsystem is in the Initiated state.

Device Clear

You can send a Device Clear at any time to abort a SCPI command that may be hanging up the GPIB interface. Device Clear clears the input and output buffers of the power system and prepares the power system to accept a new command string. The status registers, error queue, and all configuration states are left unchanged by Device Clear. The following statement shows how to send a device clear over the GPIB interface using Agilent Basic:

CLEAR 705 IEEE-488 Device Clear


Commands A-Z

A – E | F – J | K – O | P – T | U – Z

Hold the mouse cursor over a command to view the full syntax statement.

A

ABORt:ACQuire

ABORt:DLOG (N6705A only)

ABORt:TRANsient

C

*CLS

CALibrate:CURRent:[LEVel]

CALibrate:CURRent:MEASure

CALibrate:CURRent:PEAK

CALibrate:DATA

CALibrate:DATE

CALibrate:DATE?

CALibrate:DPRog

CALibrate:LEVel

CALibrate:PASSword

CALibrate:SAVE

CALibrate:STATe

CALibrate:STATe?

CALibrate:VOLTage[:LEVel]

CALibrate:VOLTage:CMRR

CALibrate:VOLTage:MEASure

D

DISPlay[:WINDow]:VIEW

DISPlay[:WINDow]:VIEW?

E

*ESE

*ESE?

*ESR?

F

FETCh:ARRay:CURRent[:DC]?

FETCh:ARRay:VOLTage[:DC]?

FETCh[:SCALar]:CURRent[:DC]?

FETCh[:SCALar]:VOLTage[:DC]?

H

HCOPY:SDUMp:DATA? (N6705A only)

I

*IDN?

INITiate[:IMMediate]:ACQuire

INITiate[:IMMediate]:DLOG (N6705A only)

INITiate[:IMMediate]:TRANsient

INITiate:CONTinuous:TRANsient

INITiate:CONTinuous:TRANsient?

M

MEASure:ARRay:CURRent[:DC]?

MEASure:ARRay:VOLTage[:DC]?

MEASure[:SCALar]:CURRent[:DC]?

MEASure[:SCALar]:VOLTage[:DC]?

MMEMory:ATTRibute? (N6705A only)

MMEMory:DATA[:DEFinite]? (N6705A only)

MMEMory:DELete (N6705A only)

MMEMory:EXPort:DLOG (N6705A only)

O

*OPC

*OPC?

*OPT?

OUTPut[:STATe]

OUTPut[:STATe]?

OUTPut[:STATe]:COUPle[:STATe]

OUTPut[:STATe]:COUPle[:STATe]?

OUTPut[:STATe]:COUPle:CHANnel

OUTPut[:STATe]:COUPle:CHANnel?

OUTPut[:STATe]:COUPle:DOFFset

OUTPut[:STATe]:COUPle:DOFFset?

OUTPut[:STATe]:COUPle:DOFFset:MODE (N6705A only)

OUTPut[:STATe]:COUPle:DOFFset:MODE? (N6705A only)

OUTPut[:STATe]:COUPle:MAX:DOFFset?

OUTPut[:STATe]:DELay:FALL

OUTPut[:STATe]:DELay:FALL?

OUTPut[:STATe]:DELay:RISE

OUTPut[:STATe]:DELay:RISE?

OUTPut[:STATe]:PMODe

OUTPut[:STATe]:PMODe?

OUTPut:INHibit:MODE

OUTPut:INHibit:MODE?

OUTPut:PON:STATe

OUTPut:PON:STATe?

OUTPut:PROTection:CLEar

OUTPut:PROTection:COUPle

OUTPut:PROTection:COUPle?

OUTPut:PROTection:DELay

OUTPut:PROTection:DELay?

OUTPut:RELay:POLarity

OUTPut:RELay:POLarity?

R

*RCL

*RDT?

*RST

S

*SAV

*SRE

*SRE?

*STB?

SENSe:CURRent[:DC]:RANGe

SENSe:CURRent[:DC]:RANGe?

SENSe:CURRent:CCOMpensate

SENSe:CURRent:CCOMpensate?

SENSe:DLOG:FUNCtion:CURRent (N6705A only)

SENSe:DLOG:FUNCtion:CURRent? (N6705A only)

SENSe:DLOG:FUNCtion:MINMax (N6705A only)

SENSe:DLOG:FUNCtion:MINMax? (N6705A only)

SENSe:DLOG:FUNCtion:VOLTage (N6705A only)

SENSe:DLOG:FUNCtion:VOLTage? (N6705A only)

SENSe:DLOG:OFFset (N6705A only)

SENSe:DLOG:OFFset? (N6705A only)

SENSe:DLOG:TIME (N6705A only)

SENSe:DLOG:TIME? (N6705A only)

SENSe:DLOG:TINTerval (N6705A only)

SENSe:DLOG:TINTerval? (N6705A only)

SENSe:FUNCtion

SENSe:FUNCtion?

SENSe:SWEep:OFFSet:POINts

SENSe:SWEep:OFFSet:POINts?

SENSe:SWEep:POINts

SENSe:SWEep:POINts?

SENSe:SWEep:TINTerval

SENSe:SWEep:TINTerval?

SENSe:VOLTage[:DC]:RANGe

SENSe:VOLTage[:DC]:RANGe?

SENSe:WINDow[:TYPE]

SENSe:WINDow[:TYPE]?

[SOURce:]CURRent[:LEVel][:IMMediate]

[SOURce:]CURRent[:LEVel][:IMMediate]?

[SOURce:]CURRent[:LEVel]:TRIGgered

[SOURce:]CURRent[:LEVel]:TRIGgered?

[SOURce:]CURRent:MODE

[SOURce:]CURRent:MODE?

[SOURce:]CURRent:PROTection:STATe

[SOURce:]CURRent:PROTection:STATe?

[SOURce:]CURRent:RANGe

[SOURce:]CURRent:RANGe?

[SOURce:]DIGital:INPut:DATA?

[SOURce:]DIGital:OUTput:DATA

[SOURce:]DIGital:OUTput:DATA?

[SOURce:]DIGital:PIN<1-7>:FUNCtion

[SOURce:]DIGital:PIN<1-7>:FUNCtion?

[SOURce:]DIGital:PIN<1-7>:POLarity

[SOURce:]DIGital:PIN<1-7>:POLarity?

[SOURce:]LIST:COUNt

[SOURce:]LIST:COUNt?

[SOURce:]LIST:CURRent[:LEVel]

[SOURce:]LIST:CURRent[:LEVel]?

[SOURce:]LIST:CURRent:POINts?

[SOURce:]LIST:DWELl

[SOURce:]LIST:DWELl?

[SOURce:]LIST:DWELl:POINts?

[SOURce:]LIST:STEP

[SOURce:]LIST:STEP?

[SOURce:]LIST:TERMinate:LAST

[SOURce:]LIST:TERMinate:LAST?

[SOURce:]LIST:TOUTput:BOSTep[:DATA]

[SOURce:]LIST:TOUTput:BOSTep[:DATA]?

[SOURce:]LIST:TOUTput:EOSTep[:DATA]

[SOURce:]LIST:TOUTput:EOSTep[:DATA]?

[SOURce:]LIST:VOLTage[:LEVel]

[SOURce:]LIST:VOLTage[:LEVel]?

[SOURce:]LIST:VOLTage:POINts?

[SOURce:]POWer:LIMit

[SOURce:]POWer:LIMit?

[SOURce:]STEP:TOUTput

[SOURce:]STEP:TOUTput?

[SOURce:]VOLTage[:LEVel][:IMMediate]

[SOURce:]VOLTage[:LEVel][:IMMediate]?

[SOURce:]VOLTage[:LEVel]:TRIGgered

[SOURce:]VOLTage[:LEVel]:TRIGgered?

[SOURce:]VOLTage:MODE

[SOURce:]VOLTage:MODE?

[SOURce:]VOLTage:PROTection[:LEVel]

[SOURce:]VOLTage:PROTection[:LEVel]?

[SOURce:]VOLTage:RANGe

[SOURce:]VOLTage:RANGe?

[SOURce:]VOLTage:SENSe:SOURce (N6705A only)

[SOURce:]VOLTage:SENSe:SOURce? (N6705A only)

[SOURce:]VOLTage:SLEW[:IMMediate]

[SOURce:]VOLTage:SLEW[:IMMediate]?

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:OPERation:NTRansition

STATus:OPERation:NTRansition?

STATus:OPERation:PTRansition

STATus:OPERation:PTRansition?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:NTRansition

STATus:QUEStionable:NTRansition?

STATus:QUEStionable:PTRansition

STATus:QUEStionable:PTRansition?

SYSTem:CHANnel[:COUNt]?

SYSTem:CHANnel:MODel?

SYSTem:CHANnel:OPTion?

SYSTem:CHANnel:SERial?

SYSTem:COMMunicate:RLSTate

SYSTem:COMMunicate:RLSTate?

SYSTem:COMMunicate:TCPip:CONTrol?

SYSTem:DATE (N6705A only)

SYSTem:DATE? (N6705A only)

SYSTem:ERRor?

SYSTem:GROup:CATalog?

SYSTem:GROup:DEFine

SYSTem:GROup:DELete

SYSTem:GROup:DELete:ALL

SYSTem:PASSword:FPANel:RESet

SYSTem:REBoot

SYSTem:TIME (N6705A only)

SYSTem:TIME? (N6705A only)

SYSTem:VERSion?

T

*TRG

*TST?

TRIGger:ACQuire[:IMMediate]

TRIGger:ACQuire:SOURce

TRIGger:ACQuire:SOURce?

TRIGger:DLOG[:IMMediate] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel]? (N6705A only)

TRIGger:DLOG:CURRent:SLOPe (N6705A only)

TRIGger:DLOG:CURRent:SLOPe? (N6705A only)

TRIGger:DLOG:SOURce (N6705A only)

TRIGger:DLOG:SOURce? (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel] (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel]? (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe? (N6705A only)

TRIGger:TRANsient[:IMMediate]

TRIGger:TRANsient:SOURce

TRIGger:TRANsient:SOURce?

W

*WAI


Commands by Subsystem

ABORt Commands

CALibration Subsystem

DISPlay Commands

FETCh Subsystem

HCOPy Subsystem

IEEE-488.2 Common Commands

INITiate Subsystem

MEASure Subsystem

MMEMory Subsystem

OUTPut Subsystem

SENSe Subsystem

SOURce Subsystem

STATus Subsystem

SYSTem Commands

TRIGger Subsystem


ABORT Commands Introduction

Abort commands cancel any triggered actions.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

ABORt:ACQuire

ABORt:DLOG (N6705A only)

ABORt:TRANsient


ABORt:ACQuire

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

ABORt:ACQuire (@<chanlist>)

Description

This command cancels any initiated triggered measurements and returns the acquire trigger state back to Idle. It also resets the WTG-meas bit in the Condition Status register.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • ABORt:ACQuire is also executed at power-on and upon execution of the *RST command.

Example

The following command aborts the triggered measurement of channel 1.

ABOR:ACQ (@1)

See Also

*RST

ABORt:TRANsient


ABORt:DLOG

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

ABORt:DLOG

Description

This command stops the currently running datalog. The datalog file is retained.

This command only applies to the Agilent N6705A DC Power Analyzer.

Example

The following command stops the currently running datalog.

ABOR:DLOG


ABORt:TRANsient

S yntax | Description | Parameters | Remarks | Return Format | Example

Syntax

ABORt:TRANsient (@<chanlist>)

Description

This command cancels any initiated trigger actions and returns the transient trigger state back to Idle. ABORt:TRANsient also resets the WTG-tran bit in the Operation Condition Status register.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • If INITiate:CONTinuous:TRANsient ON has been programmed, the trigger subsystem re-initiates itself immediately after ABORt:TRANsient.

  • ABORt:TRANsient is also executed at power-on and upon execution of the *RST command.

Example

The following command aborts the triggered transient of channel 1.

ABOR:TRAN (@1)

See Also

*RST

ABORt:ACQuire

INITiate:CONtinuous:TRANsient


CALibrate Subsystem Introduction

This subsystem lets you calibrate the power system. Only one channel can be calibrated at a time.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

If calibration mode has not been enabled with CALibrate:STATe, the calibration commands will generate an error. Use CALibrate:SAVE to save any changes, otherwise all changes will be lost when you exit calibration mode.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

CALibrate:CURRent:[LEVel]

CALibrate:CURRent:MEASure

CALibrate:CURRent:PEAK

CALibrate:DATA

CALibrate:DATE

CALibrate:DATE?

CALibrate:DPRog

CALibrate:LEVel

CALibrate:PASSword

CALibrate:SAVE

CALibrate:STATe

CALibrate:STATe?

CALibrate:VOLTage[:LEVel]

CALibrate:VOLTage:CMRR

CALibrate:VOLTage:MEASure


CALibrate:CURRent[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:CURRent[:LEVel] <value>, (@<channel>)

Description

This command initiates calibration of the output current. The value that you enter selects the range that is being calibrated.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | The maximum current of the range that is being calibrated. | Required parameter
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the current of channel 1.

CAL:CURR 10.2,(@1)

See Also

CALibrate:CURRent:MEASure

CALibrate:CURRent:PEAK


CALibrate:CURRent:MEASure

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:CURRent:MEASure <value>, (@<channel>)

Description

This command initiates calibration of the current measurement range. The value that you enter selects the range that is being calibrated.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | The maximum current of the range that is being calibrated. | Required parameter
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the current measurement range of channel 1.

CAL:CURR:MEAS 10.2,(@1)

See Also

CALibrate:CURRent[:LEVel]

CALibrate:CURRent:PEAK


CALibrate:CURRent:PEAK

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:CURRent:PEAK (@<channel>)

Description

This command initiates calibration of the peak current limit.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the peak current limit of channel 1.

CAL:CURR:PEAK (@1)

See Also

CALibrate:CURRent[:LEVel]

CALibration:CURRent:MEASure


CALibrate:DATA

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:DATA <value>

Description

This command enters a calibration value that you obtain by reading an external meter. You must first select a calibration level (with CALibrate:LEVel) for the value being entered. Data values are expressed in base units - either volts or amperes, depending on which function is being calibrated.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | The measured voltage or current value. | Required parameter

Example

The following command enters a value measured by an external meter.

CAL:DATA 10.01

See Also

CALibrate:LEVel


CALibrate:DATE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:DATE <"date">, (@<channel>)

CALibrate:DATE?

Description

This command stores the date that the power module was last calibrated. The calibration date is stored in nonvolatile memory. Enter any ASCII string up to 16 characters. The query returns the date.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<"date"> | SPD | String program data. String parameters must be enclosed in single or double quotes. | Required parameter
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Remarks

  • The firmware does not interpret the string format. The information is not used by the firmware. The command is only provided to store the calibration date.

Return Format

<SRD>

The query command returns an ASCII string enclosed in double quotes. If no date is stored, an empty quoted string ("") is returned.

Example

The following command enters a date.

CAL:DATE "3/22/05",(@1)

The following query returns the calibration date.

CAL:DATE?

Typical Response: "April 3, 2005"


CALibrate:DPRog

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:DPRog (@<channel>)

Description

This command initiates calibration of the current downprogrammer.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the current downprogrammer of channel 1.

CAL:DPR (@1)


CALibrate:LEVel

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibration:LEVel <level>

Description

This command is used to advance to the next level in the calibration. P1 is the first calibration level; P2 is the second level; P3 is the third level.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<level> | CPD | P1 | P2 | P3 | Required parameter

Remarks

  • Some calibration sequences may require some settling time after sending CAL:LEV but before reading the data from the DVM and sending CAL:DATA.

Example

The following command selects the first calibration level.

CAL:LEV P1

See Also

CALibrate:DATA


CALibrate:PASSword

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:PASSword <password>

Description

This command lets you change the calibration password. The new password is automatically stored in nonvolatile memory and does not have to be stored with CALibrate:SAVE. If the password is set to 0, password protection is removed and the ability to enter calibration mode is unrestricted. The factory-default password 0 (zero).

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<password> | NRf | A numeric value up to 15 digits in length. | Required parameter

Example

The following command sets the password to a value of 1234.

CAL:PASS 1234


CALibrate:SAVE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:SAVE

Description

This command saves calibration constants in non-volatile memory after the calibration procedure has been completed. If calibration mode is exited by programming CALibration:STATe OFF without first saving the new constants, the previous constants are restored.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Example

The following command saves the calibration values.

CAL:SAVE

See Also

CALibrate:STATe


CALibrate:STATe

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:STATe <Bool>, [<password>]

CALibrate:STATe?

Description

This command enables or disables calibration mode. Calibration mode must be enabled for the power system to accept any calibration commands. The first parameter specifies the ON (1) or OFF (0) state. The second parameter is the password.

A numeric password is required if calibration mode is being enabled and the existing password is not 0. If the password is not entered or is incorrect, an error is generated and the calibration mode remains disabled.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<password> | NRf | A numeric value up to 15 digits in length. | Required if password not 0

Remarks

  • When the calibration state is changed from enabled to disabled, new calibration constants are lost unless they have already been stored with CALibrate:SAVE.

Return Format

<NR1>

The query returns only the calibration state, not the password. It returns either 0 (OFF), or 1 (ON).

Example

The following command enables calibration mode; the password is 1234.

CAL:STAT ON, 1234

The following query returns the calibration state.

CAL:STAT?

Typical Response: 1

See Also

CALibrate:SAVE


CALibrate:VOLTage[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:VOLTage[:LEVel] <value>, (@<channel>)

Description

This command initiates calibration of the output voltage. The value that you enter selects the range that is being calibrated.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | The maximum voltage of the range that is being calibrated. | Required parameter
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the voltage of channel 1.

CAL:VOLT 51,(@1)

See Also

CALibrate:VOLTage:MEASure

CALibrate:VOLTage:CMRR


CALibrate:VOLTage:CMRR

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:VOLTage:CMRR (@<channel>)

Description

This command initiates calibration of the voltage common mode rejection ratio.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the voltage common mode rejection ratio of channel 1.

CAL:VOLT:CMRR (@1)

See Also

CALibrate:VOLTage[:LEVel]

CALibration:VOLTage:MEASure


CALibrate:VOLTage:MEASure

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

CALibrate:VOLTage:MEASure <value>, (@<channel>)

Description

This command initiates calibration of the voltage measurement range. The value that you enter selects the range that is being calibrated.

Refer to Chapter 2 in the Service Guide for a detailed description of the calibration procedure.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | The maximum voltage of the range that is being calibrated. | Required parameter
<channel> | NR1 | The output channel that is being calibrated. | Required parameter

Example

The following command calibrates the voltage measurement range of channel 1.

CAL:VOLT:MEAS 51,(@1)

See Also

CALibrate:VOLTage[:LEVel]

CALibrate:VOLTage:CMRR


DISPlay Commands Introduction

The Display commands let you control the front panel display.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

DISPlay[:WINDow]:VIEW

DISPlay[:WINDow]:VIEW?


DISPlay[:WINDow]:VIEW

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

DISPlay[:WINDow]:VIEW <view>

DISPlay[:WINDow]:VIEW?

Description

This command selects the output channel view of the front panel display. METER1 displays one output channel. METER4 displays all output channels up to a maximum of four.

Parameters

Name | Type | Range of Values | Default Value
<view> | <CPD> | METER1 | METER4 | METER1

Return Format

<CRD>

The query command returns METER1 or METER4.

Example

The following command sets the front panel to display only one output channel.

DISP:VIEW METER1

The following query returns the channel view of the front-panel display.

DISP:VIEW?

Typical Response: METER1


FETCh Subsystem Introduction

Fetch commands return measurement data that has been previously acquired. If you take a voltage measurement, you can fetch only voltage data. If you take a current measurement, you can fetch only current data. Use Fetch commands to return measurement data that has been synchronized with a triggered event.

Agilent Models N6761A and N6762A have simultaneous voltage and current measurement capability. In this case BOTH voltage and current are acquired, regardless of the parameter that is being measured. To return both values of a simultaneous measurement, first use the MEASure command to measure either the output voltage or current. Then use the FETCh command to return the other parameter.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

FETCh:ARRay:CURRent[:DC]?

FETCh:ARRay:VOLTage[:DC]?

FETCh[:SCALar]:CURRent[:DC]?

FETCh[:SCALar]:VOLTage[:DC]?


FETCh:ARRay:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

FETCh:ARRay:CURRent[:DC]? (@<chanlist>)

Description

This query returns an array containing the digitized output current in amperes. The data returned by the FETCh command is the result of the last measurement command or acquisition trigger. The data is valid until the next MEASure or INITiate command occurs.

The output current is digitized whenever a measurement command is sent or an acquisition trigger occurs. The sampling rate is set by SENSe:SWEep:TINTerval. The position of the trigger relative to the beginning of the data buffer is determined by SENSe:SWEep:OFFSet. The number of points returned is set by SENSe:SWEep:POINts.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command to return measurement data that has been synchronized with a triggered event.

  • Data is NOT erased from the measurement buffer when it is read by a FETch command.

  • All previous data IS erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3> [,<NR3>]

The reading is in the form +1.000000E+01. Array values are separated by commas.

Example

The following query returns the current measured on channel 1.

FETC:ARR:CURR? (@1)

See Also

FETCh:ARRay:VOLTage[:DC]?

SENSe:SWEep:TINTerval

SENSe:SWEep:OFFset:POINts

SENSe:SWEep:POINts


FETCh:ARRay:VOLTage[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

FETCh:ARRay:VOLTage[:DC]? (@<chanlist>)

Description

This query returns an array containing the digitized output voltage in volts. The data returned by the FETCh command is the result of the last measurement command or acquisition trigger. The data is valid until the next MEASure or INITiate command occurs.

The output voltage is digitized whenever a measurement command is sent or an acquisition trigger occurs. The sampling rate is set by SENSe:SWEep:TINTerval. The position of the trigger relative to the beginning of the data buffer is determined by SENSe:SWEep:OFFSet. The number of points returned is set by SENSe:SWEep:POINts.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command to return measurement data that has been synchronized with a triggered event.

  • Data is NOT erased from the measurement buffer when it is read by a FETch command.

  • All previous data IS erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3> [,<NR3>]

The reading is in the form +1.000000E+01. Array values are separated by commas.

Example

The following query returns the voltage measured on channel 1.

FETC:ARR:VOLT? (@1)

See Also

FETCh:ARRay:CURRent[:DC]?

SENSe:SWEep:TINTerval

SENSe:SWEep:OFFset:POINts

SENSe:SWEep:POINts


FETCh[:SCALar]:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

FETCh[:SCALar]:CURRent[:DC]? (@<chanlist>)

Description

This query returns the DC output current in amperes. The data returned by the FETCh command is the result of the last measurement command or acquisition trigger. The data is valid until the next MEASure or INITiate command occurs.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command to return measurement data that has been synchronized with a triggered event.

  • Data is NOT erased from the measurement buffer when it is read by a FETch command.

  • All previous data IS erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3>

The reading is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Example

The following query returns the current measured on channel 1.

FETC:CURR? (@1)

Typical Response: +1.000000E+01

See Also

FETCh[:SCALar]:VOLTage[:DC]?


FETCh[:SCALar]:VOLTage[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

FETCh[:SCALar]:VOLTage[:DC]? (@<chanlist>)

Description

This query returns the DC output voltage in volts. The data returned by the FETCh command is the result of the last measurement command or acquisition trigger. The data is valid until the next MEASure or INITiate command occurs.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command to return measurement data that has been synchronized with a triggered event.

  • Data is NOT erased from the measurement buffer when it is read by a FETch command.

  • All previous data IS erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3>

The reading is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Example

The following query returns the voltage measured on channel 1.

FETC:VOLT? (@1)

Typical Response: +5.000000E+01

See Also

FETCh[:SCALar]:CURRent[:DC]?


HCOPY Commands Introduction

HCOPY commands provide screen shots of the front panel display.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

HCOPY:SDUMp:DATA? (N6705A only)


HCOPy:SDUMp:DATA?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

HCOPy:SDUMp:DATA?

Description

This query returns the front panel LCD image formatted as a compressed GIF (graphical image file). The size of the compressed image is approximately 5k bytes.

This command only applies to the Agilent N6705A DC Power Analyzer.

Return Format

<Block>

The response is an indefinite length arbitrary binary block of the form:

#0<data-bytes>NL^END

#0 indicates the response is an indefinite length. The end of the block is a newline with EOI asserted.

Example

The following query returns the LCD image.

HCOP:SDUM:DATA?


IEEE-488 Common Commands Introduction

Common commands generally control overall power system functions, such as reset, status, and synchronization. All common commands consist of a three-letter mnemonic preceded by an asterisk: *RST *IDN? *SRE 8

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

*CLS

*ESE

*ESE?

*ESR?

*IDN?

*OPC

*OPC?

*OPT?

*RCL

*RDT?

*RST

*SAV

*SRE

*SRE?

*STB?

*TRG

*TST?

*WAI


*CLS

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*CLS

Description

This command causes the following actions on the status system:

  • Clears the Standard Event Status, Operation Status Event, and Questionable Status Event registers.

  • Clears the Status Byte and the Error Queue.

  • If *CLS immediately follows a program message terminator (<NL>), then the output queue and the MAV bit are also cleared.

For more information on the SCPI Status System, see the Status System diagram.

Example

The following command clears the event register bits.

*CLS


*ESE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*ESE <value>

*ESE?

Description

This command programs the Standard Event Status Enable register bits. The programming determines which events of the Standard Event Status Event register (see *ESR?) are allowed to set the ESB (Event Summary Bit) of the Status Byte register. A 1 in the bit position enables the corresponding event.

The query reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Required parameter.

For example, to enable bit 2 (decimal value = 4), bit 3 (decimal value = 8), and bit 7 (decimal value = 128), the corresponding decimal value would be 140 (4 + 8 + 128).

Remarks

  • The following table lists the bit definitions for the Standard Event Register.

Bit Number | Decimal Value | Definition
0 Operation Complete | 1 | All commands prior to and including *OPC have been executed.
1 Not Used | Not Used | 0 is returned.
2 Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query has been read. Or, both the input and output buffers are full.
3 Device-Dependent Error | 8 | A self-test or calibration error occurred. For a complete listing of the error messages, see SCPI Error Messages.
4 Execution Error | 16 | An execution error occurred (an error in the -200 range has been generated).
5 Command Error | 32 | A command syntax error occurred (an error in the -100 range has been generated).
6 Not Used | Not Used | 0 is returned.
7 Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.

  • All of the enabled events of the Standard Event Status Event Register are logically ORed to cause the Event Summary Bit (ESB) of the Status Byte Register to be set.

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

  • A STATus:PRESet command does not clear the bits in the Status Byte register.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 7 (decimal value = 128) are enabled, the query command will return 136.

Example

The following command enables bit 4 (decimal value = 16) in the enable register.

*ESE 16

The following query returns which bits are enabled in the register.

*ESE?

Typical Response: +16

See Also

*ESR?


*ESR?

Syntax | Descri ption | Parameters | Remarks | Return Format | Example

Syntax

*ESR?

Description

This query returns the value of the Event register of the Standard Event Status group. The Event register is a read-only register, which stores (latches) all standard events. Reading the Standard Event Status Event register clears it.

For more information on the SCPI Status System, see the Status System diagram.

Remarks

  • The following table lists the bit definitions for the Standard Event Register.

Bit Number | Decimal Value | Definition
0 Operation Complete | 1 | All commands prior to and including *OPC have been executed.
1 Not Used | Not Used | 0 is returned.
2 Query Error | 4 | The instrument tried to read the output buffer but it was empty. Or, a new command line was received before a previous query has been read. Or, both the input and output buffers are full.
3 Device-Dependent Error | 8 | A self-test or calibration error occurred (an error in the -300 range or any positive error has been generated). For a complete listing of the error messages, see SCPI Error Messages.
4 Execution Error | 16 | An execution error occurred (an error in the -200 range has been generated).
5 Command Error | 32 | A command syntax error occurred (an error in the -100 range has been generated).
6 Not Used | Not Used | 0 is returned.
7 Power On | 128 | Power has been turned off and on since the last time the event register was read or cleared.

  • To be reported to the Standard Event Register, the corresponding bits in the event register must be enabled using the *ESE command.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 7 (decimal value = 128) are enabled, the query command will return 136.

Example

The following command reads the event register (bits 3 and 4 are set).

*ESR?

Typical Response: +24

See Also

*ESE


*IDN?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*IDN?

Description

This command reads the instrument's (mainframe) identification string which contains four comma-separated fields. The first field is the manufacturer's name, the second field is the instrument model number, the third field is the serial number, and the fourth field is the firmware revision.

Agilent Technologies | Manufacturer
N67xxX | Mainframe model number
MYxxxxxxxx | Mainframe serial number if available, or zero
X.xx.xx | Revision levels of firmware

Return Format

<AARD>

The command returns an arbitrary ASCII string with four comma-separated fields. To read the string into your computer, be sure to dimension a string variable with at least 50 characters.

Example

The following query returns the instrument's identification string.

*IDN?

Typical Response: AGILENT TECHNOLOGIES,N6700B,MY00123456,B.00.00


*OPC

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*OPC

*OPC?

Description

The command is mainly used for program synchronization. It causes the instrument to set the OPC bit (bit 0) of the Standard Event Status register when the instrument has completed all pending operations sent before the *OPC command. Pending operations are complete when:

  • All commands sent before *OPC, including paralleled commands, have been completed. Most commands are sequential and are completed before the next command is executed. Commands that affect output voltage, current, or state, relays, and trigger actions are executed in parallel with subsequent commands. *OPC provides notification that all parallel commands have completed.

  • All triggered actions are completed.

The query returns 1 to the output buffer.

For more information on the SCPI Status System, see the Status System diagram.

Remarks

  • *OPC does not prevent processing of subsequent commands, but the OPC bit will not be set until all pending operations are completed.

  • *OPC? causes the instrument to place a 1 in the output buffer when all pending operations are completed. *OPC? does not suspend processing of commands.

Return Format

<NR1>

Returns 1 to the output buffer.

Example

The following command sets the operation complete bit.

*OPC

The following command waits until the completion of the current command and then sends 1 to the output buffer.

*OPC?


*OPT?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*OPT?

Description

This query requests the mainframe to identify any installed options.

Remarks

  • A 0 indicates no options are installed.

Return Format

<CRD>

The option number.

Example

The following command returns the option number.

*OPT?

Typical Response: +0


*RCL

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*RCL 0 | 1

Description

This command restores the power system to a state that was previously stored in memory locations 0 through 1 with the *SAV command. All instrument states are recalled except for the following:

  • The trigger system is set to the Idle state by an implied ABORt command (this cancels any uncompleted trigger actions).

  • Calibration is disabled by setting CALibration:STATe to OFF.

  • All list settings are set to their *RST values.

Remarks

  • The device state stored in location 0 is automatically recalled at power turn-on when the Output Power-On state is set to RCL 0.

  • You cannot recall the instrument state from a storage location that is empty or was deleted. You can only recall a state from a location that contains a previously stored state.

  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten or specifically deleted.

Example

The following command recalls the instrument state previously stored in location 1.

*RCL 1

See Also

*SAV

*RST


*RDT?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*RDT?

Description

This query returns a description of all the power modules (channels) installed in a mainframe. Semicolons separate multiple channel descriptions.

CHAN<c>:description

<c> refers to the channel number.
Description returns the model number of the power modules.

Return Format

<AARD>

The command returns an arbitrary ASCII string with up to four semicolon-separated fields. To read the string into your computer, be sure to dimension a string variable with at least 50 characters.

Example

The following query identifies the mainframe's installed power modules.

*RDT?

Typical Response: CHAN1:N6751A;CHAN2:N6752A


*RST

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*RST

Description

This command resets the volatile memory of the power system to a factory-defined state. See Factory Reset State for a complete listing of the power system's factory configuration.

Remarks

  • *RST also forces the ABORt:ACQuire and ABORt:TRANsient commands. This cancels any measurement or output trigger actions presently in process, and resets the two WTG bits in the Status Operation Condition register.

Example

The following command resets the instrument.

*RST

See Also

ABORt:ACQuire

ABORt:TRANsient


*SAV

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*SAV 0 | 1

Description

This command stores the present state of the instrument to the specified location in non-volatile memory. Up to 2 states can be stored - in locations 0 and 1. Any state previously stored in the same location will be overwritten. Use the *RCL command to retrieve instrument states. Refer to Factory Reset State for a list of instrument settings that can be saved.

This command causes a write cycle to nonvolatile memory. Nonvolatile memory has a finite maximum number of write cycles. Programs that repeatedly cause write cycles to nonvolatile memory can eventually exceed the maximum number of write cycles and cause the memory to fail.

Remarks

  • If a particular state is desired at power-on, it should be stored in location 0. It will then be automatically recalled at power turn-on if the Output Power-On state is set to RCL0.

  • List data and the calibration state is NOT saved as part of the *SAV operation. This means that all list data that is sent to the instrument will be lost when the power system is turned off.

  • Data saved in non-volatile memory, described in the Non-volatile Factory Settings, is not affected by the *SAV command.

  • A Factory Reset (*RST command) does not affect the configurations stored in memory. Once a state is stored, it remains until it is overwritten or specifically deleted.

Example

The following command stores the current instrument state in location 1.

*SAV 1

See Also

*RCL

*RST


*SRE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

*SRE <value>

*SRE?

Description

This command sets the value of the Service Request Enable register. This register determines which bits from the Status Byte register are summed to set the Master Status Summary (MSS) bit and the Request for Service (RQS) summary bit. A 1 in the bit position enables the corresponding event.

The query reads the enable register and returns a decimal value which corresponds to the binary-weighted sum of all bits set in the register.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Required parameter

For example, to enable bit 1 (decimal value = 2), bit 3 (decimal value = 8), and bit 6 (decimal value = 64), the corresponding decimal value would be 74 (2 + 8 + 64).

Remarks

  • The following table lists the bit definitions for the Status Byte Register.

Bit Number | Decimal Value | Definition
0 Not Used | Not Used | 0 is returned.
1 Not Used | Not Used | 0 is returned.
2 Error Queue not empty | 4 | One or more errors have been stored in the Error Queue (see SYSTem:ERRor? command).
3 Questionable Status summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 Message Available | 16 | Data is available in the instrument's output buffer.
5 Event Status Byte summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 Master Status summary (Request for Service) | 64 | One or more bits are set in the Status Byte Register (bits must be enabled, see *SRE command). Also used to indicate a request for service.
7 Operation Status summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).

  • All of the enabled events of the Standard Event Status Event Register are logically ORed to cause the Event Summary Bit (ESB) of the Status Byte Register to be set. All such enabled bits are then logically ORed to cause the MSS bit (bit 6) of the Status Byte Register to be set.

  • When the controller conducts a serial poll in response to SRQ, the RQS bit is cleared, but the MSS bit is not. When *SRE is cleared (by programming it with 0), the power system cannot generate an SRQ to the controller.

  • The *CLS (clear status) command will not clear the enable register but it does clear all bits in the event register.

  • A STATus:PRESet command does not clear the bits in the Status Byte register.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 7 (decimal value = 128) are enabled, the query command will return "+136".

Examples

The following command enables bit 4 (decimal value = 16) in the enable register.

*SRE 16

The following query returns which bits are enabled in the register.

*SRE?

Typical Response: +16

See Also

*STB?


*STB?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*STB?

Description

This query reads the Status Byte register, which contains the status summary bits and the Output Queue MAV bit. The Status Byte register is a read-only register and the bits are not cleared when it is read.

For more information on the SCPI Status System, see the Status System diagram.

Remarks

  • The following table lists the bit definitions for the Status Byte Register.

Bit Number | Decimal Value | Definition
0 Not Used | Not Used | 0 is returned.
1 Not Used | Not Used | 0 is returned.
2 Error Queue not empty | 4 | One or more errors have been stored in the Error Queue (see SYSTem:ERRor? command).
3 Questionable Status summary | 8 | One or more bits are set in the Questionable Data Register (bits must be enabled, see STATus:QUEStionable:ENABle command).
4 Message Available | 16 | Data is available in the instrument's output buffer.
5 Event Status Byte summary | 32 | One or more bits are set in the Standard Event Register (bits must be enabled, see *ESE command).
6 Master Status summary (Request for Service) | 64 | One or more bits are set in the Status Byte Register (bits must be enabled, see *SRE command). Also used to indicate a request for service.
7 Operation Status summary | 128 | One or more bits are set in the Standard Operation Register (bits must be enabled, see STATus:OPERation:ENABle command).

  • The input summary bits are cleared when the appropriate event registers are read. The MAV bit is cleared at power-on, by *CLS, or when there is no more response data available.

  • A serial poll also returns the value of the Status Byte register, except that bit 6 returns Request for Service (RQS) instead of Master Status Summary (MSS). A serial poll clears RQS, but not MSS. When MSS is set, it indicates that the power system has one or more reasons for requesting service.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 1 (decimal value = 2) and bit 4 (decimal value = 16) are set (and the corresponding bits are enabled), this command will return 18.

Example

The following command reads the condition register (bits 3 and 4 are set).

*STB?

Typical Response: +24

See Also

*SRE


*TRG

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*TRG

Description

This common command generates a trigger when the trigger subsystem has BUS selected as its source. The command has the same affect as the Group Execute Trigger (<GET>) command.

Example

The following command generates a trigger.

*TRG

See Also

ABORt:ACQuire

ABORt:TRANsient

INITiate[:IMMediate]:ACQuire

INITiate[:IMMediate]:TRANsient


*TST?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*TST?

Description

This query causes the power system to do a self-test and report any errors. A 0 indicates the power system passed self-test. If all tests pass, you can have a high confidence that the instrument is operational.

Remarks

  • If one or more tests fail, a 1 is returned and an error is stored in the error queue. For a complete listing of the error messages related to self-test failures, see SCPI Error Messages.

  • If one or more tests fail, see the Service Guide for instructions on returning the instrument to Agilent for service.

  • *TST? also forces an *RST command.

Return Format

<NR1>

The command returns 0 (all tests passed) or 1 (one or more tests failed).

Example

The following command performs a self-test and returns a pass/fail indication.

*TST?

Typical Response: +0


*WAI

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

*WAI

Description

This command instructs the power system not to process any further commands until all pending operations are completed. Pending operations are as defined under the *OPC command.

Remarks

  • *WAI can be aborted only by sending the power system a Device Clear command.

Example

The following command waits for pending operations to complete.

*WAI

See Also

*OPC


INITiate Subsystem Introduction

Initiate commands initialize the trigger system. This enables the trigger system to receive triggers.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

Initiate Commands

Related Trigger and Abort Commands

INITiate[:IMMediate]:ACQuire

INITiate[:IMMediate]:DLOG (N6705A only)

INITiate[:IMMediate]:TRANsient

INITiate:CONTinuous:TRANsient

INITiate:CONTinuous:TRANsient?

TRIGger:ACQuire[:IMMediate]

TRIGger:ACQuire:SOURce

TRIGger:ACQuire:SOURce?

TRIGger:DLOG[:IMMediate] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel]? (N6705A only)

TRIGger:DLOG:CURRent:SLOPe (N6705A only)

TRIGger:DLOG:CURRent:SLOPe? (N6705A only)

TRIGger:DLOG:SOURce (N6705A only)

TRIGger:DLOG:SOURce? (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel] (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel]? (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe? (N6705A only)

TRIGger:TRANsient[:IMMediate]

TRIGger:TRANsient:SOURce

TRIGger:TRANsient:SOURce?

ABORt:ACQuire

ABORt:DLOG (N6705A only)

ABORt:TRANsient


INITiate[:IMMediate]:ACQuire

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

INITiate[:IMMediate]:ACQuire (@<chanlist>)

Description

This command enables the measurement trigger system. When a measurement trigger is initiated, an event on a selected trigger source causes the specified triggering action to occur. If the trigger system is not initiated, all triggers are ignored.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • It takes a few milliseconds for the power supply to be ready to receive a trigger signal after receiving the INITiate:ACQuire command, and it can take longer if the value of SENSe:SWEep:OFFSet is negative.

  • If a trigger occurs before the trigger system is ready for it, the trigger will be ignored. The user can test the WTG_meas bit in the operation status register to know when the power supply is ready to receive a trigger after initiating.

Example

The following command initiates the measurement trigger system on channel 1.

INIT:ACQ (@1)

See Also

INITiate[:IMMediate]:TRANsient

ABORt:ACQuire


INITiate[:IMMediate]:DLOG

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

INITiate[:IMMediate]:DLOG <"filename">

Description

This command starts a dialog. The filename in which to save the data should be the full path and filename. All data log files must have the extension .dlog

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<"filename"> | SPD | Filename and path must be enclosed in single or double quotes. | Required parameter

Example

The following command starts the data log and creates a file named data1.dlog in the instrument's internal file system.

INIT:DLOG "internal:\data1.dlog"

See Also

TRIGger:DLOG[:IMMediate]

ABORt:DLOG


INITiate[:IMMediate]:TRANsient

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

INITiate[:IMMediate]:TRANsient (@<chanlist>)

Description

This command enables the transient trigger system. When a transient or output trigger is initiated, an event on a selected trigger source causes the specified triggering action to occur. If the trigger system is not initiated, all triggers are ignored.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Example

The following command initiates the transient trigger system on channel 1.

INIT:TRAN (@1)

See Also

INITiate[:IMMediate]:ACQuire

ABORt:TRANsient


INITiate:CONTinuous:TRANsient

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

INITiate:CONTinuous:TRANsient <Bool>, (@<chanlist>)

INITiate:CONTinuous:TRANsient? (@<chanlist>)

Description

This command continuously initiates the output trigger system. The enabled state is ON (1); the disabled state is OFF (0).

With continuous triggering disabled, the output trigger system must be initiated for each trigger using the INITiate:TRANsient command.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if continuous transients are disabled (OFF), and 1 if continuous transients are enabled (ON).

Example

The following command continually initiates the transient trigger system on channel 1.

INIT:CONT:TRAN ON,(@1)

The following query returns the continuous transient trigger state.

INIT:CONT:TRAN? (@1)

Typical Response: 0


MEASure Subsystem Introduction

Measure commands measure the output voltage or current. They trigger the acquisition of new data before returning the reading. Measurements are performed by digitizing the instantaneous output voltage or current for a specified measurement time, storing the results in a buffer, and calculating the average value. Use Measure commands when the measurement does not need to be synchronized with any other event.

Agilent Models N6761A and N6762A have simultaneous voltage and current measurement capability. In this case BOTH voltage and current are acquired, regardless of the parameter that is being measured. To return both values of a simultaneous measurement, first use the MEASure command to measure either the output voltage or current. Then use the FETCh command to return the other parameter.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

MEASure:ARRay:CURRent[:DC]?

MEASure:ARRay:VOLTage[:DC]?

MEASure[:SCALar]:CURRent[:DC]?

MEASure[:SCALar]:VOLTage[:DC]?


MEASure:ARRay:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:ARRay:CURRent[:DC]? (@<chanlist>)

Description

This query initiates and triggers a measurement and returns an array containing the digitized output current in amperes. The sampling rate is set by SENSe:SWEep:TINTerval. The position of the trigger relative to the beginning of the data buffer is determined by SENSe:SWEep:OFFSet:POINTs. The number of points returned is set by SENSe:SWEep:POINts.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command when the measurement does not need to be synchronized with any other event.

  • All previous data is erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3> [,<NR3>]

The reading is in the form +1.000000E+01. Array values responses are separated by commas.

Example

The following query returns the current measured on channel 1.

MEAS:ARR:CURR? (@1)

See Also

MEASure:ARRay:VOLTage[:DC]?

SENSe:SWEep:TINTerval

SENSe:SWEep:OFFset:POINts

SENSe:SWEep:POINts


MEASure:ARRay:VOLTage[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure:ARRay:VOLTage[:DC]? (@<chanlist>)

Description

This query initiates and triggers a measurement and returns an array containing the digitized output voltage in volts. The sampling rate is set by SENSe:SWEep:TINTerval. The position of the trigger relative to the beginning of the data buffer is determined by SENSe:SWEep:OFFSet:POINts. The number of points returned is set by SENSe:SWEep:POINts.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command when the measurement does not need to be synchronized with any other event.

  • All previous data is erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3> [,<NR3>]

The reading is in the form +1.000000E+01. Array values are separated by commas.

Example

The following query returns the voltage measured on channel 1.

MEAS:ARR:VOLT? (@1)

See Also

MEASure:ARRay:CURRent[:DC]?

SENSe:SWEep:TINTerval

SENSe:SWEep:OFFset:POINts

SENSe:SWEep:POINts


MEASure[:SCALar]:CURRent[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure[:SCALar]:CURRent[:DC]? (@<chanlist>)

Description

This query initiates and triggers a measurement, and returns the DC output current in amperes. The default time interval and number of points settings yield a measurement time of 21 milliseconds per reading (1024 data points at 20.48 microsecond intervals). The default windowing function is Rectangular.

The time interval, number of points, and windowing function can be programmed on models N6761A/N6762A, and on models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command when the measurement does not need to be synchronized with any other event.

  • All previous data is erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3>

The reading is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Example

The following query returns the voltage measured on channel 1.

MEAS:CURR? (@1)

Typical Response: +1.000000E+01

See Also

MEASure[:SCALar]:VOLTage[:DC]?


MEASure[:SCALar]:VOLTage[:DC]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MEASure[:SCALar]:VOLTage[:DC]? (@<chanlist>)

Description

This query initiates and triggers a measurement, and returns the DC output voltage in volts. The default time interval and number of points settings yield a measurement time of 21 milliseconds per reading (1024 data points at 20.48 microsecond intervals). The default windowing function is Rectangular.

The time interval, number of points, and windowing function can be programmed on models N6761A/N6762A, and on models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use this command when the measurement does not need to be synchronized with any other event.

  • All previous data is erased from the measurement buffer when a MEASurement or an INITiate command is executed.

Return Format

<NR3>

The reading is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Example

The following query returns the voltage measured on channel 1.

MEAS:VOLT? (@1)

Typical Response: +5.000000E+01

See Also

MEASure[:SCALar]:CURRent[:DC]?


MMEMory Subsystem Introduction

MMEMory commands provide mass storage capability for output measurement data. The mass storage may be either internal or external to the instrument. The mass storage device is selected using the full path embedded within the filename. The filename parameter is a string.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

MMEMory:ATTRibute? (N6705A only)

MMEMory:DATA[:DEFinite]? (N6705A only)

MMEMory:DELete (N6705A only)

MMEMory:EXPort:DLOG (N6705A only)


MMEMory:ATTRibute?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MMEMory:ATTRibute? <"object">, <"attribute">

Description

This query returns the attributes of a file system drive or of an individual file.

"INTernal:" | This object specifies the instrument's internal drive.
"EXTernal:" | This object specifies the instrument's USB drive.
"<filename>" | The filename object should be the full path and filename.
"DriveCapacity" | This attribute specifies the capacity of the internal or external drive in bytes. Only applies when the object is INTernal: or EXTernal:
"DriveFreeSpace" | This attribute specifies the number of free bytes on the internal or external drive. Only applies when the object is INTernal: or EXTernal:
"FileSize" | This attribute specifies the size of the file or folder. Only applies when the object is <filename>.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<"object"> | SPD | "INTernal:"|"EXTernal:"|"<filename>" Parameters must be enclosed in single or double quotes. | Required parameter
<"attribute"> | SPD | "DriveCapacity"|"DriveFreeSpace" |"FileSize" Parameters must be enclosed in single or double quotes. | Required parameter

Return Format

<SRD>

The query command returns an ASCII string enclosed in double quotes containing the value of the specified attribute, or a blank string if the name of the attribute is not valid or an error has occurred.

Examples

The following queries the internal drive description (quotes are also returned).

MMEM:ATTR? "INT:","DriveFreeSpace"

Typical Response: "63422464"

The following queries the attributes of a data log file (quotes are also returned).

MMEM:ATTR? "INT:\datalog\data1.dlog","FileSize"

Typical Response: "112770"


MMEMory:DATA[:DEFinite]?

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MMEMory:DATA[:DEFinite]? <"filename">

Description

This query returns the contents of the specified file. The filename should be the full path and filename.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<"filename"> | SPD | Filename and path must be enclosed in single or double quotes. | Required parameter

Return Format

<Block>

The response is a definite length arbitrary binary block of the form:

#<D><DD...D><data-bytes>

#<D> indicates the response is definite length, with <D> the number of digits are in the length field. <DD...D> indicates the length of the binary block containing the actual file. <data-bytes> are the contents of the file.

Examples

The following query returns the contents of a file (quotes are also returned).

MMEM:DATA? "internal:\datalog\data1.dlog"


MMEMory:DELete

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

MMEMory:DELete <"filename">

Description

This command deletes the specified file. The filename should be the full path and filename.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<"filename"> | SPD | Filename and path must be enclosed in single or double quotes. | Required parameter

Examples

The following command deletes the file named data1.dlog.

MMEM:DEL "internal:\datalog\data1.dlog"


MMEMory:EXPort:DLOG

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

MMEMory:EXPort:DLOG <"filename">

Description

This command exports a dialog file. The export filename should be the full path and filename. All data log files must have the extension .dlog

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<"filename"> | SPD | Filename and path must be enclosed in single or double quotes. | Required parameter

Example

The following command exports the data log file named data1.dlog to the external USB drive.

MMEM:EXP:DLOG "external:\data1.dlog"


OUTPut Subsystem Introduction

The Output subsystem controls the output, power-on, protection, and relay functions.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

OUTPut[:STATe]

OUTPut[:STATe]?

OUTPut[:STATe]:COUPle[:STATe]

OUTPut[:STATe]:COUPle[:STATe]?

OUTPut[:STATe]:COUPle:CHANnel

OUTPut[:STATe]:COUPle:CHANnel?

OUTPut[:STATe]:COUPle:DOFFset

OUTPut[:STATe]:COUPle:DOFFset?

OUTPut[:STATe]:COUPle:DOFFset:MODE (N6705A only)

OUTPut[:STATe]:COUPle:DOFFset:MODE? (N6705A only)

OUTPut[:STATe]:COUPle:MAX:DOFFset?

OUTPut[:STATe]:DELay:FALL

OUTPut[:STATe]:DELay:FALL?

OUTPut[:STATe]:DELay:RISE

OUTPut[:STATe]:DELay:RISE?

OUTPut[:STATe]:PMODe

OUTPut[:STATe]:PMODe?

OUTPut:INHibit:MODE

OUTPut:INHibit:MODE?

OUTPut:PON:STATe

OUTPut:PON:STATe?

OUTPut:PROTection:CLEar

OUTPut:PROTection:COUPle

OUTPut:PROTection:COUPle?

OUTPut:PROTection:DELay

OUTPut:PROTection:DELay?

OUTPut:RELay:POLarity

OUTPut:RELay:POLarity?


OUTPut[:STATe]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe] <Bool> [,NORelay], (@<chanlist>)

OUTPut[:STATe]? (@<chanlist>)

Description

This command enables or disables the specified output channel(s). The enabled state is ON (1); the disabled state is OFF (0). The state of a disabled output is a condition of zero output voltage and zero source current. If output and sense relays are installed (Option 761), the relays will open when the output is disabled and close when the output is enabled.

The optional NORelay parameter lets you turn the output state on or off and leave the state of the relays unchanged. When not specified, the relays open and close as the output is turned off and on. Relays only open and close when the output is at zero voltage; zero current.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Separate delays can be programmed for the off-to-on and the on-to-off transition using OUTPut:DELay:RISE and OUTput:DELay:FALL.

  • Because of internal circuit start-up procedures and any installed relay options, the OUTPut ON command may take between 35 and 50 milliseconds to complete its function. The OUTPut OFF command may take between 20 and 25 milliseconds to complete its function. To mitigate this built-in delay, you can program the output to zero volts rather than using the output on/off command.

Return Format

<NR1>

The query command returns 0 if the output is OFF, and 1 if the output is ON.

Example

The following command turns the output of channel 2 on.

OUTP ON,(@2)

The following query returns the output state of channel 4.

OUTP? (@4)

Typical Response: 0

See Also

OUTPut:PON:STATe

OUTPut[:STATe]:DELay:FALL

OUTPut[:STATe]:DELay:RISE


OUTPut[:STATe]:COUPle[:STATe]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:COUPle[:STATe] <Bool>

OUTPut[:STATe]:COUPle[:STATe]?

Description

This command enables or disables output coupling or synchronization between multiple output channels. When output channels have been coupled and the Digital connector pins have been properly configured, enabling this function allows you to control the output state of multiple outputs in multiple mainframes by controlling the output state of one output channel. Refer to Appendix D in the User's Guide for detailed information.

This command does not apply to the Agilent N6705A DC Power Analyzer as the function is always enabled.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF

Remarks

  • When this command is sent, all output channels in the mainframe will go to the output Off state.

  • This setting is non-volatile and not affected by *RST.

Return Format

<NR1>

The query command returns 1 if outputs are coupled, and 0 if outputs are not coupled.

Example

The following command turns output coupling on.

OUTP:COUP ON

The following query returns the output coupling state.

OUTP:COUP?

Typical Response: 0

See Also

OUTPut[:STATe]:COUPle:CHANnel

OUTPut[:STATe]:COUPle:DOFFset

[SOURce:]DIGital:PIN<1-7>:FUNCtion


OUTPut[:STATe]:COUPle:CHANnel

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:COUPle:CHANnel [<channel>{,<channel>}]

OUTPut[:STATe]:COUPle:CHANnel?

Description

This command specifies which output channels in the mainframe are controlled by the output synchronization function. The output channels that have been synchronized or coupled will turn on and off together when any one of them is turned on or off, or when a signal is received from a digital connector pin that has been configured as an On couple or an Off couple pin. Refer to Appendix D in the User's Guide for detailed information.

There can be only one set of coupled channels in a mainframe. If another coupled set is programmed, the existing set is deleted and the new set applies. If you do not specify an output channel, this command will uncouple all output channels on the mainframe.

Parameters

Name | Type | Range of Values | Default Value
<channel> | NR1 | 1 | 2 | 3 | 4 | Required parameter

Remarks

  • When this command is sent, all output channels in the mainframe will go to the output Off state.

  • This setting is non-volatile and not affected by *RST.

Return Format

<NR1>

The query command returns the channels that are coupled. Multiple responses are separated by commas.

Example

The following command couples channels 1, 2, and 4.

OUTP:COUP:CHAN 1,2,4

The following query returns the output coupling state.

OUTP:COUP:CHAN?

Typical Response: 1,2,4

See Also

OUTPut[:STATe]:COUPle[:STATe]

OUTPut[:STATe]:COUPle:DOFFset

[SOURce:]DIGital:PIN<1-7>:FUNCtion


OUTPut[:STATe]:COUPle:DOFFset

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:COUPle:DOFFset <delay>

OUTPut[:STATe]:COUPle:DOFFset?

Description

This command specifies a maximum delay offset to synchronize the output state changes. Units are in seconds. Setting this time to the maximum delay offset specified for any output channel that is being coupled will cause all of the output channels to synchronize to the turn-on times specified by OUTput:DELay:RISE. This delay only applies to coupled channels, provided OUTput:COUPle is enabled. Refer to Appendix D in the User's Guide for detailed information.

Parameters

Name | Type | Range of Values | Default Value
<delay> | NRf | 0 - 1.023 | Required parameter

Remarks

  • When this command is sent, all output channels in the mainframe will go to the output Off state.

  • This setting is non-volatile and not affected by *RST.

Return Format

<NR3>

The query command returns the programmed delay offset in the form +1.000000E+01.

Example

The following specifies a delay offset of 60 milliseconds.

OUTP:COUP:DOFF 0.06

The following query returns the delay offset.

OUTP:COUP:DOFF?

Typical Response: +6.000000E-02

See Also

OUTPut[:STATe]:COUPle[:STATe]

OUTPut[:STATe]:COUPle:CHANnel

OUTPut[:STATe]:DELay:RISE


OUTPut[:STATe]:COUPle:DOFFset:MODE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:COUPle:DOFFset:MODE <mode>

OUTPut[:STATe]:COUPle:DOFFset:MODE?

Description

This command sets the mode that determines where the output coupling delay value comes from when outputs are synchronized.

Normally, all outputs in an Agilent N6705A mainframe are included in an output on/off delay sequence. Additionally, a delay offset is automatically calculated and applied by the firmware to synchronize the output turn-on delays.

The output synchronization function lets you select specific outputs to be synchronized as well as manually specify the delay offset, which serves as a reference for the user-programmed turn-on delays. Refer to Appendix D in the User's Guide for detailed information.

AUTO | In AUTO mode, the N6705A automatically calculates the maximum delay offset value for all the output channels in the mainframe.
MANual | In MANual mode, the N6705A uses the delay offset value set by OUTPut:COUPle:DOFFSet.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<mode> | CPD | AUTO | MANual | AUTO

Remarks

  • When this command is sent, all output channels in the mainframe will go to the output Off state.

  • This setting is non-volatile and not affected by *RST.

Return Format

<CRD>

The query command returns AUTO or MAN.

Example

The following selects Manual as the delay offset mode.

OUTP:COUP:DOFF:MODE MAN

The following query returns the delay offset mode.

OUTP:COUP:DOFF:MODE?

Typical Response: MAN

See Also

OUTPut[:STATe]:COUPle:DOFFset


OUTPut[:STATe]:COUPle:MAX:DOFFset?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:COUPle:MAX:DOFFset?

Description

This query returns the largest delay offset that is required for the output channels installed in this mainframe. Refer to Appendix D in the User's Guide for detailed information.

Return Format

<NR3>

The query command returns the maximum delay offset in the form +1.000000E+01.

Example

The following query returns the maximum delay offset.

OUTP:COUP:MAX:DOFF?

Typical Response: +3.000000E-02

See Also

OUTPut[:STATe]:COUPle:DOFFset


OUTPut[:STATe]:DELay:FALL

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:DELay:FALL <delay>, (@<chanlist>)

OUTPut[:STATe]:DELay:FALL? [MIN|MAX,] (@<chanlist>)

Description

This command sets the delay in seconds that the instrument waits before disabling the specified output. It affects on-to-off transitions including changes in the OUTPut:STATe as well as transitions due to changes in the voltage range or current range. It does NOT affect transitions to off caused by protection functions. Delay times can range from 0 to 1.023 seconds in increments of 1 millisecond.

This command allows multiple output channels to turn off in sequence. Each output will not turn off until its delay time has elapsed.

Parameters

Name | Type | Range of Values | Default Value
<delay> | NRf+ | 0 - 1.023 | MIN | MAX | 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Refer to Appendix D in the User's Guide for information about output synchronization.

Return Format

<NR3>

The query command returns the programmed delay time. The reading is in the form +1.000000E+01.

Example

The following command sets a delay of 0.5 seconds before turning off the output of channel 2.

OUTP:DEL:FALL 0.5,(@2)

The following query returns the maximum allowable delay time of channel 1.

OUTP:DEL:FALL? MAX,(@1)

Typical Response: +1.023000E+00

See Also

OUTPut[:STATe]

OUTPut[:STATe]:DELay:RISE


OUTPut[:STATe]:DELay:RISE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:DELay:RISE <delay>, (@<chanlist>)

OUTPut[:STATe]:DELay:RISE? [MIN|MAX,] (@<chanlist>)

Description

This command sets the delay in seconds that the instrument waits before enabling the specified output. It affects all off-to-on transitions including changes in the OUTPut:STATe as well as transitions due to OUTPut:PROTection:CLEar. Delay times can range from 0 to 1.023 seconds in increments of 1 millisecond.

This command allows multiple output channels to turn on in sequence. Each output will not turn on until its delay time has elapsed.

Parameters

Name | Type | Range of Values | Default Value
<delay> | NRf+ | 0 - 1.023 | MIN | MAX | 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Output channel turn-on characteristics vary across the three power module types - DC Power, Autoranging, and Precision. Refer to Appendix D in the User's Guide for more information about turn-on synchronization. When several channels of the same module type are programmed off-to-on by this command, output sequencing is precisely determined by the programmed turn-on delays.

  • When outputs of different module types are sequenced using this command, there may be an additional offset of a few milliseconds from one output to another. This offset is the same for each module type and is repeatable. Once you have characterized this offset, using an oscilloscope for example, you can adjust the programmed delays to compensate for the offset and give the desired output sequencing.

  • Outputs within the same module type can also have an offset if one model has output relays (Option 761) and another does not. These offsets are also repeatable and can be compensated by adjusting the programmed delay values.

Return Format

<NR3>

The query command returns the programmed delay time. The reading is in the form +1.000000E+01.

Example

The following command sets a delay of 0.5 seconds before turning on the output of channel 2.

OUTP:DEL:RISE 0.5,(@2)

The following query returns the maximum allowable delay time of channel 1.

OUTP:DEL:RISE? MAX,(@1)

Typical Response: +1.023000E+00

See Also

OUTPut[:STATe]

OUTPut[:STATe]:DELay:FALL


OUTPut[:STATe]:PMODe

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut[:STATe]:PMODe <mode>, (@<chanlist>)

OUTPut[:STATe]:PMODe? (@<chanlist>)

Description

This command sets the preferred mode for output on or output off transitions. It allows output state transitions to be optimized for either constant voltage or constant current operation. Turn-on and turn-off overshoots are minimized for the preferred mode of operation.

VOLTage | Minimizes output on/off voltage overshoots in constant voltage operation.
CURRent | Minimizes output on/off current overshoots in constant current operation.

This command is used only with models N6761A/N6762A.

Parameters

Name | Type | Range of Values | Default Value
<mode> | CPD | VOLTage | CURRent | VOLTage
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns VOLT or CURR.

Example

The following command sets the preferred mode of channel 1 to CURRent.

OUTP:PMOD CURR,(@1)

The following query returns the setting of the preferred mode of channel 2.

OUTP:PMOD? (@2)

Typical Response: VOLT

See Also

OUTPut[:STATe]


OUTPut:INHibit:MODE

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:INHibit:MODE <mode>

OUTPut:INHibit:MODE?

Description

This command selects the mode of operation of the Inhibit input (INH). The inhibit function shuts down ALL output channels in response to an external signal on the Inhibit input. If an output channel has been turned off by OUTPut:STATe, the inhibit function does not affect the output channel while it is in the OFF state. The Inhibit mode setting is stored in non-volatile memory.

The following modes can be selected:

LATChing | Causes a logic-true transition on the Inhibit input to disable all outputs. The outputs remain disabled until the Inhibit input is returned to logic-false and the latched INH status bit is cleared by sending the OUTP:PROT:CLE command or a protection clear command from the front panel.
LIVE | Allows the enabled outputs to follow the state of the Inhibit input. When the Inhibit input is true, the outputs are disabled. When the Inhibit input is false, the outputs are re-enabled.
OFF | The Inhibit input is ignored.

Parameters

Name | Type | Range of Values | Default Value
<mode> | CPD | LATChing | LIVE | OFF | Required parameter

Return Format

<CRD>

The query command returns LATC, LIVE, or OFF.

Example

The following command sets the Inhibit Input to Live mode.

OUTP:INH:MODE LIVE

The following query returns the setting of the Inhibit Input.

OUTP:INH:MODE?

Typical Response: OFF

See Also

OUTPut[:STATe]

OUTPut:PROTection:CLEar


OUTPut:PON:STATe

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:PON:STATe <state>

OUTPut:PON:STATe?

Description

This command determines if the power-on state is set to the *RST (RST) state or the instrument state stored in memory location 0 (RCL0). The parameter is saved in non-volatile memory. Instrument states can be stored using the *SAV command.

When shipped from the factory, the *RST command is issued at power-on.

Parameters

Name | Type | Range of Values | Default Value
<state> | CPD | RST | RCL0 | Required parameter

Return Format

<CRD>

The query command returns RST or RCL0.

Example

The following command sets the power-on state to the *RST state.

OUTP:PON:STAT RST

The following query returns the setting of the power-on state.

OUTP:PON:STAT?

Typical Response: RST

See Also

*RCL

*RST

*SAV


OUTPut:PROTection:CLEar

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:PROTection:CLEar (@<chanlist>)

Description

This command clears the latched protection status that disables the output when an over-voltage, over-temperature, over-current, inhibit signal, power-fail condition, or on some models, a power-limit condition is detected.

All conditions that generate the fault must be removed before the latched status can be cleared. The output is restored to the state it was in before the fault condition occurred.

If a protection shutdown occurs during an output list, the list continues running even though the output is disabled. When the protection status is cleared and the output becomes enabled again, the output will be set to the values of the step that the list is presently at.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Example

The following command clears the latched protection status of channel 1.

OUTP:PROT:CLE (@1)

See Also

OUTPut:PROTection:COUPle

OUTPut:PROTection:DELay


OUTPut:PROTection:COUPle

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:PROTection:COUPle <Bool>

OUTPut:PROTection:COUPle?

Description

This command enables/disables output coupling for protection faults. When enabled, ALL output channels are disabled when a protection fault occurs on any output channel. The enabled state is On (1); the disabled state is Off (0). When disabled, only the affected output channel is disabled when a protection fault is triggered.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF

Return Format

<NR1>

The query command returns 0 if the protection coupling is OFF (disabled), and 1 if the protection coupling is ON (enabled).

Example

The following command enables protection coupling.

OUTP:PROT:COUP ON

The following query returns the protection coupling setting.

OUTP:PROT:COUP?

Typical Response: 0

See Also

OUTPut:PROTection:CLEar

OUTPut:PROTection:DELay


OUTPut:PROTection:DELay

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:PROTection:DELay <delay>, (@<chanlist>)

OUTPut:PROTection:DELay? [MIN|MAX,] (@<chanlist>)

Description

This command sets the over-current protection programming delay. The delay prevents the momentary changes in status that can occur during reprogramming from triggering the over-current protection function. Programmed values can range from 0 to 255 milliseconds in increments of 1 millisecond.

The output protection delay cannot be used to delay changes in status that are caused by changes in the output load.

Parameters

Name | Type | Range of Values | Default Value
<delay> | NRf+ | 0 - 0.255 | MIN | MAX | 20 ms
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the programmed delay time. The reading is in the form +1.000000E+01.

Example

The following command sets an output protection delay of 0.5 seconds for channel 2.

OUTP:PROT:DEL 0.5,(@2)

The following query returns the maximum allowable output protection delay of channel 1.

OUTP:PROT:DEL? MAX,(@1)

Typical Response: +2.550000E-01

See Also

OUTPut:PROTection:CLEar

OUTPut:PROTection:COUPle


OUTPut:RELay:POLarity

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

OUTPut:RELay:POLarity <polarity>, (@<chanlist>)

OUTPut:RELay:POLarity? (@<chanlist>)

Description

This command sets the output polarity on power modules with polarity reversal relays installed (Option 760). Polarity reversal affects both the output and the sense terminals.

NORMal | Causes the output polarity to be the same as the output connector labeling.
REVerse | Causes the output polarity to be the reverse of the output connector labeling. This command briefly turns the output off while the output and sense terminal polarities are switched.

When installed on models N6742B and N6773A, Option 760 (Polarity Reversal) will limit the output current of these models to a maximum of 10 A. Option 760 is not available on models N6741B, N6751A/N6752A, or N6761A/N6762A.

Parameters

Name | Type | Range of Values | Default Value
<polarity> | CPD | NORMal | REVerse | NORMal
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns NORM or REV.

Example

The following command sets the output polarity of channel 1 to REVerse.

OUTP:REL:POL REV,(@1)

The following query returns the setting of the output polarity of channel 2.

OUTP:REL:POL? (@2)

Typical Response: NORM

See Also

OUTPut[:STATe]


SENSe Subsystem Introduction

Sense commands control the current measurement range, the bandwidth detector of the power system, and the data acquisition sequence.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

SENSe:CURRent[:DC]:RANGe

SENSe:CURRent[:DC]:RANGe?

SENSe:CURRent:CCOMpensate

SENSe:CURRent:CCOMpensate?

SENSe:DLOG:FUNCtion:CURRent (N6705A only)

SENSe:DLOG:FUNCtion:CURRent? (N6705A only)

SENSe:DLOG:FUNCtion:MINMax (N6705A only)

SENSe:DLOG:FUNCtion:MINMax? (N6705A only)

SENSe:DLOG:FUNCtion:VOLTage (N6705A only)

SENSe:DLOG:FUNCtion:VOLTage? (N6705A only)

SENSe:DLOG:OFFset (N6705A only)

SENSe:DLOG:OFFset? (N6705A only)

SENSe:DLOG:TIME (N6705A only)

SENSe:DLOG:TIME? (N6705A only)

SENSe:DLOG:TINTerval (N6705A only)

SENSe:DLOG:TINTerval? (N6705A only)

SENSe:FUNCtion

SENSe:FUNCtion?

SENSe:SWEep:OFFSet:POINts

SENSe:SWEep:OFFSet:POINts?

SENSe:SWEep:POINts

SENSe:SWEep:POINts?

SENSe:SWEep:TINTerval

SENSe:SWEep:TINTerval?

SENSe:VOLTage[:DC]:RANGe

SENSe:VOLTage[:DC]:RANGe?

SENSe:WINDow[:TYPE]

SENSe:WINDow[:TYPE]?


SENSe:CURRent[:DC]:RANGe

SENSe:CURRent[:DC]:RANGe[:UPPer]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:CURRent[:DC]:RANGe[:UPPer] <range>, (@<chanlist>)

SENSe:CURRent[:DC]:RANGe[:UPPer]? [MIN|MAX,] (@<chanlist>)

Description

This command selects a DC current measurement range on models that have multiple ranges. The value that you enter must be higher than the maximum current that you expect to measure. Units are in amperes. The instrument selects the range with the best resolution for the value entered. MIN selects the lowest range; MAX selects the highest range.

When queried, the returned value is the maximum DC current that can be measured on the range that is presently set.

This command is used only with models N6761A/N6762A, because these models have multiple measurement ranges.

Parameters

Name | Type | Range of Values | Default Value
<range> | NRf+ | 0 - 3 | MIN | MAX Available ranges: 100 mA (N6761A/N6762A) 1.5 A (N6761A) 3 A (N7662A) | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the range in the form "+1.000000E-01" for each channel specified. Multiple responses are separated by commas.

Examples

The following command selects the 100 mA range on channel 3.

SENS:CURR:RANG 0.1,(@3)

The following query returns the range selected on channel 3.

SENS:CURR:RANG? (@3)

Typical Response: +1.000000E-01

See Also

SENSe:VOLTage[:DC]:RANGe


SENSe:CURRent:CCOMpensate

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:CURRent:CCOMpensate <Bool>, (@<chanlist>)

SENSe:CURRent:CCOMpensate? (@<chanlist>)

Description

This command turns current measurement compensation ON or OFF on the specified output channel.

When turned ON, this function corrects the output current measurement for the current that flows into the output capacitor. This current is only significant when high dv/dt occurs, and because this current does not flow into the output load, it represents an error when not corrected. Note that turning on the current measurement compensation increases the peak to peak noise in current measurements.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | ON
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if current measurement compensation is OFF, and 1 if current measurement compensation is ON.

Examples

The following command turns current measurement compensation ON for output channel 2.

SENS:CURR:CCOM ON,(@2)

The following query returns the current measurement compensation setting of channel 1.

SENS:CURR:CCOM? (@1)

Typical Response: 0


SENSe:DLOG:FUNCtion:CURRent

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:FUNCtion:CURRent <Bool>, (@<chanlist>)

SENSe:DLOG:FUNCtion:CURRent? (@<chanlist>)

Description

This command turns current data logging ON or OFF on the specified output channel.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if current data logging is OFF, and 1 if current data logging is ON.

Examples

The following command turns current data logging ON for output channel 2.

SENS:DLOG:FUNC:CURR ON,(@2)

The following query returns the current data logging setting of channel 1.

SENS:DLOG:FUNC:CURR? (@1)

Typical Response: 0


SENSe:DLOG:FUNCtion:MINMax

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:FUNCtion:MINMax <Bool>

SENSe:DLOG:FUNCtion:MINMax?

Description

This command enables/disables the logging of the minimum and maximum values to the datalog file.

Although data is logged to the data file at the logging interval, it is sampled at a rate of 20.48 microseconds. When the data is logged, the minimum, maximum, and average values are computed from all of the samples taken during the logging interval. With SENSe:DLOG:FUNCtion:MINMax disabled, only the average values are entered into the datalog file. With SENSe:DLOG:FUNCtion:MINMax enabled, all three values are entered into the datalog file - thus tripling its size.

This function cannot be enabled when interleaved data logging is in effect.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF

Return Format

<NR1>

The query command returns 0 if MIN/MAX logging is OFF, and 1 if MIN/MAX logging is ON.

Examples

The following command turns MIN/MAX logging ON for all output channels.

SENS:DLOG:FUNC:MINM ON

The following query returns the MIN/MAX logging setting.

SENS:DLOG:FUNC:MINM?

Typical Response: 1


SENSe:DLOG:FUNCtion:VOLTage

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:FUNCtion:VOLTage <Bool>, (@<chanlist>)

SENSe:DLOG:FUNCtion:VOLTage? (@<chanlist>)

Description

This command turns voltage data logging ON or OFF on the specified output channel.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | ON
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if voltage data logging is OFF, and 1 if voltage data logging is ON.

Examples

The following command turns voltage data logging ON for output channel 2.

SENS:DLOG:FUNC:VOLT ON,(@2)

The following query returns the voltage data logging setting of channel 1.

SENS:DLOG:FUNC:VOLT? (@1)

Typical Response: 0


SENSe:DLOG:OFFset

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:OFFset <percent>

SENSe:DLOG:OFFset?

Description

This command specifies the datalog trigger offset as a percent of the total datalog duration. Programming a trigger offset lets you specify the percent of pre-trigger data that will be logged to the datalog file.

A percent of 0 means the trigger occurs at the beginning of the running datalog, while 100 means that the trigger occurs at the end of the running datalog. Any value between 0 and 100 can be set.

This function cannot be set to values other than zero when interleaved data logging is in effect.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<percent> | NR1 | 0 - 100 | 0

Return Format

<NR1>

The query command returns the trigger offset percentage.

Examples

The following command specifies a trigger offset of 50%.

SENS:DLOG:OFF 50

The following query returns the trigger offset setting.

SENS:DLOG:OFF?

Typical Response: 50


SENSe:DLOG:TIME

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:TIME <seconds>

SENSe:DLOG:TIME?

Description

This command specifies the duration of the datalog in seconds. Values from 1 second up to the equivalent of 99.999 hours can be specified.

The resulting datalog file cannot exceed 2E9 bytes (1.87 Gbytes in Microsoft Windows units). If the duration value causes the file to exceeds this size, the time interval will automatically be adjusted to a longer interval to reduce the file size.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<seconds> | NRf+ | 1 - 3,599,964,000 | MIN | MAX | 30

Return Format

<NR1>

The query command returns the duration of the datalog in seconds.

Examples

The following command specifies a datalog duration of 5000 seconds.

SENS:DLOG:TIME 5000

The following query returns the datalog duration.

SENS:DLOG:TIME?

Typical Response: 5000


SENSe:DLOG:TINTerval

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:DLOG:TINTerval <seconds>

SENSe:DLOG:TINTerval?

Description

This command specifies the time interval between datalog samples in seconds. Values from 1 millisecond to 60 seconds can be specified.

This function cannot be set to values less than 75 milliseconds when interleaved data logging is in effect.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<seconds> | NRf+ | 0.001 - 60 | MIN | MAX | 0.1

Return Format

<NR1>

The query command returns the datalog time interval in seconds.

Examples

The following command specifies a datalog time interval of 0.01 seconds.

SENS:DLOG:TINT 0.01

The following query returns the datalog time interval.

SENS:DLOG:TINT?

Typical Response: 0.01


SENSe:FUNCtion

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:FUNCtion <"function">, (@<chanlist>)

SENSe:FUNCtion? (@<chanlist>)

Description

This command selects a measurement function on models that do not have simultaneous voltage and current measurement capability. This command is required so that the acquisition system knows which measurement function to acquire when a measurement is triggered.

This command does NOT apply to models N6761A/N6762A, because these models have simultaneous voltage and current measurement capability.

Parameters

Name | Type | Range of Values | Default Value
<"function"> | SPD | "CURRent"|"VOLTage" Parameters must be enclosed in single or double quotes | VOLTage
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<SRD>

The query command returns an ASCII string enclosed in double quotes for each channel specified. Multiple responses are separated by commas. The short form of the parameter is always returned.

Examples

The following command selects the voltage function on channel 3.

SENS:FUNC "VOLT", (@3)

The following query returns the function selected on channel 1 (quotes are also returned).

SENS:FUNC? (@1)

Typical Response: "VOLT"


SENSe:SWEep:OFFSet:POINts

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:SWEep:OFFSet:POINts <points>, (@<chanlist>)

SENSe:SWEep:OFFSet:POINts? [MIN|MAX,] (@<chanlist>)

Description

This command defines the offset in a data sweep when an acquire trigger is used on models that have measurement controls. Programmed values can range from -4095 through 2,000,000,000 (2E9). Negative values represent data samples taken prior to the trigger. Positive values represent the delay after the trigger occurs but before the samples are acquired.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<points> | NRf+ | -4095 - 2,000,000,000 | MIN | MAX | 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the number of offset points for each channel specified. Multiple responses are separated by commas.

Examples

The following command specifies -2048 offset points on channel 3.

SENS:SWE:OFFS:POIN -2048,(@3)

The following query returns the number of offset points specified for channel 1.

SENS:SWE:OFFS:POIN? (@1)

Typical Response: +0

See Also

SENSe:SWEep:POINts

SENSe:SWEep:TINTerval


SENSe:SWEep:POINts

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:SWEep:POINts <points>, (@<chanlist>)

SENSe:SWEep:POINts? [MIN|MAX,] (@<chanlist>)

Description

This command defines the number of points in a measurement on models that have measurement controls. Programmed values can range from 1 to 4096.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<points> | NRf+ | 1 - 4096 | MIN | MAX | 1024
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns the number of points for each channel specified. Multiple responses are separated by commas.

Examples

The following command specifies 2048 measurement points on channel 3.

SENS:SWE:POIN 2048,(@3)

The following query returns the number of points specified for channel 1.

SENS:SWE:POIN? (@1)

Typical Response: +1024

See Also

SENSe:SWEep:OFFSet:POINts

SENSe:SWEep:TINTerval


SENSe:SWEep:TINTerval

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:SWEep:TINTerval <interval>, (@<chanlist>)

SENSe:SWEep:TINTerval? [MIN|MAX,] (@<chanlist>)

Description

This command defines the time period between samples in seconds on models that have measurement controls. Programmed values can range from 20.48 microseconds to 40000 seconds. Values are rounded to the nearest 20.48-microsecond increment.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<interval> | NRf+ | 0.00002048 - 40000 | MIN | MAX | 20.48 microseconds
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the time interval for each channel specified. The value returned is the time period rounded to the nearest 20.48 microsecond increment; which is not necessarily the value that was programmed. Multiple responses are separated by commas.

Examples

The following command specifies a time interval of 1 second between measurement points on channel 3.

SENS:SWE:TINT 1,(@3)

The following query returns the measurement time interval for channel 1.

SENS:SWE:TINT? (@1)

Typical Response: +2.048000E-5

See Also

SENSe:SWEep:OFFSet:POINts

SENSe:SWEep:POINts


SENSe:VOLTage[:DC]:RANGe

SENSe:VOLTage[:DC]:RANGe[:UPPer]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:VOLTage[:DC]:RANGe[:UPPer] <range>, (@<chanlist>)

SENSe:VOLTage[:DC]:RANGe[:UPPer]? [MIN|MAX,] (@<chanlist>)

Description

This command selects a DC voltage measurement range on models that have multiple ranges. The programmed value must be the maximum voltage that you expect to measure. Units are in volts. The instrument selects the range with the best resolution for the value entered. MIN selects the lowest range; MAX selects the highest range.

When queried, the returned value is the maximum DC voltage that can be measured on the range that is presently set.

This command is used only with models N6761A/N6762A, because these models have multiple measurement ranges.

Parameters

Name | Type | Range of Values | Default Value
<range> | NRf+ | 0 - 50 | MIN | MAX Available ranges: 5.5 V (N6761A/N6762A) 50 V (N6761A/N6762A) | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the range in the form "+1.000000E+01" for each channel specified. Multiple responses are separated by commas.

Examples

The following command selects the 5 V range on channel 3.

SENS:VOLT:RANG 5,(@3)

The following query returns the range selected on channel 1.

SENS:VOLT:RANG? (@1)

Typical Response: +5.500000E+01

See Also

SENSe:CURRent[:DC]:RANGe


SENSe:WINDow[:TYPE]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SENSe:WINDow[:TYPE] <window>, (@<chanlist>)

SENSe:WINDow[:TYPE]? (@<chanlist>)

Description

This command sets the window function used in DC measurement calculations on models that have measurement controls. Select from the following window types:

HANNing | A signal conditioning window that reduces errors in DC measurement calculations in the presence of periodic signals such as AC line ripple. The Hanning window multiplies each point in the sample by the function cosine4.
RECTangular | A window that returns measurement calculations with no signal conditioning.

Note that neither window function alters the instantaneous voltage or current data returned in the measurement array.

This command is used only with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<window> | CPD | HANNing|RECTangular | RECTangular
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns the window setting for each channel specified. Multiple responses are separated by commas.

Examples

The following command specifies a RECTangular measurement window for channel 3.

SENS:WIND RECT,(@3)

The following query returns the measurement window for channel 1.

SENS:WIND? (@1)

Typical Response: RECT


SOURce Subsystem Introduction

The Source subsystem programs the current, digital, list, step, and voltage functions.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

[SOURce:]CURRent[:LEVel][:IMMediate]

[SOURce:]CURRent[:LEVel][:IMMediate]?

[SOURce:]CURRent[:LEVel]:TRIGgered

[SOURce:]CURRent[:LEVel]:TRIGgered?

[SOURce:]CURRent:MODE

[SOURce:]CURRent:MODE?

[SOURce:]CURRent:PROTection:STATe

[SOURce:]CURRent:PROTection:STATe?

[SOURce:]CURRent:RANGe

[SOURce:]CURRent:RANGe?

[SOURce:]DIGital:INPut:DATA?

[SOURce:]DIGital:OUTput:DATA

[SOURce:]DIGital:OUTput:DATA?

[SOURce:]DIGital:PIN<1-7>:FUNCtion

[SOURce:]DIGital:PIN<1-7>:FUNCtion?

[SOURce:]DIGital:PIN<1-7>:POLarity

[SOURce:]DIGital:PIN<1-7>:POLarity?

[SOURce:]LIST:COUNt

[SOURce:]LIST:COUNt?

[SOURce:]LIST:CURRent[:LEVel]

[SOURce:]LIST:CURRent[:LEVel]?

[SOURce:]LIST:CURRent:POINts?

[SOURce:]LIST:DWELl

[SOURce:]LIST:DWELl?

[SOURce:]LIST:DWELl:POINts?

[SOURce:]LIST:STEP

[SOURce:]LIST:STEP?

[SOURce:]LIST:TERMinate:LAST

[SOURce:]LIST:TERMinate:LAST?

[SOURce:]LIST:TOUTput:BOSTep[:DATA]

[SOURce:]LIST:TOUTput:BOSTep[:DATA]?

[SOURce:]LIST:TOUTput:EOSTep[:DATA]

[SOURce:]LIST:TOUTput:EOSTep[:DATA]?

[SOURce:]LIST:VOLTage[:LEVel]

[SOURce:]LIST:VOLTage[:LEVel]?

[SOURce:]LIST:VOLTage:POINts?

[SOURce:]POWer:LIMit

[SOURce:]POWer:LIMit?

[SOURce:]STEP:TOUTput

[SOURce:]STEP:TOUTput?

[SOURce:]VOLTage[:LEVel][:IMMediate]

[SOURce:]VOLTage[:LEVel][:IMMediate]?

[SOURce:]VOLTage[:LEVel]:TRIGgered

[SOURce:]VOLTage[:LEVel]:TRIGgered?

[SOURce:]VOLTage:MODE

[SOURce:]VOLTage:MODE?

[SOURce:]VOLTage:PROTection[:LEVel]

[SOURce:]VOLTage:PROTection[:LEVel]?

[SOURce:]VOLTage:RANGe

[SOURce:]VOLTage:RANGe?

[SOURce:]VOLTage:SENSe:SOURce (N6705A only)

[SOURce:]VOLTage:SENSe:SOURce? (N6705A only)

[SOURce:]VOLTage:SLEW[:IMMediate]

[SOURce:]VOLTage:SLEW[:IMMediate]?


[SOURce:]CURRent[:LEVel][:IMMediate]

[SOURce:]CURRent[:LEVel][:IMMediate][:AMPLitude]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]CURRent[:LEVel][:IMMediate][:AMPLitude] <current>, (@<chanlist>)

[SOURce:]CURRent[:LEVel][:IMMediate][:AMPLitude]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the immediate current level of the specified output channel. Units are in amperes. The immediate level is the output current setting.

Parameters

Name | Type | Range of Values | Default Value
<current> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the current rating of the power module. | 80 mA
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with [SOURce:]CURRent:RANGe.

Return Format

<NR3>

The query command returns the programmed current level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the output current to 3 A on channels 1 and 2.

CURR 3,(@1,2)

The following query returns the programmed current level on channels 1 and 2.

CURR? (@1,2)

Typical Response: +3.000000E+00,+3.000000E+00

See Also

[SOURce:]CURRent:RANGe


[SOURce:]CURRent[:LEVel]:TRIGgered

[SOURce:]CURRent[:LEVel]:TRIGgered[:AMPLitude]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]CURRent[:LEVel]:TRIGgered[:AMPLitude] <current>, (@<chanlist>)

[SOURce:]CURRent[:LEVel]:TRIGgered[:AMPLitude]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the triggered current level of the specified output channel. Units are in amperes. The triggered level is a stored value that is transferred to the output when an output Step is triggered.

Parameters

Name | Type | Range of Values | Default Value
<current> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the current rating of the power module. | MIN
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with [SOURce:]CURRent:RANGe.

Return Format

<NR3>

The query command returns the programmed triggered level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the triggered current to 2 A on channels 1 and 2.

CURR:TRIG 2,(@1,2)

The following query returns the programmed triggered level on channels 1 and 2.

CURR:TRIG? (@1,2)

Typical Response: +2.000000E+00,+2.000000E+00

See Also

[SOURce:]CURRent[:LEVel][:IMMediate]

[SOURce:]CURRent:MODE

TRIGger:TRANsient[:IMMediate]


[SOURce:]CURRent:MODE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]CURRent:MODE <mode>, (@<chanlist>)

[SOURce:]CURRent:MODE? (@<chanlist>)

Description

This command determines what happens to the output current when the transient system is initiated and triggered.

FIXed | The output current remains at the immediate value.
STEP | The output goes to the triggered level when a trigger occurs.
LIST | The output follows the programmed list values when a trigger occurs.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<mode> | CPD | FIXed | STEP | LIST | FIXed
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns the current mode for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the current mode of channel 4.

CURR:MODE STEP,(@4)

The following query returns the current mode of channel 1.

CURR:MODE? (@1)

Typical Response: FIX

See Also

[SOURce:]VOLTage:MODE

INITiate[:IMMediate]:TRANsient

TRIGger:TRANsient[:IMMediate]


[SOURce:]CURRent:PROTection:STATe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]CURRent:PROTection:STATe <Bool>, (@<chanlist>)

[SOURce:]CURRent:PROTection:STATe? (@<chanlist>)

Description

This command enables or disables the over-current protection (OCP) function. The enabled state is On (1); the disabled state is Off (0). If the over-current protection function is enabled and the output goes into constant current operation, the output is disabled and the Questionable Condition status register OCP bit is set.

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The current limit setting determines when the output channel goes into constant current operation.

  • An over-current condition can be cleared with OUTPut:PROTection:CLEar after the cause of the condition is removed.

Return Format

<NR1>

The query command returns 0 if the current protection state is OFF, and 1 if the current protection state is ON.

Examples

The following command sets the current protection state of channel 4.

CURR:PROT:STAT ON,(@4)

The following query returns the current protection state of channel 1.

CURR:PROT:STAT? (@1)

Typical Response: 0

See Also

OUTPut:PROTection:CLEar


[SOURce:]CURRent:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]CURRent:RANGe <range>, (@<chanlist>)

[SOURce:]CURRent:RANGe? [MIN|MAX,] (@<chanlist>)

Description

This command sets the output current range. Units are in amperes. The instrument selects the range with the best resolution for the value entered.

This command is used only with models N6761A/N6762A, because these models have multiple ranges.

Parameters

Name | Type | Range of Values | Default Value
<range> | NRf+ | 0 - 3 | MIN | MAX Available ranges: 100 mA (N6761A/N6762A) 1.5 A (N6761A) 3 A (N6762A). | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with the [SOURce:]CURRent command. This means that if a range command is sent that places an output on a range with a lower maximum current than the present current level, an error is generated. This also occurs if a current level is programmed with a value too large for the present range.

  • These types of errors can be avoided by sending the both level and range commands in the same SCPI message. When the range and setting information is received as a set, no range/setting conflict occurs.

  • If programming a range value causes a range change to occur while the output is enabled, the output will be temporarily disabled while the range switch occurs. The transition from on-to-off and then from off-to-on will also be delayed by the settings of OUTPut:DELay:FALL and OUTPut:DELay:RISE.

Return Format

<NR3>

The query command returns the maximum current that can be output on the range that is presently set. The current level is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the output current range to 1 A on channels 1 and 2.

CURR:RANG 1,(@1,2)

The following query returns the programmed current range on channels 1 and 2.

CURR:RANG? (@1,2)

Typical Response: +1.000000E+00,+1.000000E+00

See Also

[SOURce:]CURRent[:LEVel][:IMMediate]


[SOURce:]DIGItal:INPut:DATA?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]DIGital:INPut:DATA?

Description

This query reads the state of the digital control port.

Return Format

<NR1>

The query returns the binary-weighted value of the state of pins 1 through 7 in bits 0 through 6 respectively.

Example

The following query returns the state of the digital control port pins.

DIG:INP:DATA?

Typical Response: +0

See Also

[SOURce:]DIGital:OUTput:DATA


[SOURce:]DIGital:OUTPut:DATA

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]DIGital:OUTPut:DATA <value>

[SOURce:]DIGital:OUTPut:DATA?

Description

This command sets the output data on the digital control port when that port is configured for Digital I/O operation. The port has seven signal pins and a digital ground pin. In the binary-weighted value that is written to the port, the pins are controlled according to the following bit assignments:

Pin | Bit Number | Decimal Value
1 | 0 | 1
2 | 1 | 2
3 | 2 | 4
4 | 3 | 8
5 | 4 | 16
6 | 5 | 32
7 | 6 | 64

Parameters

Name | Type | Range of Values | Default Value
<value> | NRf | 0 - 127 | 0

Return Format

<NR1>

The query returns the last programmed value of the bits. To read the actual state of the pin, use [SOURce:]DIGital:INPut:DATA?

Example

The following command programs pins 1, 3, and 5 on. (bit 0 = 1; bit 2 = 4; bit 4 = 16) (1 + 4 + 16 = 21)

DIG:OUTP:DATA 21

The following query returns the state of the digital control port pins.

DIG:OUTP:DATA?

Typical Response: +21

See Also

[SOURce:]DIGital:INPut:DATA?


[SOURce:]DIGital:PIN<1-7>:FUNCtion

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]DIGital:PIN<1-7>:FUNCtion <function>

[SOURce:]DIGital:PIN<1-7>:FUNCtion?

Description

This command sets the functions of the digital port pins. The pin functions are saved in non-volatile memory.

DIO | The pin is a general-purpose ground-referenced digital input/output. The output can be set with [SOURce:]DIGital:OUTPut:DATA.
DINPut | The pin is in digital input-only mode. The digital output data of the corresponding pin is ignored.
TOUTput | The pin is configured as a trigger output. When configured as a trigger output, the pin will only generate output triggers if the Step or List transient system has been configured to generated trigger signals. See: [SOURce:]STEP:TOUTput, [SOURce:]LIST:TOUTput:BOSTep, and [SOURce:]LIST:TOUTput:EOSTep
TINPut | The pin is configured as a trigger input. When configured as a trigger input, the pin can be selected as the source for measurement and transient trigger signals. See TRIGger:ACQuire:SOURce and TRIGger:TRANsient:SOURce
FAULt | Applies only to pin 1. Setting FAULt means that pin 1 functions as an isolated fault output. The fault signal is true when any output is in a protected state (from OC, OV, OT, INH, PF, or CP+ on some models). Note also that Pin 2 serves as the isolated common for pin 1. When pin 1 is set to the FAULt function, the instrument ignores any commands to program pin 2. Queries of pin 2 will return FAULt. If pin 1 is changed from FAULt to another function, pin 2 is set to DINPut.
INHibit | Applies only to pin 3. When pin 3 is configured as an inhibit input, a true signal at the pin will disable all output channels.
ONCouple | Applies only to pins 4 -7. When configured as an On control, the pin will synchronize the output On state between mainframes. Only one pin can be configured as an On control. The pin will function as both an input and an output. The polarity of the pin is fixed and cannot be programmed.
OFFCouple | Applies only to pins 4-7. When configured as an Off control, the pin will synchronize the output Off state between mainframes. Only one pin can be configured as an Off control. The pin will function as both an input and an output. The polarity of the pin is fixed and cannot be programmed.

Parameters

Name | Type | Range of Values | Default Value
<function> | CPD | DIO | DINPut | TOUTput | TINPut | FAULt | INHibit | ONCouple | OFFCouple | Required parameter

Return Format

<CRD>

The query command returns DIO, DINP, TOUT, TINP, FAUL, INH, ONC, or OFFC.

Example

The following command sets pin 1 to Fault mode.

DIG:PIN1:FUNC FAUL

The following query returns the setting of pin 7.

DIG:PIN7:FUNC?

Typical Response: DIO

See Also

[SOURce:]DIGital:PIN<1-7>:POLarity


[SOURce:]DIGital:PIN<1-7>:POLarity

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]DIGital:PIN<1-7>:POLarity <polarity>

[SOURce:]DIGital:PIN<1-7>:POLarity?

Description

This command sets the polarity of the digital port pins. The pin polarities are saved in non-volatile memory.

POSitive | Setting a polarity to POSitive means that a logical true signal is a voltage high at the pin. For trigger inputs and outputs, POSitive means a rising edge.
NEGative | Setting the polarity NEGative means that a logical true signal is a voltage low at the pin. For trigger inputs and outputs, NEGative means a falling edge.

Parameters

Name | Type | Range of Values | Default Value
<function> | CPD | POSitive | NEGative | Required parameter

Return Format

<CRD>

The query command returns POS or NEG.

Example

The following command sets pin 1 to negative polarity.

DIG:PIN1:POL NEGative

The following query returns the polarity of pin 7.

DIG:PIN7:POL?

Typical Response: POS

See Also

[SOURce:]DIGital:PIN<1-7>:FUNCtion


[SOURce:]LIST:COUNt

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:COUNt <count>|INFinity, (@<chanlist>)

[SOURce:]LIST:COUNt? [MIN|MAX,] (@<chanlist>)

Description

This command sets the number of times that the list is executed before it is completed. The list count range is 1 through 256.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<count> | NRf+ | 1 - 256 | MIN | MAX | INFinity | 1
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Use the INFinity parameter to execute a list indefinitely.

  • Use ABORt:TRANsient to stop the list at any time. When the list is aborted, the output returns to the settings that were in effect before the list started.

Return Format

<NR1>

The query command returns the list count for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the list count to 10 on channel 1.

LIST:COUN 10,(@1)

The following query returns the list count of channel 1.

LIST:COUN? (@1)

Typical Response: +10


[SOURce:]LIST:CURRent[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:CURRent[:LEVel] <current>{,<current>}, (@<chanlist>)

[SOURce:]LIST:CURRent[:LEVel]? (@<chanlist>)

Description

This command specifies the current setting for each list step in amperes. A comma-delimited list of up to 512 steps may be programmed.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<current> | NRf | 0 - maximum The maximum value is dependent on the current rating of the power module. | 1 step set to the minimum programmable value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the programmed current level in the form +1.000000E+01. Multiple responses are separated by commas.

Examples

The following command programs a current list. The list contains 5 steps and is on channel 1.

LIST:CURR 5,4,3,2,1,(@1)

The following query returns the current list settings of channel 1.

LIST:CURR? (@1)

Typical Response: +5.000000E+00,+4.000000E+00,+3.000000E+00,+2.000000E+00,+1.000000E+00

See Also

[SOURce:]LIST:DWELl

[SOURce:]LIST:VOLTage[:LEVel]


[SOURce:]LIST:CURRent:POINts?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]LIST:CURRent:POINts? (@<chanlist>)

Description

This query returns the number of points (steps) in the current list, not the point values.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The number of points in the current list. Multiple responses are separated by commas.

Example

The following query returns the number of points in a current list for channel 1.

LIST:CURR:POIN? (@1)

Typical Response: +1


[SOURce:]LIST:DWELl

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:DWELl <time>{,<time>}, (@<chanlist>)

[SOURce:]LIST:DWELl? (@<chanlist>)

Description

This command specifies the dwell time for each list step. A comma-delimited list of up to 512 steps may be programmed. Dwell time is the time that the output will remain at a specific step. Dwell times can be programmed from 0 through 262.144 seconds with the following resolution:

Range in seconds | Resolution
0 - 0.262144 | 1 microsecond
0 - 2.62144 | 10 microseconds
0 - 26.2144 | 100 microseconds
0 - 262.144 | 1 millisecond

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<time> | NRf | 0 - 262.144 | 1 step with a value of 0.001
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • At the end of the dwell time, the output state of the unit depends upon the LIST:STEP program settings.

  • The order in which the dwell values are entered determines the sequence when the list executes.

Return Format

<NR3>

The query command returns the programmed dwell time in the form +1.000000E+01. Multiple responses are separated by commas.

Examples

The following command programs a dwell list. The list contains 5 steps and is on channel 1.

LIST:DWEL 0.2,0.8,1.5,0.8,0.2,(@1)

The following query returns the dwell list settings of channel 1.

LIST:DWEL? (@1)

Typical Response:
+2.000000E-01,+8.000000E-01,+1.500000E+00,+8.000000E-01,+02.000000E-01

See Also

[SOURce:]LIST:CURRent[:LEVel]

[SOURce:]LIST:VOLTage[:LEVel]


[SOURce:]LIST:DWELl:POINts?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]LIST:DWELl:POINts? (@<chanlist>)

Description

This query returns the number of points (steps) in the dwell list, not the point values.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The number of points in the dwell list. Multiple responses are separated by commas.

Example

The following query returns the number of points in a dwell list for channel 1.

LIST:DWEL:POIN? (@1)

Typical Response: +1


[SOURce:]LIST:STEP

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:STEP <step>, (@<chanlist>)

[SOURce:]LIST:STEP? (@<chanlist>)

Description

This command specifies how the list responds to triggers.

ONCE | Causes the output to remain at the present step until a trigger advances it to the next step. Triggers that arrive during the dwell time are ignored.
AUTO | Causes the output to automatically advance to each step, after the receipt of an initial starting trigger. The steps are paced by the dwell list. As each dwell time elapses, the next step is immediately output.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<step> | CPD | ONCE | AUTO | AUTO
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns the list step setting. Multiple responses are separated by commas.

Examples

The following command sets the list step setting of channel 1 to ONCE, causing the list steps to be paced by trigger signals.

LIST:STEP ONCE,(@1)

The following query returns the list step setting of channel 1.

VOLT:MODE? (@4)

Typical Response: ONCE

See Also

[SOURce:]LIST:TERMinate:LAST


[SOURce:]LIST:TERMinate:LAST

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:TERMinate:LAST <Bool>, (@<chanlist>)

[SOURce:]LIST:TERMinate:LAST? (@<chanlist>)

Description

This command determines the output value when the list terminates. The state is either ON (1) or OFF (0).

When ON, the output voltage or current remains at the value of the last list step. The value of the last voltage or current list step becomes the IMMediate value when the list completes.

When OFF, and also when the list is aborted, the output returns to the settings that were in effect before the list started.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if the output returns to the settings that were in effect before the list started, and 1 if the output voltage or current remains at the value of the last list step.

Examples

The following command sets the list to terminate with the output voltage or current remaining at the value of the last list step on channel 2.

LIST:TERM:LAST ON,(@2)

The following query returns the list terminate setting of channel 1.

LIST:TERM:LAST? (@1)

Typical Response: 0

See Also

[SOURce:]LIST:STEP


[SOURce:]LIST:TOUTput:BOSTep[:DATA]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:TOUTput:BOSTep[:DATA] <Bool>{,<Bool>}, (@<chanlist>)

[SOURce:]LIST:TOUTput:BOSTep[:DATA]? (@<chanlist>)

Description

This command specifies which list steps generate a trigger-out signal at the beginning of the list step (BOSTep). A comma-delimited list of up to 512 steps may be programmed. The state is either ON (1) or OFF (0).

A trigger is only generated when the state is set to ON.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | 1 step with a value of OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if no trigger is generated, and 1 if a trigger is generated. Multiple responses are separated by commas.

Examples

The following command specifies that triggers will be generated at the beginning of each list step. The list contains 5 steps and is on channel 1.

LIST:TOUT:BOST ON,ON,ON,ON,ON,(@1)

The following query returns the list step trigger settings of channel 1.

LIST:TOUT:BOST? (@1)

Typical Response: 1,1,1,1,1

See Also

[SOURce:]LIST:TOUTput:EOSTep[:DATA]


[SOURce:]LIST:TOUTput:EOSTep[:DATA]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:TOUTput:EOSTep[:DATA] <Bool>{,<Bool>}, (@<chanlist>)

[SOURce:]LIST:TOUTput:EOSTep[:DATA]? (@<chanlist>)

Description

This command specifies which list steps generate a trigger-out signal at the end of the list step (EOSTep). A comma-delimited list of up to 512 steps may be programmed. The state is either ON (1) or OFF (0).

A trigger is only generated when the state is set to ON.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | 1 step with a value of OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if no trigger is generated, and 1 if a trigger is generated. Multiple responses are separated by commas.

Examples

The following command specifies that triggers will be generated at the end of each list step. The list contains 5 steps and is on channel 1.

LIST:TOUT:EOST ON,ON,ON,ON,ON,(@1)

The following query returns the list step trigger settings of channel 1.

LIST:TOUT:EOST? (@1)

Typical Response: 1,1,1,1,1

See Also

[SOURce:]LIST:TOUTput:BOSTep[:DATA]


[SOURce:]LIST:VOLTage[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]LIST:VOLTage[:LEVel] <voltage>{,<voltage>}, (@<chanlist>)

[SOURce:]LIST:VOLTage[:LEVel]? (@<chanlist>)

Description

This command specifies the voltage setting for each list step in volts. A comma-delimited list of up to 512 steps may be programmed.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<voltage> | NRf | 0 - maximum The maximum value is dependent on the voltage rating of the power module. | 1 step set to the minimum programmable value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR3>

The query command returns the programmed voltage level in the form +1.000000E+01. Multiple responses are separated by commas.

Examples

The following command programs a voltage list. The list contains 5 steps and is on channel 1.

LIST:VOLT 10,20,30,40,50,(@1)

The following query returns the voltage list settings of channel 1.

LIST:VOLT? (@1)

Typical Response: +1.000000E+01,+2.000000E+01,+3.000000E+01,+4.000000E+01,+5.000000E+01

See Also

[SOURce:]LIST:DWELl

[SOURce:]LIST:CURRent[:LEVel]


[SOURce:]LIST:VOLTage:POINts?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]LIST:VOLTage:POINts? (@<chanlist>)

Description

This query returns the number of points (steps) in the voltage list, not the point values.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The number of points in the voltage list. Multiple responses are separated by commas.

Example

The following query returns the number of points in a voltage list for channel 1.

LIST:VOLT:POIN? (@1)

Typical Response: +1


[SOURce:]POWer:LIMit

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]POWer:LIMit <power>, (@<chanlist>)

[SOURce:]POWer:LIMit? [MIN|MAX,] (@<chanlist>)

Description

This command sets the power limit on output channels. Units are in Watts.

For the majority of Agilent N6700 and N6705A configurations, full power is available from all installed power modules. However, it is possible to configure a mainframe in which the combined ratings of the power modules exceed the power rating of the mainframe.

For these instrument configurations, the power allocation lets you programmatically limit the output power of some of the power modules so that the combined output power does not exceed the power rating of the mainframe. Refer to Appendix C in the User’s Guide for more information.

Parameters

Name | Type | Range of Values | Default Value
<power> | NRf+ | 0 - maximum | MIN | MAX | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Setting a power limit of MAX on an output channel sets the output channel to its maximum rated power limit. If the power limit is left at the maximum rating, then the power module will not enable its power limit function.

  • Querying MAX on an output channel returns the maximum rated power limit.

Return Format

<NR3>

The query command returns the programmed power level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the power limit to 75 W on channels 1 and 2.

POW:LIM 75,(@1,2)

The following query returns the programmed power limit on channels 1 and 2.

POW:LIM? (@1,2)

Typical Response: +7.500000E+01,+7.500000E+01


[SOURce:]STEP:TOUTput

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]STEP:TOUTput <Bool>, (@<chanlist>)

[SOURce:]STEP:TOUTput? (@<chanlist>)

Description

This command specifies whether an output trigger signal is generated when a transient voltage or current step occurs. The state is either ON (1) or OFF (0). A trigger is generated when the state is True (ON).

Parameters

Name | Type | Range of Values | Default Value
<Bool> | Boolean | OFF | 0 | ON | 1 | OFF
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<NR1>

The query command returns 0 if the trigger signal will NOT be generated (OFF) when a step occurs, and 1 if a trigger signal will be generated (ON) when a step occurs.

Examples

The following command sets the step trigger signal ON for channel 2.

STEP:TOUT ON,(@2)

The following query returns the step trigger signal state of channel 1.

STEP:TOUT? (@1)

Typical Response: 0

See Also

TRIGger:ACQuire:SOURce

TRIGger:TRANsient:SOURce


[SOURce:]VOLTage[:LEVel][:IMMediate]

[SOURce:]VOLTage[:LEVel][:IMMediate][:AMPLitude]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage[:LEVel][:IMMediate][:AMPLitude] <voltage>, (@<chanlist>)

[SOURce:]VOLTage[:LEVel][:IMMediate][:AMPLitude]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the immediate voltage level of the specified output channel. Units are in volts. The immediate level is the output voltage setting.

Parameters

Name | Type | Range of Values | Default Value
<voltage> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the voltage rating of the power module. | MIN
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with [SOURce:]VOLTage:RANGe.

Return Format

<NR3>

The query command returns the programmed voltage level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the output voltage to 50 V on channels 1 and 2.

VOLT 50,(@1,2)

The following query returns the programmed voltage level on channels 1 and 2.

VOLT? (@1,2)

Typical Response: +5.000000E+01,+5.000000E+01

See Also

[SOURce:]VOLTage:RANGe


[SOURce:]VOLTage[:LEVel]:TRIGgered

[SOURce:]VOLTage[:LEVel]:TRIGgered[:AMPLitude]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage[:LEVel]:TRIGgered[:AMPLitude] <voltage>, (@<chanlist>)

[SOURce:]VOLTage[:LEVel]:TRIGgered[:AMPLitude]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the triggered voltage level of the specified output channel. Units are in volts. The triggered level is a stored value that is transferred to the output when an output Step is triggered.

Parameters

Name | Type | Range of Values | Default Value
<voltage> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the voltage rating of the power module. | MIN
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with [SOURce:]VOLTage:RANGe.

Return Format

<NR3>

The query command returns the programmed triggered level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the triggered voltage to 40 V on channels 1 and 2.

VOLT:TRIG 40,(@1,2)

The following query returns the programmed triggered level on channels 1 and 2.

VOLT:TRIG? (@1,2)

Typical Response: +4.000000E+01,+4.000000E+01

See Also

[SOURce:]VOLTage[:LEVel][:IMMediate]

[SOURce:]VOLTage:MODE

TRIGger:TRANsient[:IMMediate]


[SOURce:]VOLTage:MODE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage:MODE <mode>, (@<chanlist>)

[SOURce:]VOLTage:MODE? (@<chanlist>)

Description

This command determines what happens to the output voltage when the transient system is initiated and triggered.

FIXed | The output voltage remains at the immediate value.
STEP | The output goes to the triggered level when a trigger occurs.
LIST | The output follows the programmed list values when a trigger occurs.

List mode is only available with models N6761A/N6762A, or models that have Option 054 (High Speed Test Extensions).

Parameters

Name | Type | Range of Values | Default Value
<mode> | CPD | FIXed | STEP | LIST | FIXed
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns the voltage mode for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the voltage mode of channel 4.

VOLT:MODE STEP,(@4)

The following query returns the voltage mode of channel 1.

VOLT:MODE? (@4)

Typical Response: FIX

See Also

[SOURce:]CURRent:MODE

INITiate[:IMMediate]:TRANsient

TRIGger:TRANsient[:IMMediate]


[SOURce:]VOLTage:PROTection[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage:PROTection[:LEVel] <voltage>, (@<chanlist>)

[SOURce:]VOLTage:PROTection[:LEVel]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the over-voltage protection (OVP) level of the output channel. The values are programmed in volts. If the output voltage exceeds the OVP level, the output is disabled and the Questionable Condition status register OV bit is set.

Parameters

Name | Type | Range of Values | Default Value
<voltage> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the voltage rating of the power module. | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • An over-voltage condition can be cleared with the OUTput:PROTection:CLEar command after the condition that caused the OVP trip is removed.

Return Format

<NR3>

The query command returns the programmed protection level in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the voltage protection level to 45 V on channel 1.

VOLT:PROT 45,(@1)

The following query returns the programmed voltage protection level on channel 1.

VOLT:PROT? (@1)

Typical Response: +4.500000E+01

See Also

OUTPut:PROTection:CLEar


[SOURce:]VOLTage:RANGe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage:RANGe <range>, (@<chanlist>)

[SOURce:]VOLTage:RANGe? [MIN|MAX,] (@<chanlist>)

Description

This command sets the output voltage range. Units are in volts. The instrument selects the range with the best resolution for the value entered.

This command is used only with models N6761A/N6762A, because these models have multiple ranges.

Parameters

Name | Type | Range of Values | Default Value
<range> | NRf+ | 0 - 50 | MIN | MAX Available ranges: 5.5 V (N6761A/N6762A) 50 V (N6761A/N6762A). | MAX
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • This command is coupled with the [SOURce:]VOLTage command. This means that if a range command is sent that places an output on a range with a lower maximum voltage than the present voltage level, an error is generated. This also occurs if a voltage level is programmed with a value too large for the present range.

  • These types of errors can be avoided by sending the both level and range commands in the same SCPI message. When the range and setting information is received as a set, no range/setting conflict occurs.

  • If programming a range value causes a range change to occur while the output is enabled, the output will be temporarily disabled while the range switch occurs. The transition from on-to-off and then from off-to-on will also be delayed by the settings of OUTPut:DELay:FALL and OUTPut:DELay:RISE.

Return Format

<NR3>

The query command returns the maximum voltage that can be output on the range that is presently set. The voltage level is in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the output voltage range to 5 V on channels 1 and 2.

VOLT:RANG 5,(@1,2)

The following query returns the programmed voltage range on channels 1 and 2.

VOLT:RANG? (@1,2)

Typical Response: +5.500000E+00,+5.500000E+00

See Also

[SOURce:]VOLTage[:LEVel][:IMMediate]


[SOURce:]VOLTage:SENse:SOURce

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

[SOURce:]VOLTage:SENSe:SOURce <state>, (@<chanlist>)

[SOURce:]VOLTage:SENSe:SOURce? (@<chanlist>)

Description

This command sets the state of the remote sense relays.

INTernal | Internal sets the remote sense relays to local sensing. The front panel remote sense terminals are internally connected to the output terminals. The 4 wire indicator is off.
EXTernal | External sets the remote sense relays to remote sensing. The front panel remote sense terminals are enabled and must be connected to the external load. The 4 wire indicator is on.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<state> | CPD | INTernal | EXTernal | INTernal
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Return Format

<CRD>

The query command returns INT or EXT.

Example

The following selects EXTernal as the remote sense relay state.

VOLT:SENS:SOUR EXT,(@1)

The following query returns the remote sense relay state.

VOLT:SENS:SOUR? (@1)

Typical Response: INT


[SOURce:]VOLTage:SLEW[:IMMediate]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

[SOURce:]VOLTage:SLEW[:IMMediate] <slew>|INFinity, (@<chanlist>)

[SOURce:]VOLTage:SLEW[:IMMediate]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the voltage slew rate in volts per second. The slew rate setting affects all programmed voltage changes, including those due to the output state turning on or off. The slew rate can be set to any value between 0 and 9.9E+37. For very large values, the slew rate will be limited by the analog performance of the output circuit. The keywords MAX or INFinity set the slew rate to maximum.

The query returns the value that was sent, unless the value was less than the minimum slew rate, in which case the minimum value is returned. The LSB weight of the 24-bit register can be queried using VOLTage:SLEW? MIN. The exact value varies slightly according to the voltage calibration.

Parameters

Name | Type | Range of Values | Default Value
<slew> | NRf+ | 0 - 9.9E+37 | MIN | MAX | INFinity | 9.9E+37
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • Internally, the slew rate is controlled by a 24-bit register. The slowest or minimum slew rate is a function of the full-scale voltage range. For a model with a 50 V range, the minimum slew rate is about 4.76 V/s. For other voltage ranges the minimum slew rate is proportional to this value, so for a model with a 5 V range the minimum slew rate is about 0.476 V/s. The unit accepts slew rates as low as 0 V/s, but values sent to the 24-bit register will be limited at 1 count.

Return Format

<NR3>

The query command returns the programmed slew rate in the form +1.000000E+01 for each channel specified. Multiple responses are separated by commas.

Examples

The following command sets the slew rate to 5 volts per second on channel 1.

VOLT:SLEW 5,(@1)

The following query returns the programmed slew rate on channel 1.

VOLT:SLEW? (@1)

Typical Response: +5.000000E+00


STATus Subsystem Introduction

Status register programming lets you determine the operating condition of the power system at any time. The power system has three groups of status registers; Operation, Questionable, and Standard Event. The Operation and Questionable status groups each consist of the Condition, Enable, and Event registers as well as NTR and PTR filters.

The Status subsystem is also programmed using Common commands. Common commands control additional status functions such as the Service Request Enable and the Status Byte registers.

Refer to the Status System diagram.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

Status Commands

Related Common Commands

STATus:OPERation:CONDition?

STATus:OPERation:ENABle

STATus:OPERation:ENABle?

STATus:OPERation[:EVENt]?

STATus:OPERation:NTRansition

STATus:OPERation:NTRansition?

STATus:OPERation:PTRansition

STATus:OPERation:PTRansition?

STATus:PRESet

STATus:QUEStionable:CONDition?

STATus:QUEStionable:ENABle

STATus:QUEStionable:ENABle?

STATus:QUEStionable[:EVENt]?

STATus:QUEStionable:NTRansition

STATus:QUEStionable:NTRansition?

STATus:QUEStionable:PTRansition

STATus:QUEStionable:PTRansition?

*CLS

*ESE

*ESE?

*ESR?

*OPC

*OPC?

*SRE

*SRE?

*STB?

*WAI

Agilent N6700 Status System Diagram


STATus:OPERation[:EVENt]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

STATus:OPERation[:EVENt]? (@<chanlist>)

Description

This query returns the value of the Operation Status Event register. The Event register is a read-only register, which stores (latches) all events that are passed by the Operation NTR and/or PTR filter. Reading the Operation Status Event register clears it.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The following table lists the bit definitions for the Operation Status registers.

Bit Number |  | Decimal Value | Definition
0 | CV | 1 | The output is in constant voltage.
1 | CC | 2 | The output is in constant current.
2 | OFF | 4 | The output is programmed off.
3 | WTG-meas | 8 | The measurement system is waiting for a trigger.
4 | WTG-tran | 16 | The transient system is waiting for a trigger.
5-15 | Not Used | Not Used | 0 is returned.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 4 (decimal value = 16) are set, this command will return 24.

Example

The following command reads the Operation Status Event register.

STAT:OPER? (@1)

Typical Response: +24

See Also

STATus:OPERation:ENABle

*CLS


STATus:OPERation:CONDition?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

STATus:OPERation:CONDition? (@<chanlist>)

Description

This query returns the value of the Operation Status Condition register. The Condition register is a read-only register, which holds the live (unlatched) operational status of the power system. Reading the Operation Condition register does not clear it.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The following table lists the bit definitions for the Operation Status registers.

Bit Number |  | Decimal Value | Definition
0 | CV | 1 | The output is in constant voltage.
1 | CC | 2 | The output is in constant current.
2 | OFF | 4 | The output is programmed off.
3 | WTG-meas | 8 | The measurement system is waiting for a trigger.
4 | WTG-tran | 16 | The transient system is waiting for a trigger.
5-15 | Not Used | Not Used | 0 is returned.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 4 (decimal value = 16) are set, this command will return 24.

Example

The following command reads the Operation Status Condition register.

STAT:OPER:COND? (@1)

Typical Response: +24


STATus:OPERation:ENABle

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:OPERation:ENABle <value>, (@<chanlist>)

STATus:OPERation:ENABle? (@<chanlist>)

Description

This command and its query set and read the value of the Operation Status Enable register. The Enable register is a mask for enabling specific bits from the Operation Event register to set the operation summary bit (OPER) of the Status Byte register. This bit (bit 7) is the logical OR of all the Operational Event register bits that are enabled by the Operation Status Enable register.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 4 (decimal value = 16), the corresponding decimal value would be 24 (8 + 16).

Remarks

  • The following table lists the bit definitions for the Operation Status registers.

Bit Number |  | Decimal Value | Definition
0 | CV | 1 | The output is in constant voltage.
1 | CC | 2 | The output is in constant current.
2 | OFF | 4 | The output is programmed off.
3 | WTG-meas | 8 | The measurement system is waiting for a trigger.
4 | WTG-tran | 16 | The transient system is waiting for a trigger.
5-15 | Not Used | Not Used | 0 is returned.

  • The STATus:PRESet command will clear all bits in the enable register.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 3 (decimal value = 8) and bit 4 (decimal value = 16) are set, this command will return 24.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the enable register.

STAT:OPER:ENAB 3,(@1)

The following query returns which bits are enabled in the register.

STAT:OPER:ENAB? (@1)

Typical Response: +3

See Also

STATus:OPERation[:EVENt]?

STATus:PRESet


STATus:OPERation:NTRansition

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:OPERation:NTRansition <value>, (@<chanlist>)

STATus:OPERation:NTRansition? (@<chanlist>)

Description

These command sets and reads the value of the Operation NTR (Negative-Transition) register. This register serves as a polarity filter between the Operation Condition and Operation Event registers.

When a bit in the Operation NTR register is set to 1, then a 1-to-0 transition of the corresponding bit in the Operation Condition register causes that bit in the Operation Event register to be set.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 4 (decimal value = 16), the corresponding decimal value would be 24 (8 + 16).

Remarks

  • The following table lists the bit definitions for the Operation Status registers.

Bit Number |  | Decimal Value | Definition
0 | CV | 1 | The output is in constant voltage.
1 | CC | 2 | The output is in constant current.
2 | OFF | 4 | The output is programmed off.
3 | WTG-meas | 8 | The measurement system is waiting for a trigger.
4 | WTG-tran | 16 | The transient system is waiting for a trigger.
5-15 | Not Used | Not Used | 0 is returned.

  • If the same bits in both NTR and PTR registers are set to 1, then any transition of that bit at the Operation Condition register sets the corresponding bit in the Operation Event register.

  • If the same bits in both NTR and PTR registers are set to 0, then no transition of that bit at the Operation Condition register can set the corresponding bit in the Operation Event register.

  • The STATus:PRESet command will set all bits in the NTR register to 0.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the NTR register.

STAT:OPER:NTR 3,(@1)

The following query returns which bits are enabled in the register.

STAT:OPER:NTR? (@1)

Typical Response: +3

See Also

STATus:OPERation:PTRansition

STATus:PRESet


STATus:OPERation:PTRansition

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:OPERation:PTRansition <value>, (@<chanlist>)

STATus:OPERation:PTRansition? (@<chanlist>)

Description

These command sets and reads the value of the Operation PTR (Positive-Transition) register. This register serves as a polarity filter between the Operation Condition and Operation Event registers.

When a bit in the Operation PTR register is set to 1, then a 0-to-1 transition of the corresponding bit in the Operation Condition register causes that bit in the Operation Event register to be set.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 31
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 4 (decimal value = 16), the corresponding decimal value would be 24 (8 + 16).

Remarks

  • The following table lists the bit definitions for the Operation Status registers.

Bit Number |  | Decimal Value | Definition
0 | CV | 1 | The output is in constant voltage.
1 | CC | 2 | The output is in constant current.
2 | OFF | 4 | The output is programmed off.
3 | WTG-meas | 8 | The measurement system is waiting for a trigger.
4 | WTG-tran | 16 | The transient system is waiting for a trigger.
5-15 | Not Used | Not Used | 0 is returned.

  • If the same bits in both NTR and PTR registers are set to 1, then any transition of that bit at the Operation Condition register sets the corresponding bit in the Operation Event register.

  • If the same bits in both NTR and PTR registers are set to 0, then no transition of that bit at the Operation Condition register can set the corresponding bit in the Operation Event register.

  • The STATus:PRESet command will set all bits in the PTR register to 1.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the PTR register.

STAT:OPER:PTR 3,(@1)

The following query returns which bits are enabled in the register.

STAT:OPER:PTR? (@1)

Typical Response: +3

See Also

STATus:OPERation:NTRansition

STATus:PRESet


STATus:PRESet

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

STATus:PRESet

Description

This command sets all defined bits in the status system's PTR registers and clears all bits in the NTR and Enable registers.

Operation Register | Questionable Register | Preset setting
STAT:OPER:ENAB | STAT:QUES:ENAB | 0 - all bits disabled
STAT:OPER:NTR | STAT:QUES:NTR | 0 - all bits disabled
STAT:OPER:PTR |  | 31 - all defined bits enabled
 | STAT:QUES:PTR | 3647 - all defined bits enabled

Example

The following command presets the Operation and Questionable status registers.

STAT:PRES


STATus:QUEStionable[:EVENt]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

STATus:QUEStionable[:EVENt]? (@<chanlist>)

Description

This query returns the value of the Questionable Status Event register. The Event register is a read-only register, which stores (latches) all events that are passed by the Questionable NTR and/or PTR filter. Reading the Questionable Status Event register clears it.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The following table lists the bit definitions for the Questionable Status registers.

Bit Number |  | Decimal Value | Definition
0 | OV | 1 | The output is disabled by the over-voltage protection.
1 | OC | 2 | The output is disabled by the over-current protection.
2 | PF | 4 | The output is disabled by the power-fail - which may be caused by a low-line or brownout condition on the AC line.
3 | CP+ | 8 | The output is limited (or disabled on some models) by the positive power limit.
4 | OT | 16 | The over-temperature protection has tripped.
5 | CP- | 32 | The output is limited by the negative power limit.
6-8 | Not Used | Not Used | 0 is returned.
9 | INH | 512 | The output is inhibited by an external signal.
10 | UNR | 1024 | The output is unregulated.
11 | PROT | 2048 | The output has been disabled because it is coupled to a protection condition that occurred on another channel.
12-15 | Not Used | Not Used | 0 is returned.

  • Once a bit is set, it remains set until cleared by reading the event register or the *CLS (clear status) command.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 10 is set, this command will return 1024.

Example

The following command reads the Questionable Status Event register.

STAT:QUES?

Typical Response: +1024

See Also

STATus:QUEStionable:ENABle?

*CLS


STATus:QUEStionable:CONDition?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

STATus:QUEStionable:CONDition? (@<chanlist>)

Description

This query returns the value of the Questionable Status Condition register. The Condition register is a read-only register, which holds the live (unlatched) questionable status of the power system. Reading the Questionable Condition register does not clear it.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The following table lists the bit definitions for the Questionable Status registers.

Bit Number |  | Decimal Value | Definition
0 | OV | 1 | The output is disabled by the over-voltage protection.
1 | OC | 2 | The output is disabled by the over-current protection.
2 | PF | 4 | The output is disabled by the power-fail - which may be caused by a low-line or brownout condition on the AC line.
3 | CP+ | 8 | The output is limited (or disabled on some models) by the positive power limit.
4 | OT | 16 | The over-temperature protection has tripped.
5 | CP- | 32 | The output is limited by the negative power limit.
6-8 | Not Used | Not Used | 0 is returned.
9 | INH | 512 | The output is inhibited by an external signal.
10 | UNR | 1024 | The output is unregulated.
11 | PROT | 2048 | The output has been disabled because it is coupled to a protection condition that occurred on another channel.
12-15 | Not Used | Not Used | 0 is returned.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register. For example, if bit 10 is set, this command will return 1024.

Example

The following command reads the Questionable Status Condition register.

STAT:QUES:COND? (@1)

Typical Response: +1024


STATus:QUEStionable:ENABle

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:QUEStionable:ENABle <value>, (@<chanlist>)

STATus:QUEStionable:ENABle? (@<chanlist>)

Description

This command and its query set and read the value of the Questionable Status Enable register. The Enable register is a mask for enabling specific bits from the Questionable Event register to set the questionable summary bit (QUES) of the Status Byte register. This bit (bit 3) is the logical OR of all the Questionable Event register bits that are enabled by the Questionable Status Enable register.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 5 (decimal value = 32), the corresponding decimal value would be 40 (8 + 32).

Remarks

  • The following table lists the bit definitions for the Questionable Status registers.

Bit Number |  | Decimal Value | Definition
0 | OV | 1 | The output is disabled by the over-voltage protection.
1 | OC | 2 | The output is disabled by the over-current protection.
2 | PF | 4 | The output is disabled by the power-fail - which may be caused by a low-line or brownout condition on the AC line.
3 | CP+ | 8 | The output is limited (or disabled on some models) by the positive power limit.
4 | OT | 16 | The over-temperature protection has tripped.
5 | CP- | 32 | The output is limited by the negative power limit.
6-8 | Not Used | Not Used | 0 is returned.
9 | INH | 512 | The output is inhibited by an external signal.
10 | UNR | 1024 | The output is unregulated.
11 | PROT | 2048 | The output has been disabled because it is coupled to a protection condition that occurred on another channel.
12-15 | Not Used | Not Used | 0 is returned.

  • The STATus:PRESet command will clear all bits in the enable register.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the enable register.

STAT:QUES:ENAB 3,(@1)

The following query returns which bits are enabled in the register.

STAT:QUES:ENAB? (@1)

Typical Response: +3

See Also

STATus:QUEStionable[:EVENt]?

STATus:PRESet


STATus:QUEStionable:NTRansition

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:QUEStionable:NTRansition <value>, (@<chanlist>)

STATus:QUEStionable:NTRansition? (@<chanlist>)

Description

These command sets and reads the value of the Questionable NTR (Negative-Transition) register. This register serves as a polarity filter between the Questionable Condition and Questionable Event registers.

When a bit in the Questionable NTR register is set to 1, then a 1-to-0 transition of the corresponding bit in the Questionable Condition register causes that bit in the Questionable Event register to be set.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 0
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 5 (decimal value = 32), the corresponding decimal value would be 40 (8 + 32).

Remarks

  • The following table lists the bit definitions for the Questionable Status registers.

Bit Number |  | Decimal Value | Definition
0 | OV | 1 | The output is disabled by the over-voltage protection.
1 | OC | 2 | The output is disabled by the over-current protection.
2 | PF | 4 | The output is disabled by the power-fail - which may be caused by a low-line or brownout condition on the AC line.
3 | CP+ | 8 | The output is limited (or disabled on some models) by the positive power limit.
4 | OT | 16 | The over-temperature protection has tripped.
5 | CP- | 32 | The output is limited by the negative power limit.
6-8 | Not Used | Not Used | 0 is returned.
9 | INH | 512 | The output is inhibited by an external signal.
10 | UNR | 1024 | The output is unregulated.
11 | PROT | 2048 | The output has been disabled because it is coupled to a protection condition that occurred on another channel.
12-15 | Not Used | Not Used | 0 is returned.

  • If the same bits in both NTR and PTR registers are set to 1, then any transition of that bit at the Questionable Condition register sets the corresponding bit in the Questionable Event register.

  • If the same bits in both NTR and PTR registers are set to 0, then no transition of that bit at the Questionable Condition register can set the corresponding bit in the Questionable Event register.

  • The STATus:PRESet command will set all bits in the NTR register to 0.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the NTR register.

STAT:QUES:NTR 3,(@1)

The following query returns which bits are enabled in the register.

STAT:QUES:NTR? (@1)

Typical Response: +3

See Also

STATus:QUEStionable:PTRansition

STATus:PRESet


STATus:QUEStionable:PTRansition

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

STATus:QUEStionable:PTRansition <value>, (@<chanlist>)

STATus:QUEStionable:PTRansition? (@<chanlist>)

Description

These command sets and reads the value of the Questionable PTR (Positive-Transition) register. This register serves as a polarity filter between the Questionable Condition and Questionable Event registers.

When a bit in the Questionable PTR register is set to 1, then a 0-to-1 transition of the corresponding bit in the Questionable Condition register causes that bit in the Questionable Event register to be set.

For more information on the SCPI Status System, see the Status System diagram.

Parameters

Name | Type | Range of Values | Default Value
<value> | NR1 | A decimal value which corresponds to the binary-weighted sum of the bits in the register (see table below). | Preset = 3647
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

For example, to enable bit 3 (decimal value = 8) and bit 5 (decimal value = 32), the corresponding decimal value would be 40 (8 + 32).

Remarks

  • The following table lists the bit definitions for the Questionable Status registers.

Bit Number |  | Decimal Value | Definition
0 | OV | 1 | The output is disabled by the over-voltage protection.
1 | OC | 2 | The output is disabled by the over-current protection.
2 | PF | 4 | The output is disabled by the power-fail - which may be caused by a low-line or brownout condition on the AC line.
3 | CP+ | 8 | The output is limited (or disabled on some models) by the positive power limit.
4 | OT | 16 | The over-temperature protection has tripped.
5 | CP- | 32 | The output is limited by the negative power limit.
6-8 | Not Used | Not Used | 0 is returned.
9 | INH | 512 | The output is inhibited by an external signal.
10 | UNR | 1024 | The output is unregulated.
11 | PROT | 2048 | The output has been disabled because it is coupled to a protection condition that occurred on another channel.
12-15 | Not Used | Not Used | 0 is returned.

  • If the same bits in both NTR and PTR registers are set to 1, then any transition of that bit at the Questionable Condition register sets the corresponding bit in the Questionable Event register.

  • If the same bits in both NTR and PTR registers are set to 0, then no transition of that bit at the Questionable Condition register can set the corresponding bit in the Questionable Event register.

  • The STATus:PRESet command will set all bits in the PTR register to 1.

Return Format

<NR1>

The value returned is the binary-weighted sum of all bits set in the register.

Examples

The following command enables bits 0 and 1 (decimal value = 3) in the PTR register.

STAT:QUES:PTR 3,(@1)

The following query returns which bits are enabled in the register.

STAT:QUES:PTR? (@1)

Typical Response: +3

See Also

STATus:QUEStionable:NTRansition

STATus:PRESet


SYSTem Commands Introduction

System commands control system functions that are not directly related to output control, measurement, or status functions.

Common commands also control system functions such as self-test, saving and recalling states, and others.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

System Commands

Related Common Commands

SYSTem:CHANnel[:COUNt]?

SYSTem:CHANnel:MODel?

SYSTem:CHANnel:OPTion?

SYSTem:CHANnel:SERial?

SYSTem:COMMunicate:RLSTate

SYSTem:COMMunicate:RLSTate?

SYSTem:COMMunicate:TCPip:CONTrol?

SYSTem:DATE (N6705A only)

SYSTem:DATE? (N6705A only)

SYSTem:ERRor?

SYSTem:GROup:CATalog?

SYSTem:GROup:DEFine

SYSTem:GROup:DELete

SYSTem:GROup:DELete:ALL

SYSTem:PASSword:FPANel:RESet

SYSTem:REBoot

SYSTem:TIME (N6705A only)

SYSTem:TIME? (N6705A only)

SYSTem:VERSion?

*IDN?

*OPT?

*RCL

*RDT?

*RST

*SAV

*TST?


SYSTem:CHANnel[:COUNt]?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:CHANnel[:COUNt]?

Description

This query returns the number of output channels in a mainframe.

Return Format

<NR1>

The number of output channels.

Example

The following query returns the number of channels.

SYST:CHAN?

Typical Response: +4


SYSTem:CHANnel:MODel?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:CHANnel:MODel? (@<chanlist>)

Description

This query returns the model number of the selected output channel.

Return Format

<AARD>

The model number of the output channel. Multiple responses are separated by commas.

Example

The following query returns the model number in channels 2 and 3.

SYST:CHAN:MOD? (@2,3)

Typical Response: N6751A,N6761A


SYSTem:CHANnel:OPTion?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:CHANnel:OPTion? (@<chanlist>)

Description

This query returns a list of options installed in each channel given in the channel list.

Return Format

<SRD>

The query command returns an ASCII string enclosed in double quotes. If no option is installed, an empty quoted string ("") is returned. Multiple responses are separated by commas.

Example

The following query returns the options in channels 2 and 3.

SYST:CHAN:OPT? (@2,3)

Response with options installed in channel 2, none in channel 3: "Opt 054",""


SYSTem:CHANnel:SERial?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:CHANnel:SERial? (@<chanlist>)

Description

This query returns the serial number of the selected output channel.

Return Format

<AARD>

The serial number of the output channel. Multiple responses are separated by commas.

Example

The following query returns the serial numbers in channels 2 and 3.

SYST:CHAN:SER? (@2,3)

Typical Response: MY00123456,MY00234567


SYSTem:COMMunicate:RLSTate

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:COMMunicate:RLSTate <state>

SYSTem:COMMunicate:RLSTate?

Description

This command configures the remote/local state of the instrument according to the following settings:

LOCal | The instrument is set to front panel and remote interface control.
REMote | The instrument is set to front panel and remote interface control.
RWLock | The front panel keys are disabled. The instrument can only be controlled via the remote interface. This programmable setting is completely independent from the front panel lock/unlock function that is available from the front panel menu.

The remote/local state is unaffected by *RST or any SCPI commands other than SYSTem:COMMunicate:RLState.

Parameters

Name | Type | Range of Values | Default Value
<state> | CPD | LOCal | REMote | RWLock | LOCal (set at power-on)

Remarks

  • The remote/local instrument state can also be set by other interface commands over the GPIB and some other I/O interfaces.

  • When multiple remote programming interfaces are active, the interface with the most recently changed remote/local state determines the instrument’s remote/local state.

Return Format

<CRD>

The query command returns LOC, REM, or RWL.

Examples

The following command sets the remote/local state of the power system.

SYST:COMM:RLST REMote

The following query returns the remote/local state of the power system.

SYST:COMM:RLST?

Typical Response: LOC


SYSTem:COMMunicate:TCPip:CONTrol?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:COMMunicate:TCPip:CONTrol?

Description

This query returns the control connection port number. This is used to open a control socket connection to the instrument. Unlike the data socket, which uses a fixed port number (5025 for Agilent instruments), the port number for a control socket varies, and must be obtained using this query.

Refer to chapter 3 of the User's Guide under “Using Sockets” for more information.

Remarks

  • After the control port number is obtained, a control socket connection can be opened.

  • The control socket connection can only be used by a client to send a Device Clear to the instrument or to detect Service Request (SRQ) events.

  • All commands to the control socket must be terminated with a newline <NL>, and all query responses returned on the control socket will be terminated with a newline.

Return Format

<NR1>

The Control connection port number.

Example

The following query returns the Control connection port number.

SYST:COMM:TCP:CONT?

Typical Response: +5000


SYSTem:DATE

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:DATE <yyyy>,<mm>,<dd>

SYSTem:DATE?

Description

This command sets the date of the real time clock in year (yyyy), month (mm), and day (dd).

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<yyyy> | NR1 | An 4-digit integer representing the year | Required parameter
<mm> | NR1 | An integer from 1 to 12 | Required parameter
<dd> | NR1 | An integer from 1 to 31 | Required parameter

Return Format

<NR1>

The query command returns comma-separated values that correspond to the year, month, and day.

Examples

The following command sets the date (April 1, 2007).

SYST:DATE 2007,4,1

The following query returns the date.

SYST:DATE?

Typical Response: 2007,4,1


SYSTem:ERRor?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:ERRor?

Description

This query returns the next error number and its corresponding message string from the error queue.

For a complete listing of the Agilent N6700 power system error messages, see SCPI Error Messages.

Remarks

  • The front-panel ERR annunciator turns on when one or more errors are currently stored in the error queue.

  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored.

  • Errors are cleared as you read them. When you have read all errors from the error queue, the ERR annunciator turns off and the errors are cleared.

  • If more errors have accumulated than the queue can hold, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".

  • The error queue is cleared by the *CLS (Clear Status) command and when power is cycled. The errors are also cleared when you read the error queue.

Return Format

<NR1>,<SRD>

The error string may contain up to 80 characters and consists of an error number and an error string enclosed in double quotes. For example: -113,"Undefined header".

Example

The following query reads and clears one error.

SYST:ERR?

Typical Response: -101,"Invalid character"


SYSTem:GROup:CATalog?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:GROup:CATalog?

Description

This query returns information about channels that are grouped. The defined groups are enclosed in quotes.

Return Format

<SRD>

The defined groups in quotes. Multiple responses are separated by commas.

Example

The following query returns the channels that are grouped.

SYST:GRO:CAT?

Response with 4 channels; none grouped: "1","2","3","4"

Response with channels 1 + 2 grouped; 3 + 4 grouped: "1,2","3,4"

Response with channels 1 - 3 grouped; channel 4 not grouped: "1,2,3","4"


SYSTem:GROup:DEFine

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:GROup:DEFine (@<chanlist>)

Description

This command defines a list of output channels as a paralleled group. This effectively creates a single output with higher current and power capability. You can group up to four channels per mainframe. All channels in a group must have identical model numbers and have identical options installed.

After the channels are wired in parallel and defined as a group, they can be addressed using any of the channel-specific SCPI commands by sending the channel number of the LOWEST channel in the group.

All grouped channels must have their output terminals connected in parallel and their sense terminals connected in parallel.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | Two or more channels. (@1,2) - channels 1 and 2 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • For the group changes to take effect, you must reboot the unit. Either cycle AC power or send the SYSTem:REBoot command.

  • Group channel definitions are stored in non-volatile memory and are unaffected by *RST or *RCL.

  • Group channel settings (voltage, current, etc.) are set and saved by *RST or *RCL.

  • This command also deletes any previously saved states.

Example

The following command defines channels 1 , 2, and 3 as a group.

SYST:GRO:DEF (@1:3)

The following command defines channels 1 and 4 as a group.

SYST:GRO:DEF (@1,4)


SYSTem:GROup:DELete

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:GROup:DELete <channel>

Description

This command removes the indicated channel from a group. It leaves the other channels in the group intact.

When ungrouping a channel, you must also remove the parallel connections between the output and sense terminals of that channel.

Parameters

Name | Type | Range of Values | Default Value
<channel> | NR1 | 1 | 2 | 3 | 4 | Required parameter

Remarks

  • For the group changes to take effect, you must reboot the unit. Either cycle AC power or send the SYSTem:REBoot command.

  • This command also deletes any previously saved states.

Example

The following command deletes channel 3 from a group.

SYST:GRO:DEL 3


SYSTem:GROup:DELete:ALL

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:GROup:DELete:ALL

Description

This command deletes all groups on a mainframe. It returns any channels that have been grouped back to an ungrouped state.

When ungrouping channels, you must also remove all paralleled sense and output terminal connections between channels.

Remarks

  • For the group changes to take effect, you must reboot the unit. Either cycle AC power or send the SYSTem:REBoot command.

  • This command also deletes any previously saved states.

Example

The following command deletes all groups.

SYST:GRO:DEL:ALL


SYSTem:PASSword:FPANel:RESet

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:PASSword:FPANel:RESet

Description

This command resets the front panel lockout password to the factory-shipped setting, which is zero (0). This command does not reset the calibration password.

The front panel password can also be reset to 0 by setting an internal switch on the unit. This switch will also reset the calibration password to 0. Refer to the Service Manual under “Calibration Switches” for more information.

Example

The following command resets the front panel password.

SYST:PASS:FPAN:RES

See Also

*RST


SYSTem:REBoot

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:REBoot

Description

This command causes the power system to reboot to its power-on state.

Example

The following command reboots the power system.

SYST:REB

See Also

*RST


SYSTem:TIME

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

SYSTem:TIME <hh>,<mm>,<ss>

SYSTem:TIME?

Description

This command sets the real time clock in hours (hh), minutes (mm), and seconds (ss).

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<hh> | NR1 | An integer from 0 to 23 | Required parameter
<mm> | NR1 | An integer from 0 to 59 | Required parameter
<ss> | NR1 | An integer from 0 to 59 | Required parameter

Return Format

<NR1>

The query command returns comma-separated values that correspond to the hours, minutes, and seconds.

Examples

The following command sets a time.

SYST:TIME 12,30,0

The following query returns the time of the clock.

SYST:TIME?

Typical Response: 12,30,0


SYSTem:VERSion?

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

SYSTem:VERSion?

Description

This command returns the version of the SCPI (Standard Commands for Programmable Instruments) standard with which the instrument is in compliance.

Return Format

<SRD>

The command returns a string in the form "YYYY.V", where YYYY represents the year of the version and V represents a version for that year.

Example

The following query returns the SCPI version.

SYST:VERS?

Typical Response: "1997.0"


TRIGger Subsystem Introduction

Trigger commands control the remote triggering of the instrument. They specify the trigger source for the transient and the measurement system and also generate software triggers.

The Common command *TRG is also used to trigger the instrument.

Command Summary

Hold the mouse cursor over a command to view the full syntax statement.

Trigger Commands

Related Initiate and Abort Commands

TRIGger:ACQuire[:IMMediate]

TRIGger:ACQuire:SOURce

TRIGger:ACQuire:SOURce?

TRIGger:DLOG[:IMMediate] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel] (N6705A only)

TRIGger:DLOG:CURRent[:LEVel]? (N6705A only)

TRIGger:DLOG:CURRent:SLOPe (N6705A only)

TRIGger:DLOG:CURRent:SLOPe? (N6705A only)

TRIGger:DLOG:SOURce (N6705A only)

TRIGger:DLOG:SOURce? (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel] (N6705A only)

TRIGger:DLOG:VOLTage[:LEVel]? (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe (N6705A only)

TRIGger:DLOG:VOLTage:SLOPe? (N6705A only)

TRIGger:TRANsient[:IMMediate]

TRIGger:TRANsient:SOURce

TRIGger:TRANsient:SOURce?

INITiate[:IMMediate]:ACQuire

INITiate[:IMMediate]:DLOG (N6705A only)

INITiate[:IMMediate]:TRANsient

INITiate:CONTinuous:TRANsient

INITiate:CONTinuous:TRANsient?

ABORt:ACQuire

ABORt:DLOG (N6705A only)

ABORt:TRANsient


TRIGger:ACQuire[:IMMediate]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

TRIGger:ACQuire[:IMMediate] (@<chanlist>)

Description

This command sends an immediate trigger to the measurement system. When the trigger system is initiated, a measurement trigger causes the power system to measure the output voltage or current, and store the results in a buffer.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • You must initiate the measurement trigger system before you can send any triggers.

  • The measured quantity, either voltage or current, must be specified by the SENSe:FUNCtion command.

  • When the triggered measurement has completed, the WTG-meas bit in the Status Operation Condition register is cleared.

Example

The following command generates a measurement trigger on channels 1 and 2.

TRIG:ACQ (@1,2)

See Also

INITiate[:IMMediate]:ACQuire

SENSe:FUNCtion

*TRG


TRIGger:ACQuire:SOURce

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:ACQuire:SOURce <source>, (@<chanlist>)

TRIGger:ACQuire:SOURce? (@<chanlist>)

Description

This command selects the trigger source for the measurement trigger system. The following trigger sources can be selected:

BUS | Selects GPIB device trigger, *TRG, or <GET> (Group Execute Trigger).
PIN<n> | Selects an output port connector pin. <n> specifies the pin number.
TRANsient<n> | Selects the transient system of an output channel as the trigger source. <n> specifies the channel.

Parameters

Name | Type | Range of Values | Default Value
<source> | CPD | BUS | PIN<1-7> | TRANsient<1-4> | BUS
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3 | Required parameter

Remarks

  • Pins 1 – 7 must be configured as trigger outputs before they can be used as a trigger source. See [SOURce:]DIGital:PIN<n>:FUNCtion and [SOURce:]DIGital:PIN<n>:POLarity.

  • You must also configure the transient system to use it as a trigger source. See: [SOURce:]STEP:TOUTput, [SOURce:]LIST:TOUTput:BOSTep, and [SOURce:]LIST:TOUTput:EOSTep

Return Format

<CRD>

The query command returns BUS, PIN<1-7>, or TRAN<1-4>.

Examples

The following command selects pin 1 as the measurement trigger source for channel 2.

TRIG:ACQ:SOUR PIN1,(@2)

The following query returns the measurement trigger source of channel 1.

TRIG:ACQ:SOUR? (@1)

Typical Response: BUS

See Also

[SOURce:]DIGital:PIN<1-7>:FUNCtion

[SOURce:]DIGital:PIN<1-7>:POLarity

[SOURce:]STEP:TOUTput

[SOURce:]LIST:TOUTput:BOSTep

[SOURce:]LIST:TOUTput:EOSTep


TRIGger:DLOG[:IMMediate]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

TRIGger:DLOG[:IMMediate]

Description

This command sends an immediate trigger signal to the data logger. This will trigger the datalog regardless of the selected data logger trigger source.

This command only applies to the Agilent N6705A DC Power Analyzer.

Remarks

  • You must initiate (run) the data logger before you trigger it.

Example

The following command triggers the data logger.

TRIG:DLOG

See Also

INITiate[:IMMediate]:DLOG

SENSe:DLOG:FUNCtion:CURRent

SENSe:DLOG:FUNCtion:VOLTage

*TRG


TRIGger:DLOG:CURRent[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DLOG:CURRent[:LEVel] <current>, (@<chanlist>)

TRIGger:DLOG:CURRent[:LEVel]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the triggered current level of the specified output channel when the trigger source for the datalogger is set to a current. Units are in amperes.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<current> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the current rating of the power module. | MIN
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The output channel specified with this command must match the output channel specified by TRIGger:DLOG:SOURce.

Return Format

<NR3>

The query command returns the programmed trigger level in the form +1.000000E+01 for the specified output channel.

Examples

The following command sets the triggered datalog current level to 2 A on channel 2.

TRIG:DLOG:CURR 2,(@2)

The following query returns the programmed triggered datalog current level.

TRIG:DLOG:CURR (@2)

Typical Response: +2.000000E+00

See Also

TRIGger:DLOG:SOURce


TRIGger:DLOG:CURRent:SLOPe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DLOG:CURRent:SLOPe <slope>, (@<chanlist>)

TRIGger:DLOG:CURRent:SLOPe? (@<chanlist>)

Description

This command sets the slope of the current level of the specified output channel when the trigger source for the data logger is set to a current.

POSitive | Specifies a rising slope of the output signal.
NEGative | Specifies a falling slope of the output signal.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<slope> | CPD | POSitive | NEGative | POS
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The output channel specified with this command must match the output channel specified by TRIGger:DLOG:SOURce.

Return Format

<CRD>

The query command returns POS or NEG.

Examples

The following command sets the current slope to Positive on output channel 2.

TRIG:DLOG:CURR:SLOP POS,(@2)

The following query returns the current slope on output channel 2.

TRIG:DLOG:CURR:SLOP (@2)

Typical Response: POS

See Also

TRIGger:DLOG:SOURce


TRIGger:DLOG:SOURce

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DLOG:SOURce <source>

TRIGger:DLOG:SOURce?

Description

This command selects the trigger source for the data logger. The following trigger sources can be selected:

IMMediate | Triggers the data logger immediately.
EXTernal | Selects the rear panel Trigger In connector
BUS | Selects a remote interface command
VOLTage<n> | Selects a voltage level. <n> specifies the output channel.
CURRent<n> | Selects a current level. <n> specifies the output channel.
ARSKey | Selects the Arb Run/Stop key.
OOOKey | Selects the Output On/Off keys and the All Outputs On/Off keys.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<source> | CPD | IMMediate | EXTernal | BUS | VOLTage<1-4> | CURRent<1-4> | ARSKey | OOOKey | IMM

Remarks

  • If you have selected a voltage or current level as the rigger source, you must also program the voltage or current level and the polarity. See: TRIGger:DLOG:CURRent, TRIGger:DLOG:CURRent:SLOPe, TRIGger:DLOG:VOLTage, TRIGger:DLOG:VOLTage:SLOPe

Return Format

<CRD>

The query command returns IMM, EXT, BUS, VOLT<1-4>, CURR<1-4>, ARSK, or OOOK.

Examples

The following command selects the Output On/Off key as the data logger trigger source.

TRIG:DLOG:SOUR OOOK

The following query returns the data logger trigger source.

TRIG:DLOG:SOUR?

Typical Response: VOLT1

See Also

TRIGger:DLOG:CURRent

TRIGger:DLOG:CURRent:SLOPe

TRIGger:DLOG:VOLTage

TRIGger:DLOG:VOLTage:SLOPe


TRIGger:DLOG:VOLTage[:LEVel]

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DLOG:VOLTage[:LEVel] <voltage>, (@<chanlist>)

TRIGger:DLOG:VOLTage[:LEVel]? [MIN|MAX,] (@<chanlist>)

Description

This command sets the triggered voltage level of the specified output channel when the trigger source for the datalogger is set to a voltage. Units are in volts.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<voltage> | NRf+ | 0 - maximum | MIN | MAX The maximum value is dependent on the voltage rating of the power module. | MIN
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The output channel specified with this command must match the output channel specified by TRIGger:DLOG:SOURce.

Return Format

<NR3>

The query command returns the programmed trigger level in the form +1.000000E+01 for the specified output channel.

Examples

The following command sets the triggered datalog voltage level to 5 V on channel 2.

TRIG:DLOG:VOLT 5,(@2)

The following query returns the programmed triggered datalog voltage level.

TRIG:DLOG:VOLT (@2)

Typical Response: +5.000000E+00

See Also

TRIGger:DLOG:SOURce


TRIGger:DLOG:VOLTage:SLOPe

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:DLOG:VOLTage:SLOPe <slope>, (@<chanlist>)

TRIGger:DLOG:VOLTage:SLOPe? (@<chanlist>)

Description

This command sets the slope of the voltage level of the specified output channel when the trigger source for the data logger is set to a voltage.

POSitive | Specifies a rising slope of the output signal.
NEGative | Specifies a falling slope of the output signal.

This command only applies to the Agilent N6705A DC Power Analyzer.

Parameters

Name | Type | Range of Values | Default Value
<slope> | CPD | POSitive | NEGative | POS
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • The output channel specified with this command must match the output channel specified by TRIGger:DLOG:SOURce.

Return Format

<CRD>

The query command returns POS or NEG.

Examples

The following command sets the voltage slope to Positive on output channel 2.

TRIG:DLOG:VOLT:SLOP POS,(@2)

The following query returns the voltage slope on output channel 2.

TRIG:DLOG:VOLT:SLOP (@2)

Typical Response: POS

See Also

TRIGger:DLOG:SOURce


TRIGger:TRANsient[:IMMediate]

Syntax | Description | Parameters | Remarks | Return Format | Example

Syntax

TRIGger:TRANsient[:IMMediate] (@<chanlist>)

Description

This command generates an immediate transient trigger regardless of the selected trigger source. Output triggers affect the following functions: voltage, current, and current limit.

Parameters

Name | Type | Range of Values | Default Value
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3. | Required parameter

Remarks

  • You must initiate the output trigger system before you can send any triggers.

  • When sent, the transient trigger will initiate an output change as specified by the CURRent:TRIGgered or VOLTage:TRIGgered commands.

  • When the transient trigger sequence has completed, the WTG-tran bit in the Status Operation Condition register is cleared.

Example

The following command generates an output trigger on channels 1 and 2.

TRIG:TRAN (@1,2)

See Also

INITiate[:IMMediate]:TRANsient

[SOURce:]CURRent[:LEVel]:TRIGgered

[SOURce:]VOLTage[:LEVel]:TRIGgered

*TRG


TRIGger:TRANsient:SOURce

Syntax | Description | Parameters | Remarks | Return Format | Examples

Syntax

TRIGger:TRANsient:SOURce <source>, (@<chanlist>)

TRIGger:TRANsient:SOURce? (@<chanlist>)

Description

This command selects the trigger source for the output trigger system. The following trigger sources can be selected:

BUS | Selects GPIB device trigger, *TRG, or <GET> (Group Execute Trigger).
PIN<n> | Selects an output port connector pin. <n> specifies the pin number.
TRANsient<n> | Selects the transient system of an output channel as the trigger source. <n> specifies the channel.

Parameters

Name | Type | Range of Values | Default Value
<source> | CPD | BUS | PIN<1-7> | TRANsient<1-4> | BUS
<chanlist> | Numeric | One or more channels. (@2) - channel 2 (@1,4) - channels 1 and 4 (@1:3) - channels 1 through 3 | Required parameter

Remarks

  • Pins 1 – 7 must be configured as trigger outputs before they can be used as a trigger source. See [SOURce:]DIGital:PIN<n>:FUNCtion and [SOURce:]DIGital:PIN<n>:POLarity.

  • You must also configure the transient system to use it as a trigger source. See: [SOURce:]STEP:TOUTput, [SOURce:]LIST:TOUTput:BOSTep, and [SOURce:]LIST:TOUTput:EOSTep

Return Format

<CRD>

The query command returns BUS, PIN<1-7>, or TRAN<1-4>.

Examples

The following command selects pin 1 as the output trigger source for channel 2.

TRIG:TRAN:SOUR PIN1,(@2)

The following query returns the output trigger source of channel 1.

TRIG:TRAN:SOUR? (@1)

Typical Response: BUS

See Also

[SOURce:]DIGital:PIN<1-7>:FUNCtion

[SOURce:]DIGital:PIN<1-7>:POLarity

[SOURce:]STEP:TOUTput

[SOURce:]LIST:TOUTput:BOSTep

[SOURce:]LIST:TOUTput:EOSTep


Command Quick Reference

Printable PDF Version

Some [optional] commands have been included for clarity. All settings commands have a corresponding query. Not all commands apply to all models.

Abort Commands

ABORt |
:ACQuire (@<chanlist>) | Resets the measurement trigger system to the Idle state
:ACQuire:DLOG | Stops a running datalog (only on Agilent N6705A)
:TRANsient (@<chanlist>) | Resets the transient trigger system to the Idle state

Calibrate Commands

CALibrate |
:CURRent |
[:LEVel] <NRf>, (@<channel>) | Calibrates the output current programming
:MEASure <NRf>, (@<channel>) | Calibrates the current measurement
:PEAK (@channel) | Calibrates the peak current limit (Agilent N6751A/52A/61A/62A)
:DATA <NRf> | Enters the calibration value
:DATE <SPD>, (@<channel>) | Sets the calibration date
:DPRog (@<channel>) | Calibrates the current downprogrammer
:LEVel P1 | P2 | P3 | Advances to the next calibration step
:PASSword <NRf> | Sets the numeric calibration password
:SAVE | Saves the new cal constants in non-volatile memory
:STATE <Bool> [,<NRf>] | Enables/disables calibration mode
:VOLTage |
[:LEVel] <NRf>, (@<channel>) | Calibrates the output voltage programming
:CMRR (@channel) | Calibrates common mode rejection ratio (Agilent N6751A/52A/61A/62A)
:MEASure <NRf>, (@<channel>) | Calibrates the voltage measurement

Display Commands

DISPlay |
[:WINDow] |
:VIEW METER1 | METER4 | Selects 1-channel or 4-channel meter view

Fetch Commands

FETCh | (Agilent N6761A/62A and Option 054)
[:SCALar] |
:CURRent [:DC]? (@<chanlist>) | Returns the average output current
:VOLTage [:DC]? (@<chanlist>) | Returns the average output voltage
:ARRay |
:CURRent [:DC]? (@<chanlist>) | Returns the instantaneous output current
:VOLTage [:DC]? (@<chanlist>) | Returns the instantaneous output voltage

HCopy Commands

HCOPY |
:SDUMP |
:DATA | Returns an image of the display in .gif format (only on Agilent N6705A)

Initiate Commands

INITiate |
[:IMMediate] |
:ACQuire (@<chanlist>) | Enables the measurement system to receive triggers (Agilent N6761A/62A and Option 054)
:DLOG "filename" | Enables the data logger function (only on Agilent N6705A)
:TRANsient (@<chanlist>) | Enables the output transient system to receive triggers
:CONTinuous |
:TRANsient <Bool>, (@<chanlist>) | Enables/disables continuous transient triggers

Measure Commands

MEASure |
[:SCALar] |
:CURRent [:DC]? (@<chanlist>) | Takes a measurement; returns the average output current
:VOLTage [:DC]? (@<chanlist>) | Takes a measurement; returns the average output voltage
:ARRay | (Agilent N6761A/62A and Option 054)
:CURRent [:DC]? (@<chanlist>) | Takes a measurement; returns the instantaneous output current
:VOLTage [:DC]? (@<chanlist>) | Takes a measurement; returns the instantaneous output voltage

MMemory Commands

MMEMory |
:ATTRibute? “object”, “attribute” | Gets the attributes of a file system object (only on Agilent N6705A)
:DATA[:DEFinite]? “filename” | Gets the file contents; response is a definite length binary block (only on Agilent N6705A)
:DELete “filename” | Deletes a file (only on Agilent N6705A)
:EXPort:DLOG “filename” | Exports a datalog from the display to a file (only on Agilent N6705A)

Output Commands

OUTPut |
[:STATe] <Bool> [,NORelay], (@<chanlist>) | Enables/disables the specified output channel(s)
:COUPle |
[:STATe] | Enables/disables channel coupling for output synchronization
:CHANnel | Selects which channels are coupled
:DOFFset | Specifies a maximum delay offset to synchronize output changes
:DOFFset:MODE AUTO | MANual | Specifies the output delay coupling mode
:MAX:DOFFset? | Returns the maximum delay offset required for a mainframe
:DELay |
:FALL <NRf+>, (@<chanlist>) | Sets the output turn-off sequence delay
:RISE <NRf+>, (@<chanlist>) | Sets the output turn-on sequence delay
:PMODe VOLTage | CURRent, (@chanlist) | Sets the mode for turn on/off transitions (Agilent N6761A/62A)
:INHibit |
:MODE LATChing | LIVE | OFF | Sets the remote inhibit input
:PON |
:STATe RST | RCL0 | Programs the power-on state
:PROTection |
:CLEar (@channel) | Resets latched protection
:COUPle <Bool> | Enables/disables channel coupling for protection faults
:DELay <NRf>, (@<chanlist>) | Sets over-current protection programming delay
:RELay | (Option 760)
:POLarity NORMal | REVerse, (@<chanlist>) | Sets the output relay polarity

Sense Commands

SENSe |
:CURRent |
[:DC]:RANGe [:UPPer] <NRf+>, (@<chanlist>) | Selects the current measurement range (Agilent N6761A/62A)
CCOMpensate <Bool>, (@chanlist) | Enables/disables the capacitive current compensation
:DLOG | (DLOG commands only on Agilent N6705A)
:FUNCtion |
:CURRent <Bool>, (@chanlist) | Enables/disables current datalogging
:MINMax <Bool> | Enables/disables min/max datalogging
:VOLTage <Bool>, (@chanlist) | Enables/disables voltage datalogging
:OFFSet <NR1> | Sets trigger offset as a percent from start of datalog duration
:TIME <NRf+> | Sets the duration of the datalog in seconds
:TINTerval <NRf+> | Sets the time interval between datalog samples
:FUNCtion “VOLTage” | ”CURRent”, (@<chanlist>) | Selects the measurement function
:SWEep |
:OFFSet |
:POINts <NRf+>, (@<chanlist>) | Defines the trigger offset in the measurement sweep
:POINts <NRf+>, (@<chanlist>) | Defines the number of data points in the measurement
:TINTerval <NRf+>, (@<chanlist>) | Sets the measurement sample interval
:VOLTage |
[:DC] |
:RANGe [:UPPer] <NRf+>, (@<chanlist>) | Selects the voltage measurement range (Agilent N6761A/62A)
:WINDow |
[:TYPE] HANNing | RECTangular, (@<chanlist>) | Selects the measurement window (Agilent N6761A/62A and Option 054)

Source Commands

[SOURce:] |
CURRent |
[:LEVel] |
[:IMMediate] |
[:AMPLitude] <NRf+>, (@<chanlist>) | Sets the output current
:TRIGgered |
[:AMPLitude] <NRf+>, (@<chanlist>) | Sets the triggered output current
:MODE FIXed | STEP | LIST, (@<chanlist>) | Sets the current trigger mode
:PROTection |
:STATe <Bool>, (@<chanlist>) | Enables/disables over-current protection on the selected output
:RANGe <NRf+>, (@<chanlist>) | Sets the output current range (Agilent N6761A/62A)
DIGital |
:INPut:DATA? | Reads the state of the digital port pins
:OUTPut:DATA <NRf> | Sets the digital port
:PIN<1-7> |
:FUNCtion DIO|DINP|TOUT|TINP|FAUL|INH|ONC|OFFC | Sets the selected pin’s function
:POLarity POSitive | NEGative | Sets the selected pin’s polarity
LIST | (Agilent N6761A/62A and Option 054)
:COUNt <NRf+> | INFinity, (@<chanlist>) | Sets the list repeat count
:CURRent |
[:LEVel] <NRf> {,<NRf>}, (@<chanlist>) | Sets the current list
:POINts? (@<chanlist>) | Returns the number of current list points
:DWELl <NRf> {,<NRf>}, (@<chanlist>) | Sets the list of dwell times
:POINts? (@<chanlist>) | Returns the number of dwell list points
:STEP ONCE | AUTO, (@<chanlist>) | Specifies how the list responds to triggers
:TERMinate |
:LAST <Bool>, (@<chanlist>) | Sets the list termination mode
:TOUTput |
:BOSTep |
[:DATA] <Bool> {,<Bool>}, (@<chanlist>) | Generate triggers at the Beginning Of Step
:POINts? (@<chanlist>) | Returns the number of BOS list points
:EOSTep |
[:DATA] <Bool> {,<Bool>}, (@<chanlist>) | Generate triggers at the End Of Step
:POINts? (@<chanlist>) | Returns the number of EOS list points
:VOLTage |
[:LEVel] <NRf> {,<NRf>}, (@<chanlist>) | Sets the voltage list
:POINts? (@<chanlist>) | Returns the number of voltage list points
POWer |
:LIMit <NRf+>, (@<chanlist>) | Sets the power limit on output channels
STEP |
:TOUTput <Bool>, (@<chanlist>) | Generate a trigger output on the voltage or current step transient
VOLTage |
[:LEVel] |
[:IMMediate] |
[:AMPLitude] <NRf+>, (@<chanlist>) | Sets the output voltage
:TRIGgered |
[:AMPLitude] <NRf+>, (@<chanlist>) | Sets the triggered output voltage
:MODE FIXed | STEP | LIST, (@<chanlist>) | Sets the voltage trigger mode
:PROTection |
[:LEVel] <NRf+>, (@<chanlist>) | Sets the over-voltage protection level
:RANGe <NRf+>, (@<chanlist>) | Sets the output voltage range (Agilent N6761A/62A)
:SENSe |
:SOURce INTernal | EXTernal, (@chanlist) | Sets the state of the remote sense relays (only on Agilent N6705A)
:SLEW |
[:IMMediate] <NRf+> | INFinity, (@<chanlist>) | Sets the output voltage slew rate

Status Commands

STATus |
:OPERation |
[:EVENt]? (@<chanlist>) | Returns the value of the operation event register
:CONDition? (@<chanlist>) | Returns the value of the operation condition register
:ENABle <NRf>, (@<chanlist>) | Enables specific bits in the Event register
:NTRansition <NRf>, (@<chanlist>) | Sets the Negative transition filter
:PTRansition <NRf>, (@<chanlist>) | Sets the Positive transition filter
:PRESet | Presets all enable and transition registers to power-on
:QUEStionable |
[:EVENt]? (@<chanlist>) | Returns the value of the questionable event register
:CONDition? (@<chanlist>) | Returns the value of the questionable condition register
:ENABle <NRf>, (@<chanlist>) | Enables specific bits in the Event register
:NTRansition <NRf>, (@<chanlist>) | Sets the Negative transition filter
:PTRansition <NRf>, (@<chanlist>) | Sets the Positive transition filter

System Commands

SYSTem |
:CHANnel |
[:COUNt]? | Returns the number of output channels in a mainframe
:MODel? (@<chanlist>) | Returns the model number of the selected channel
:OPTion? (@<chanlist>) | Returns the option installed in the selected channel
:SERial? (@<chanlist>) | Returns the serial number of the selected channel
:COMMunicate |
:RLSTate LOCal | REMote | RWLock | Specifies the Remote/Local state of the instrument
:TCPip:CONTrol? | Returns the control connection port number
:DATE <yyyy>,<mm>,<dd> | Sets the date of the system clock
:ERRor | Returns the error number and error string
:GROup |
:CATalog? | Returns the groups that have been defined
:DEFine (@<chanlist>) | Group multiple channels together to create a single output
:DELete <channel> | Removes the specified channel from a group
:ALL | Ungroups all channels
:PASSword |
:FPANel |
:RESet | Resets the front panel password to zero
:REBoot | Returns the unit to its power-on state
:TIME <hh>,<mm>,<ss> | Sets the time of the system clock
:VERSion? | Returns the SCPI version number

Trigger Commands

TRIGger |
:ACQuire | (Agilent N6761A/62A and Option 054)
[:IMMediate] (@<chanlist>) | Triggers the measurement immediately
:SOURce BUS | PIN<n> | TRAN<n>, (@<chanlist>) | Sets the measurement trigger source
:DLOG | (DLOG commands only on Agilent N6705A)
[:IMMediate] | Triggers the data logger immediately
:CURRent |
[:LEVel] <NRf>, (@chanlist) | Sets the current trigger level of the data logger
:SLOPe POSitive | NEGative, (@chanlist) | Sets the current trigger slope of the data logger
:SOURce IMM|EXT|BUS|VOLT<1-4>| CURR<1-4>|ARSKey | OOOKey | Sets the source of data logger trigger
:VOLTage | Sets the voltage trigger level of the data logger
[:LEVel] <NRf>, (@chanlist) | Sets the voltage trigger slope of the data logger
:SLOPe POSitive | NEGative, (@chanlist) |
:TRANsient | (Agilent N6761A/62A and Option 054)
[:IMMediate] (@<chanlist>) | Triggers the output immediately
:SOURce BUS | PIN<n> | TRAN<n>, (@<chanlist>) | Sets the output trigger source

Common Commands

*CLS | Clear status
*ESE <NRf> | Standard event status enable
*ESR? | Return event status register
*IDN? | Return instrument identification
*OPC | Enable "operation complete" bit in ESR
*OPT? | Return option number
*RCL <NRf> | Recalls a saved instrument state
*RDT? | Return output channel descriptions
*RST | Reset
*SAV <NRf> | Saves an instrument state
*SRE <NRf> | Set service request enable register
*STB? | Return status byte
*TRG | Trigger
*TST? | Performs self-test, then returns result
*WAI | Pauses additional command processing until all device commands are done


Non-Volatile Settings

The following tables show the factory-shipped non-volatile settings of the instrument. Information in non-volatile memory is NOT lost when power is turned off. These settings are all customer-configurable.

The factory-shipped LAN settings can be restored by selecting the front panel Reset control located in the System\I/O\LAN\Config\Reset menu.

All non-volatile settings including LAN, can be restored by selecting the front panel Reset control located in the System\Admin\Nvram menu.

Factory-shipped non-volatile LAN settings
DHCP | Enabled
AutoIP | Enabled
IP Address | 169.254.67.0
Subnet Mask | 255.255.0.0
Default Gateway | 0.0.0.0
Obtain DNS server from DHCP | Enabled
DNS server | Blank
Hostname | A-N6700B-xxxxx
Use DNS naming service | Enabled
Use NetBIOS naming service | Enabled
Domain Name | Blank
TCP keepalive | C
TCP keepalive seconds | 1800

Other factory-shipped non-volatile settings
Admin/Calibration password | 0 (zero)
Calibration date | March 5, 2003
Channel grouping | No groups
Digital port function (all pins) | Digital In
Digital port polarity (all pins) | Positive
Front panel lockout | Disabled
Front panel meter view | 1-channel
GPIB Address | 5
Key clicks | Enabled
LAN interface | Enabled
On/Off key affects all channels | Disabled
Output inhibit mode | Off
Saved states | *RST command
Screen contrast | 50%
Screen saver | Enabled
Screen saver delay | 60 minutes
USB interface | Enabled
Wake on I/O | Enabled
Web server | Enabled


Reset Settings (*RST)

The following tables show the state of the instrument after a *RST command is issued.

Calibration Function | *RST Setting
CAL:STAT | OFF

Current Function | *RST Setting
[SOUR:]CURR | 0.08
[SOUR:]CURR:MODE | FIX
[SOUR:]CURR:PROT:STAT | OFF
[SOUR:]CURR:RANG | MAX
[SOUR:]CURR:TRIG | MIN

Digital Function | *RST Setting
[SOUR:]DIG:OUTP:DATA | 0

Display Function | *RST Setting
DISP:VIEW | METER1

Initiate Function | *RST Setting
INIT:CONT:TRAN | OFF

List Function | *RST Setting
[SOUR:]LIST:COUN | 1
[SOUR:]LIST:CURR | MIN
[SOUR:]LIST:DWEL | 0.001
[SOUR:]LIST:STEP | AUTO
[SOUR:]LIST:TERM:LAST | OFF
[SOUR:]LIST:TOUT:BOST | OFF
[SOUR:]LIST:TOUT:EOST | OFF
[SOUR:]LIST:VOLT | MIN

Output Function | *RST Setting
OUTP | OFF
OUTP:COUP | OFF
OUTP:DEL:FALL | 0
OUTP:DEL:RISE | 0
OUTP:PMOD | VOLT
OUTP:PROT:COUP | OFF
OUTP:PROT:DEL | 0.02
OUTP:REL:POL | NORM

Power Function | *RST Setting
[SOUR:]POW:LIM | MAX

Sense Function | *RST Setting
SENS:CURR:RANG | MAX
SENS:CURR:CCOM | ON
SENS:DLOG:FUNC:CURR | OFF
SENS:DLOG:FUNC:MINM | OFF
SENS:DLOG:FUNC:VOLT | ON
SENS:DLOG:OFFS | 0
SENS:DLOG:TIME | 30
SENS:DLOG:TINT | 0.1
SENS:FUNC | "VOLT"
SENS:SWE:POIN | 1024
SENS:SWE:OFFS:POIN | 0
SENS:SWE:TINT | 20.48E-06
SENS:VOLT:RANG | MAX
SENS:WIND | RECT

Step Function | *RST Setting
[SOUR:]STEP:TOUT | FALSE

Trigger Function | *RST Setting
TRIG:ACQ:SOUR | BUS
TRIG:DLOG:CURR | MIN
TRIG:DLOG:CURR:SLOP | POS
TRIG:DLOG:SOUR | IMM
TRIG:DLOG:VOLT | MIN
TRIG:DLOG:VOLT:SLOP | POS
TRIG:TRAN:SOUR | BUS

Voltage Function | *RST Setting
[SOUR:]VOLT | MIN
[SOUR:]VOLT:MODE | FIX
[SOUR:]VOLT:PROT | MAX
[SOUR:]VOLT:RANG | MAX
[SOUR:]VOLT:SLEW | 9.9E+37
[SOUR:]VOLT:TRIG | MIN


Programming Examples

We have included several example programs on the Agilent N6700 Product Reference CD-ROM shipped along with your Agilent N6700 Modular Power System. The examples support the following language environments.

  • Microsoft® Visual Basic 6.0

  • Microsoft® Visual C++ 6.0

  • Microsoft® Excel

  • Agilent VEE Pro

You can also download the examples from the Agilent Web site at www.agilent.com/find/N6700.

For your convenience, this Help document contains several Microsoft Visual Basic 6.0 example programs to help you develop programs for your own application. The example programs are for illustration only, and are provided with the assumption that you are familiar with the programming language being demonstrated and the tools used to create and debug procedures.

Output Example

List Example

Digitizer Example


Output Example

Output Programming Example

This is a simple program that sets a voltage, current, over-voltage, and the status of over-current protection. When done, the program checks for instrument error and gives a message if there is an error.

You have a royalty-free right to use, modify, reproduce and distribute this example program (and/or any modified version) in any way you find useful, provided you agree that Agilent Technologies has no warranty, obligations, or liability for any example programs.

This program is written in Microsoft Visual Basic 6.0 using the VISA COM IO library. The VISA COM library must be downloaded from the Automation-Ready CD-ROM to use this program. For information about using VISA COM in another Visual Basic project, refer to “Programming Your Instruments” in the USB/LAN/GPIB Interfaces Connectivity Guide, also included on the Automation-Ready CD-ROM.

Sub output_programming_example()

Dim IDN As String

Dim GPIBaddress As String

Dim ErrString As String

' This variable controls the channel number to be programmed

Dim channel As String

' This variable controls the voltage

Dim VoltSetting As Double

' This variable measures the voltage

Dim MeasureVoltString As String

' This variable controls the current

Dim CurrSetting As Double

' This variable controls the over voltage protection setting

Dim overVoltSetting As Double

'These variables are necessary to initialize the VISA COM.

Dim ioMgr As AgilentRMLib.SRMCls

Dim Instrument As VisaComLib.FormattedIO488

' The following command line provides the program with the VISA name of the

' interface that it will communicate with. It is currently set to use GPIB.

GPIBaddress = "GPIB0::5::INSTR"

' Use the following line instead for LAN communication

' TCPIPaddress="TCPIP0::141.25.36.214"

' Use the following line instead for USB communication

' USBaddress = "USB0::2391::1799::US00000002"

' Initialize the VISA COM communication

Set ioMgr = New AgilentRMLib.SRMCls

Set Instrument = New VisaComLib.FormattedIO488

Set Instrument.IO = ioMgr.Open(GPIBaddress)

' The next three command lines set the voltage, current, and over voltage

VoltSetting = 3

CurrSetting = 1.5 ' amps

overVoltSetting = 10

' This variable can be changed to program any channel in the mainframe

channel = "(@1)" ' channel 1

With Instrument

' Send a power reset to the instrument

.WriteString "*RST"

' Query the instrument for the IDN string

.WriteString "*IDN?"

IDN = .ReadString

' Set the voltage

.WriteString "VOLT" & Str$(VoltSetting) & "," & channel

' Set the over voltage level

.WriteString "VOLT:PROT:LEV " & Str$(overVoltSetting) & "," & channel

' Set current level

.WriteString "CURR " & Str$(CurrSetting) & "," & channel

' Turn on over current protection

.WriteString "CURR:PROT:STAT ON," & channel

' Turn the output on

.WriteString "OUTP ON," & channel

' Wait for previous commands to complete.

.WriteString "*OPC?"

.ReadString

' Measure the voltage

.WriteString "MEAS:VOLT? " & channel

MeasureVoltString = .ReadString

MsgBox "Measured Voltage is " & MeasureVoltString & "At channel" & channel

' Check instrument for any errors

.WriteString "Syst:err?"

ErrString = .ReadString

' give message if there is an error

If Val(ErrString) Then

MsgBox "Error in instrument!" & vbCrLf & ErrString

End If

End With

End Sub


List Example

List Programming Example

This program executes a 10 point current and voltage list. It also specifies 10 different dwell times. When done, the program checks for instrument error and gives a message if there is an error.

You have a royalty-free right to use, modify, reproduce and distribute this example program (and/or any modified version) in any way you find useful, provided you agree that Agilent Technologies has no warranty, obligations, or liability for any example programs.

This program is written in Microsoft Visual Basic 6.0 using the VISA COM IO library. The VISA COM library must be downloaded from the Automation-Ready CD-ROM to use this program. For information about using VISA COM in another Visual Basic project, refer to “Programming Your Instruments” in the USB/LAN/GPIB Interfaces Connectivity Guide, also included on the Automation-Ready CD-ROM.

Sub list_programming_example()

Dim IDN As String

Dim GPIBaddress As String

Dim ErrString As String

Dim channel As String

'These variable are necessary to initialize the VISA COM.

Dim ioMgr As AgilentRMLib.SRMCls

Dim Instrument As VisaComLib.FormattedIO488

' The following command line provides the program with the VISA name of the

' interface that it will communicate with. It is currently set to use GPIB.

GPIBaddress = "GPIB1::5::INSTR"

' Use the following line instead for LAN communication

' TCPIPaddress="TCPIP0::141.25.36.214"

' Use the following line instead for USB communication

' USBaddress = "USB0::2391::1799::US00000002"

' Initialize the VISA COM communication

Set ioMgr = New AgilentRMLib.SRMCls

Set Instrument = New VisaComLib.FormattedIO488

Set Instrument.IO = ioMgr.Open(GPIBaddress)

' These next three strings are the points in the list.

' All three strings are the same length.

' The first one controls voltage, the second current, and the third dwell time

Const voltPoints = "1,2,3,4,5,6,7,8,9,10"

Const currPoints = "0.5,1,1.5,2,2.5,3,3.5,4,4.5,5"

Const dwellPoints = "1,2,0.5,1,0.25,1.5,0.1,1,0.75,1.2"

' This variable can be changed to program any channel in the mainframe

channel = "(@1)" ' channel 1

With Instrument

' Send a power reset to the instrument

.WriteString "*RST"

' Query the instrument for the IDN string

.WriteString "*IDN?"

IDN = .ReadString

' Set the voltage mode to list

.WriteString "VOLT:MODE LIST," & channel

' Set the current mode to list

.WriteString "CURR:MODE LIST," & channel

' Send the voltage list points

.WriteString "LIST:VOLT " & voltPoints & "," & channel

' Send the Current list points

.WriteString "LIST:CURR " & currPoints & "," & channel

' Send the dwell points

.WriteString "LIST:DWEL " & dwellPoints & "," & channel

' Turn the output on

.WriteString "OUTP ON," & channel

' Wait for output to settle in the ON state.

.WriteString "*OPC?"

.ReadString

' Set the trigger source to bus

.WriteString "TRIG:TRAN:SOUR BUS," & channel

' Initiate the transient system

.WriteString "INIT:TRAN " & channel

' Trigger the unit

.WriteString "*TRG"

' Check instrument for any errors

.WriteString "Syst:err?"

ErrString = .ReadString

' give message if there is an error

If Val(ErrString) Then

MsgBox "Error in instrument!" & vbCrLf & ErrString

End If

End With

End Sub


Digitizer Example

Digitizer Programming Example

This program uses the voltage in step mode and also demonstrates how to set up and use the digitizer. When done, the program checks for instrument error and gives a message if there is an error.

You have a royalty-free right to use, modify, reproduce and distribute this example program (and/or any modified version) in any way you find useful, provided you agree that Agilent Technologies has no warranty, obligations, or liability for any example programs.

This program is written in Microsoft Visual Basic 6.0 using the VISA COM IO library. The VISA COM library must be downloaded from the Automation-Ready CD-ROM to use this program. For information about using VISA COM in another Visual Basic project, refer to “Programming Your Instruments” in the USB/LAN/GPIB Interfaces Connectivity Guide, also included on the Automation-Ready CD-ROM.

Sub digitizer_programming_example()

Dim IDN As String

Dim GPIBaddress As String

Dim ErrString As String

Dim channel As String

Dim measPoints As Long

Dim measOffset As Long

Dim VoltSetting As Double

Dim finalVoltage As Double

Dim timeInterval As Double

Dim VoltPoints() As Variant

Dim i As Long

Const WTG_MEAS = 8

Const WTG_TRANS = 16

'These variables are necessary to initialize the VISA COM.

Dim ioMgr As AgilentRMLib.SRMCls

Dim Instrument As VisaComLib.FormattedIO488

' The following command line provides the program with the VISA name of the

' interface that it will communicate with. It is currently set to use GPIB.

GPIBaddress = "GPIB0::5::INSTR"

' Use the following line instead for LAN communication

' TCPIPaddress="TCPIP0::141.25.36.214"

' Use the following line instead for USB communication

' USBaddress = "USB0::2391::1799::US00000002"

' Initialize the VISA COM communication

Set ioMgr = New AgilentRMLib.SRMCls

Set Instrument = New VisaComLib.FormattedIO488

Set Instrument.IO = ioMgr.Open(GPIBaddress)

' This controls the number of points the measurement system measures

measPoints = 100

' This controls the number of points to offset the measurement (positive for

' forward, negative for reverse)

measOffset = 0

' This sets the time between points

timeInterval = 0.0025

' This controls the voltage

VoltSetting = 5

' This is the final voltage that will be triggered

finalVoltage = 10

' This variable can be changed to program any channel in the mainframe

channel = "(@1)" ' channel 1

With Instrument

' Send a power reset to the instrument

.WriteString "*RST"

' Query the instrument for the IDN string

.WriteString "*IDN?"

IDN = .ReadString

' Put the Voltage into step mode which causes it to transition from one

' voltage to another upon receiving a trigger

.WriteString "VOLT:MODE STEP," & channel

' Set the voltage

.WriteString "VOLT" & Str$(VoltSetting) & "," & channel

' Go to final value

.WriteString "VOLT:TRIG" & Str$(finalVoltage) & "," & channel

' Turn the output on

.WriteString "OUTP ON," & channel

' Wait for output to turn on.

.WriteString "*OPC?"

.ReadString

' Set the bus as the transient trigger source

.WriteString "TRIG:TRAN:SOUR BUS," & channel

' Set the number of points for the measurement system to use as an offset

.WriteString "SENS:SWE:OFFS:POIN" & Str$(measOffset) & "," & channel

' Set the number of points that the measurement system uses

.WriteString "SENS:SWE:POIN" & Str$(measPoints) & "," & channel

' Set the time interval between points

.WriteString "SENS:SWE:TINT" & Str$(timeInterval) & "," & channel

' Set the measurement trigger source

.WriteString "TRIG:ACQ:SOUR BUS," & channel

' Initiate the measurement trigger system

.WriteString "INIT:ACQ " & channel

' Initiate the transient trigger system

.WriteString "INIT:TRAN " & channel

' Wait for INITiate commands to complete

Do

.WriteString "STAT:OPER:COND? " & channel

Status = .ReadString

Loop Until (Status And (WTG_MEAS + WTG_TRANS)) = (WTG_MEAS + WTG_TRANS)

' Trigger the unit

.WriteString "*TRG"

' Read back the voltage points

.WriteString "FETC:ARR:VOLT? " & channel

VoltPoints = .ReadList

' Print the first 10 voltage points

For i = 0 To 9

Debug.Print i, VoltPoints(i)

Next i

' Check instrument for any errors

.WriteString "Syst:err?"

ErrString = .ReadString

' give message if there is an error

If Val(ErrString) Then

MsgBox "Error in instrument!" & vbCrLf & ErrString

End If

End With

End Sub


SCPI Error Messages

This is the response to the ERR? query when there are no errors.

You have specified more channels than are installed in the mainframe.

Calibration is not enabled. The instrument will not accept calibration commands.

The calibration password is incorrect.

Calibration mode is locked out by the calibration switch. Refer to the Agilent N6700 Service Guide for more information.

Calibration commands have not been entered in the proper sequence.

The measured output current is outside the acceptable range.

The “zero” measurement value is outside the acceptable range.

The programmed calibration constant is outside the acceptable range.

The measurement calibration constant is outside the acceptable range.

The over voltage calibration constant is outside the acceptable range.

The instrument was unable to set the correct voltage or current value.

Calibration constants on the internal auxiliary local ADC are outside the acceptable range.

Calibration constants on the internal auxiliary remote ADC are outside the acceptable range.

Calibration constants on the internal auxiliary imon ADC are outside the acceptable range.

A hardware error has occurred on the specified channel.

There is an empty slot between modules. This configuration is not allowed.

A selftest failure has occurred. See Self-Test Error list for details.

The requested compatibility function is not available.

A checksum error has occurred in the instrument’s nonvolatile random access memory.

The non-volatile random access memory of the instrument is full.

The internal calibration file or the internal channel attribute file was not found in NVRAM.

The calibration file was written or read using old firmware. Firmware must be updated.

The option that is programmed by this command is not installed.

There is no valid data in the measurement buffer.

Voltage and current cannot be in Step and List mode at the same time.

A triggered value is on a different range than the one that is presently set.

Too many list points have been specified.

One or more lists are not the same length.

Setting cannot be changed while the instrument is waiting for or executing a trigger sequence.

Cannot initiate the transient generator because either the voltage or the current function is set to Fixed mode.

Generic syntax error.

An invalid character was found in the command string.

Invalid syntax was found in the command string. Check for blank spaces.

An invalid separator was found in the command string. Check for proper use of , ; :

A different data type than the one allowed was found in the command string.

A group execute trigger is not allowed in a command string.

More parameters were received than were expected.

Fewer parameters were received than were expected.

An error was detected in the header.

A character that was not a valid header separator was found in the command string.

The header contains more than 12 characters.

A command was received that was not valid for this instrument.

The value of the numeric suffix is not valid.

Generic numeric data error.

An invalid character for the data type was found in the command string.

The magnitude of the exponent was larger than 32000.

The mantissa of a numeric parameter contained more than 255 digits, excluding leading zeros.

A numeric parameter was received but a character string was expected.

Generic suffix error.

A suffix was incorrectly specified for a numeric parameter.

The suffix contains more than 12 characters.

A suffix is not supported for this command.

Generic character data error.

Either the character data element contains an invalid character, or the element is not valid.

The character data element contains more than 12 characters.

A discrete parameter was received, but a string or numeric parameter was expected.

Generic string data error.

An invalid character string was received. Check that the string is enclosed in quotation marks.

A character string was received, but is not allowed for this command.

Generic block data error.

The number of data bytes sent does not match the number of bytes specified in the header.

Data was sent in arbitrary block format but is not allowed for this command.

Generic expression error.

The expression data element was invalid.

Expression data element was sent but is not allowed for this command.

Generic syntax error.

A data element related error occurred.

A data element could not be executed because of the present instrument state.

A data element could not be executed because the value was outside the valid range.

A data element was received that contains more data than the instrument can handle.

An exact value was expected but not received.

The device has insufficient memory to perform the requested operation.

One or more lists are not the same length.

Possible invalid data. A new reading was started but not completed.

The measurement accuracy is suspect.

The data format or structure is inappropriate.

The version of the data format is incorrect to the instrument.

The command could not be executed because of a hardware problem with the instrument.

The command could not be executed because of missing hardware, such as an option.

An expression program data element related error occurred.

An expression program data element could not be executed due to a math error.

Generic error query.

A condition causing an interrupted query error occurred.

A condition causing an unterminated query error occurred.

A condition causing a deadlocked query error occurred.

A query was received in the same program message after a query indicating an indefinite response was executed.

Auxiliary ADC failed. n1 and n2 are the expected limits. n3 is the measured value. n4 is the channel location of the failed module.

Both voltage and current DACs are at zero. n1 and n2 are the expected limits. n3 is the measured value. n4 is the channel location of the failed module.

Voltage DAC is at zero; current DAC is at full scale. n1 and n2 are the expected limits. n3 is the measured value. n4 is the channel location of the failed module.

Voltage DAC is at full scale; current DAC is at zero. n1 and n2 are the expected limits. n3 is the measured value. n4 is the channel location of the failed module.

Both voltage and current DACs are at full scale. n1 and n2 are the expected limits. n3 is the measured value. n4 is the channel location of the failed module.

SCPI Error Messages

Device-Dependent Errors (100...) | Command Errors (-101...) | Execution Errors (-200...) | Query Errors (-400...) | Self-Test Errors (202...)

  • The front-panel ERR annunciator turns on when one or more errors are currently stored in the error queue.

  • Errors are retrieved in first-in-first-out (FIFO) order. The first error returned is the first error that was stored.

  • Errors are cleared as you read them. When you have read all errors from the error queue, the ERR annunciator turns off and the errors are cleared.

  • If more errors have occurred than can fit in the buffer, the last error stored in the queue (the most recent error) is replaced with -350,"Error queue overflow". No additional errors are stored until you remove errors from the queue. If no errors have occurred when you read the error queue, the instrument responds with +0,"No error".

  • The error queue is cleared by the *CLS (Clear Status) command and when power is cycled. The errors are also cleared when you read the error queue. The error queue is not cleared by a Factory Reset (*RST command) or an Instrument Preset (SYSTem:PRESet command).

  • Front-Panel Operation:

    If the ERR annunciator is on, press the Error key to view the errors. Use the navigation keys to scroll through the error list. All errors are cleared when you exit the menu.

  • Remote Interface Operation:

    SYSTem:ERRor?     Reads and clears one error from the queue

    Errors have the following format (the error string may contain up to 80 characters):

    -113,"Undefined header"

Device-Dependent Errors

Device-dependent Errors set Standard Event Status register bit #3 (see STATus Subsystem Introduction).

0 No error

100 Too many channels

101 Calibration state is off

102 Calibration password is incorrect

103 Calibration is inhibited by switch setting

104 Bad sequence of calibration commands

105 Unexpected output current

106 Zero measurement out of range error

107 Programming cal constants out of range

108 Measurement cal constants out of range

109 Over voltage cal constants out of range

110 Wrong V+I

111 Aux vloc cal constants out of range

112 Aux vrem cal constants out of range

113 Aux imon cal constants out of range

200 Hardware error channel <channel>

201 Invalid configuration, empty slots

202 Selftest Fail

203 Compatibility function not implemented

204 NVRAM checksum error

205 NVRAM full

206 File not found

207 Cal file version error

302 Option not installed

303 There is not a valid acquisition to fetch from

304 Volt and curr in incompatible transient modes

305 A triggered value is on a different range

306 Too many list points

307 List lengths are not equivalent

3 08 This setting cannot be changed while transient trigger is initiated

309 Cannot initiate, voltage and current in fixed mode

Command Errors

Command Errors set Standard Event Status register bit #5 (see STATus Subsystem Introduction).

-100 Command error

-101 Invalid character

-102 Syntax error

-103 Invalid separator

-104 Data type error

-105 GET not allowed

-108 Parameter not allowed

-109 Missing parameter

-110 Command header error

-111 Header separator error

-112 Program mnemonic too long

-113 Undefined header

-114 Header suffix out of range

-120 Numeric data error

-121 Invalid character in number

-123 Exponent too large

-124 Too many digits

-128 Numeric data not allowed

-130 Suffix error

-131 Invalid suffix

-134 Suffix too long

-138 Suffix not allowed

-140 Character data error

-141 Invalid character data

-144 Character data too long

-148 Character data not allowed

-150 String data error

-151 Invalid string data

-158 String data not allowed

-160 Block data error

-161 Invalid block data

-168 Block data not allowed

-170 Expression error

-171 Invalid expression data

-178 Expression data not allowed

Execution Errors

Execution Errors set Standard Event Status register bit #4 (see STATus Subsystem Introduction).

-200 Execution error

-220 Parameter error

-221 Settings conflict

-222 Data out of range

-223 Too much data

-224 Illegal parameter value

-225 Out of memory

-226 Lists not same length

-230 Data corrupt or stale

-231 Data questionable

-232 Invalid format

-233 Invalid version

-240 Hardware error

-241 Hardware missing

-260 Expression error

-261 Math error in expression

Query Errors

Query Errors set Standard Event Status register bit #2 (see STATus Subsystem Introduction).

-400 Query Error

-410 Query INTERRUPTED

-420 Query UNTERMINATED

-430 Query DEADLOCKED

-440 Query UNTERMINATED after indefinite response

Self-Test Errors

Self-Test Errors set Standard Event Status register bit #3 (see STATus Subsystem Introduction).

202 Selftest Fail Aux Adc 0 expected <n1> to <n2>, measured <n3>, chan <n4>

2 02 Selftest Fail DACs 0 expected <n1> to <n2>, measured <n3>, chan <n4>

2 02 Selftest Fail DACs 1 expected <n1> to <n2>, measured <n3>, chan <n4>

2 02 Selftest Fail DACs 2 expected <n1> to <n2>, measured <n3>, chan <n4>

2 02 Selftest Fail DACs 3 expected <n1> to <n2>, measured <n3>, chan <n4>


Compatibility

The Agilent N6700 Modular Power System is programmatically compatible with the Agilent 6621A - 6629A DC power supplies. This means that you can program the power system using the same commands that are used to program the Agilent 662xA power supplies.

Agilent 662xA commands ONLY work in Agilent N6700 mainframes that contain combinations of Agilent N675xA or N676xA power modules.

Agilent 662xA commands will NOT work in Agilent N6700 mainframes that contain any Agilent N673xA/B, N674xA/B, or N677xA power modules. This is true even if the mainframes also contain Agilent N675xA or N676xA power modules.

Differences - In General

The following table documents the general differences between the way Compatibility programming commands work on the Agilent N6700 Modular Power System and the way they work on the Agilent 662xA series DC power supplies.

Item | Differences
Queries | The Agilent N67xxA modules will respond to multiple queries. It will not allow a space separator between numbers. It will not allow a user to query information, read back only a portion of the information, send another command, and finish reading back the information from the original query. Sending a second query without reading the response to the first will generate an error. Model number queries will only return the N6700 model number.
Status functions | Serial Poll will be controlled by the SCPI status model and will not act like a 662xA serial poll. SRQ will be controlled by the SCPI status model. Parallel poll will not work. The Agilent N67xxA modules will never set the CC- bit. All other status bits are translated to the closest 662xA bits.
Settings | The full-scale limits will match the Agilent N67xxA module limits. There is no automatic setting adjustment.
Measurement | Measurements use the present settings for points, time interval, etc. Floating point numbers returned by the instrument may not have exactly the same syntax or number of digits.
Calibration | Calibration must be done in SCPI.
Storage states | The Agilent N67xxA modules have 2 non-volatile states and 9 volatile states. The 9 volatile states are only available when using compatibility commands.
Protection functions | OVRST and OCRST will reset all latched protection functions, not just over-voltage or over-current.

Compatibility Command Summary

The following table documents the compatibility commands that the Agilent N6700 Modular Power System supports. All compatibility commands are accepted; however, some commands will generate an error.

Agilent 662xA Command | Description | Similar SCPI Command
ASTS? <ch> | Queries the accumulated status (ASTS) of the specified output channel. The response represents the sum of the binary weights of the ASTS register bits. The ASTS register is automatically set to the present status after being queried. | STAT:OPER:EVEN? STAT:QUES:EVEN? *ESE?
CLR | Returns the entire power system (all outputs) to the power-on state, except the unit is not unaddressed and its store/recall registers are not changed. | *RST
CMODE <on/off> | Generates error -113. The unit must be calibrated using SCPI commands. | see Service Guide
CMODE? | Generates error -113. The unit must be calibrated using SCPI commands. | see Service Guide
DC <ch>, <on/off> | Turns the specified output channel on or off. On/off = 0 turns the channel off; on/off = 1 turns the channel on. | OUTP:STAT
DC? <ch> | Queries whether the specified output channel is on or off. Response is either 1 (on) or 0 (off). | OUTP:STAT?
DCPON <on/off> | Sets the power-on state of the output channels. For on/off = 0, all outputs will be off state when the unit is turned on. For on/off = 1 all outputs will be in the on state when the power system is turned on. This command requires the output power-on state to be set to RCL0. | OUTP:PON:STAT RCL0
DCPON? | Returns a 1 if any channels are set to turn on their output at power on. | OUTP:PON:STAT?
DLY <ch>, <delay> | Sets the reprogramming delay for the specified output channel. This delay is used to mask the CV, CC, CP-, UNR, and other status bits from the fault register and the OCP function for the specified delay period. | OUTP:PROT:DEL
DLY? <ch> | Queries the present reprogramming delay of the specified output channel. | OUTP:PROT:DEL?
DSP <on/off> | Does nothing. | None
DSP? | Always returns a 1. | None
DSP “ xxxxxxxxxxxx” | Does nothing. | None
ERR? | Queries the present programming or hardware error. An error code number is returned over the GPIB to identify the error. | SYST:ERR?
FAULT? <ch> | Queries the fault register of the specified output channel. A bit is set in the fault register when the corresponding bit in both the status and the mask registers. The response is an integer 0 to 255. The fault register is cleared after being read. | STAT:OPER? STAT:QUES? *ESE?
ID? | Queries the model number of the power system. | *IDN?
IDATA <ch>, <Ilo>, <Ihi> | Generates error -113. Unit must be calibrated using SCPI commands. | see Service Guide
IHI <ch> | Generates error -113. Unit must be calibrated using SCPI commands. | see Service Guide
ILO <ch> | Generates error -113. Unit must be calibrated using SCPI commands. | see Service Guide
IOUT? <ch> | Queries the measured output current of the specified output channel. The response is a real number. The front panel display can be used to monitor the measured output current (and voltage) of the selected output channel. | MEAS:CURR?
IRLO <ch> | Generates error -113. | None
IRHI <ch> | Generates error -113. | None
IRLN <ch> | Generates error -113. | None
IRHN <ch> | Generates error -113. | None
IRSET <ch>, <x> | Sets the full-scale current range programming for an output channel. The power system will select the lowest operating range that will contain the value (x). If the present operating current is greater than the full-scale range selected, the present output current will be reduced to the full-scale value of the new range selected. If the current entered is larger than the highest possible range, an error will result. | SENS:CURR:RANG
IRSET? <ch> | Queries the full-scale current range setting of an output channel. | SENS:CURR:RANG?
ISET <ch>, <current> | Sets the current of the specified output channel. | CURR
ISET? <ch> | Queries the present current setting of the specified output channel. The response is a real number. | CURR?
ISTEP <ch>, <x> | Increases or decreases the output channel current in steps. If the step value <x> is positive, output current will increase by the step value, if the step value is negative, the output current will decrease by the step value. Stepping beyond the active operating range causes an error. | LIST:CURR
METER <ch> | Does nothing. | None
METER? | Always returns a 1. | None
OCP <ch>, <on/off> | Enables the over-current protection circuit for the specified output channel. This circuit, when enabled, causes the output to go to the off state when the output is in + CC mode. On/off is a 1 to turn on (enable) or a 0 to turn off (disable) the circuit. | CURR:PROT:STAT
OCP? < ch > | Queries the over-current protection circuit on/off status for the specified output channel. Response is either a 1 (on) or a 0 (off). | CURR:PROT:STAT?
OCRST < ch > | Returns the specified output channel to its previous settings after it has been turned off by a protection shutdown. | OUTP:PROT:CLE
OUT <ch>, <on/off> | Turns the specified output channel on or off. <on/off> equals 1 to turn the output on and equals 0 to turn the output off. | OUTP
OUT? <ch> | Queries whether the specified output channel is turned on or off . The response is either 1 (on) or O (off). | OUTP?
OVCAL <ch> | Generates error -113. Unit must be calibrated using SCPI commands. | see Service Guide
OVRST <ch> | Returns the specified output channel to its previous settings after it has been turned off by a protection shutdown. | OUTP:PROT:CLE
OVSET <ch>, <ovpoint> | Sets the over-voltage trip point for the specified output channel. | VOLT:PROT:LEV
OVSET? <ch> | Queries the present over-voltage setting of the specified output channel. The response is a real number. | VOLT:PROT:LEV?
PON <on/off> | Does nothing. | *SRE
PON? | Always returns a 0. | *SRE?
RCL <reg> | Recalls the settings for all output channels from the specified internal register. These settings were previously stored using the STO command. RCL programs all output channels in sequential order to these stored settings. | *RCL
RELAY <on/off> | Generates error 203. This Option 750 capability is not supported. | None
RELAY? | Generates error 203. This Option 750 capability is not supported. | None
RIRST <ch> | Resets all protection functions for the specified channel. This Option 750 capability is supported. | OUTP:PROT:CLE
ROM? | Queries the revision of the power system's firmware. | *IDN?
SROM? | Queries the revision of the power system's firmware. | *IDN?
SRQ <setting> | Does nothing. | *SRQ
SRQ? | Always returns a 0. | *SRQ?
STO <reg> | Stores the present settings for all output channels in the specified register. These settings can be recalled when desired. | *SAV
STS? <ch> | Queries the present status of the specified output channel. The response represents the sum of the binary weights of the status register bits. | STAT:OPER:COND? STAT:QUES:COND?
TEST? | Always returns a 0. | *TST?
UNMASK <ch>, <setting> | Sets the bits in the mask register of the specified output channel to the setting. The setting is an integer that represents the sum of the binary weights of the bits. The mask register operates in conjunction with the status and fault registers. | STAT:OPER:NTR STAT:OPER:PTR STAT:QUES:NTR STAT:QUES:PTR
UNMASK? <ch> | Queries the present setting of the mask register of the specified output channel. The response is an integer from 0 to 255. | STAT:OPER:NTR? STAT:OPER:PTR? STAT:QUES:NTR? STAT:QUES:PTR?
VDATA <ch>, <Vlo>, <Vhi> | Generates error -113. Unit must be calibrated using SCPI commands. | see Service Guide
VHI <ch> | Generates error -113. | None
VLO <ch> | Generates error -113. | None
VMUX? <ch>, <input> | Generates error -113. | None
VOUT? <ch> | Queries the measured output voltage of the specified output channel. The response is a real number. The front panel display can be used to monitor the measured output voltage (and current) of the selected output channel. | MEAS:VOLT?
VRLO <ch> | Generates error -113. | None
VRHI <ch> | Generates error -113. | None
VRSET <ch>, <x> | Sets the full-scale voltage range programming for an output channel. The power system will select the lowest operating range that will contain the value (x). If the present operating voltage is greater than the full-scale range selected, the present output voltage will be reduced to the full-scale value of the new range selected. If the voltage entered is larger than the highest possible range, an error message will result. | None
VRSET? <ch> | Queries the full scale voltage range setting of an output channel. | None
VSET <ch>, <voltage> | Sets the voltage of the specified output channel. | VOLT
VSET? <ch> | Queries the present voltage setting of the specified output channel. The response is a real number. | VOLT?
VSTEP <ch>, <x> | Increases or decreases the output channel voltage in steps. If the step value < x > is positive, output voltage will increase by the step value, if the step value is negative, the output voltage will decrease by the step value. Trying to step beyond the operating range will cause a number range error. | LIST:VOLT


Autoranging Modules

Agilent models N6751A and N6752A.


Condition Register

A condition register continuously monitors the state of the instrument. The bits in the condition register are updated in real time and the bits are not latched or buffered.


DC Power Modules

Agilent models N6731B - N6736B; N5741B - N6746B; N6773A - N6776A


Enable Register

An enable register defines which bits in the event register will be reported to the Status Byte register group. You can write to or read from an enable register.


Error Queue

The Error Queue is a first-in, first-out (FIFO) data register that stores power system's error messages until the controller reads them. Whenever the queue holds one or more bytes, it sets the ERR bit (2) of the Status Byte register.


Event Register

An event register latches the various events from the condition register. There is no buffering in this register; while an event bit is set, subsequent events corresponding to that bit are ignored. This is a read-only register.


MSS Bit

MSS is a real-time (unlatched) summary of all Status Byte register bits that are enabled by the Service Request Enable register. MSS is set whenever the power system has one or more reasons for requesting service. *STB? reads the MSS in bit position 6 of the response but does not clear any of the bits in the Status Byte register.


Operation Status Group

The Operation Status registers record signals that occur during normal operation. The group consists of a Condition, PTR/NTR, Event, and Enable register. The outputs of the Operation Status register group are logically-ORed into the OPERation summary bit (7) of the Status Byte register.


Output Queue

The Output Queue is a first-in, first-out (FIFO) data register that stores power system-to-controller messages until the controller reads them. Whenever the queue holds one or more bytes, it sets the MAV bit (4) of the Status Byte register.


Precision Modules

Agilent models N6761A and N6762A.


Questionable Status Group

The Questionable Status registers record signals that indicate abnormal operation. The group consists of the same register types as the Status Operation group. The outputs of the Questionable Status group are logically-ORed into the QUEStionable summary bit (3) of the Status Byte register.


RQS Bit

The RQS bit is a latched version of the MSS bit. Whenever the power system requests service, it sets the SRQ interrupt line true and latches RQS into bit 6 of the Status Byte register. When the controller does a serial poll, RQS is cleared inside the register and returned in bit position 6 of the response. The remaining bits of the Status Byte register are not disturbed.


Standard Event Status Group

The Standard Event registers are programmed by Common commands. The Standard Event event register latches events relating to communication status. It is a read-only register that is cleared when read. The Standard Event enable register functions similarly to the enable registers of the Operation and Questionable status groups.


Status Byte Register

This register summarizes the information from all other status groups as defined in the IEEE 488.2 Standard Digital Interface for Programmable Instrumentation.


Note_Caution_Warning Template

Caution Warning Note

Use the Caution, Warning, and Note examples from this page in your own HTML Help project. Just copy and paste.

Type note text here.

Type caution text here. If you go on and on, you can just keep going and going and going, like this.

Type warning text here.

If you prefer creating your own Caution, Warning, and Note entries, here's how:

  1. Create a two-cell table.

  2. Select it by moving your cursor a few pixels off the left end of the table until you see a left-pointing arrow. Then click. (If you select the table by choosing Table > Select Table, the rest of this procedure does not work.)

  3. Choose Format > Borders and Shading.

  4. For Border Width, enter 0 px. Then click OK.

  5. Insert the Caution, Warning, or Note graphic into the left cell in the table.

  6. Drag the divider between the two cells as far to the left as you can.